Débugage site WordPress , problème de javascript / médias (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #2356744
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.11  / 10.3.25-MariaDB
    • Thème utilisé :  Bellevue
    • Extensions en place :
    • Nom de l’hébergeur : o2switch ou OVH (même problème)
    • Adresse du site : temporaire pour test  https://chateaulequesnoy.njweb.fr/

    Problème(s) rencontré(s) :

    Bonjour, je débute sur wordpress, je connais mieux Joomla.

    Je cherche à dépanné un site qui n’avait pas été suivit depuis longtemps.

    Je l’ai sauvegarder et remonté sur mon serveur pour test (via Akeeba), j’ai effectué toute les maj. moteur 5.5.1 et extentions

    Le site est fonctionnel mais impossible d’utiliser la fonction Media.

    J’ai donc fait des recherches :

    • en premier lieu désactivation de toute les extensions : idem
    • ensuite j’ai voulu insérer la ligne “define(‘CONCATENATE_SCRIPTS’, false );” dans le wp-config.php mais cela rend le panneau d’administration hors de service (que des liens apparents, voir capture jointe)
    • Du coup j’ai voulu activer le mode debug toujours via wp-config.php  > idem, panneau d’administration HS

    Donc, je ne peux intervenir sur le wp-config.php c qui est embêtant !

     

    Avez vous une idée ?

     

    Merci par avance

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2356841
    momofr@free.fr
    Modérateur
    Maître WordPress
    3749 contributions

    Salut, avec un configuration clean tu dois regarder la console d’erreur de ton navigateur pour voir les erreurs tracées lors de l’utilisation de l’admin et de ta fonction média (déjà on ne sait pas à quel moment tu as un souci).

    Selon ce qui sera affiché tu sauras si c’est un souci JS ou de droits d’utilisation.

    #2356988
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    Bonjour et merci pour ton aide.

    Je ne suis pas calé du tout en JS, j’ai ouvert la console FF, cliquez sur le bouton “Ajouter un media”  sur une page , mais après je ne sais ou aller et quoi faire 🙁

     

    Pour les droits, j’ai vérifier les CHMOD sans rien voir d’anormal.

    Ce qui est bizarre aussi c’est dès que je veux changer une ligne dans le wp-config.php mais cela rend le panneau d’administration hors de service (que des liens apparents, plus d’interface)

     

     

    #2357000
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    Je viens de voir, même le bouton “réduire le menu” ne fonctionne pas donc ce n’est pas uniquement un problème de média…

    #2357011
    momofr@free.fr
    Modérateur
    Maître WordPress
    3749 contributions

    Salut, c’est un problème JS à priori. Tu utilises quel navigateur ?

    Tu dois voir les erreurs dans la console du navigateur, on ne peut pas le faire à ta place.

    #2357013
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    j’ai essayé avec Firefox, Chrome et Edge… c’est pareil, je vais rechercher les erreurs

    #2357014
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions
    Uncaught TypeError: a.browser is undefined
    chosen http://chateaulequesnoy.njweb.fr/wp-content/plugins/bellevue-shortcodes/js/chosen.js?ver=1.1:10
     http://chateaulequesnoy.njweb.fr/wp-content/plugins/wp-booking-system/js/wpbs-admin.js?ver=5.5.1:48
    jQuery 4
    Uncaught TypeError: s is undefined
    http://chateaulequesnoy.njweb.fr/wp-includes/js/wp-auth-check.min.js?ver=5.5.1:2
    jQuery 7
    xhr http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    jQuery 4
    Uncaught TypeError: s is undefined
     http://chateaulequesnoy.njweb.fr/wp-includes/js/wp-auth-check.min.js?ver=5.5.1:2
    jQuery 7
    xhr http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    jQuery 6
    l http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    beatTimer http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    setTimeout handler*d http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    v http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    h http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    p http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2
    jQuery 8
    p http://chateaulequesnoy.njweb.fr/wp-includes/js/heartbeat.min.js?ver=5.5.1:2

    • Cette réponse a été modifiée le il y a 4 semaines par momofr@free.fr. Raison: Ménage
    #2357015
    pasglop
    Participant
    Chevalier WordPress
    147 contributions

    Par curiosité, as-tu installé et activé Enable Jquey Migrate Helper ?

    • Cette réponse a été modifiée le il y a 4 semaines et 1 jour par pasglop.
    #2357023
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    Bonjour Pasglop,

     

    non, en tout cas je ne le trouve pas dans les extensions activés ou pas. (j’ai récupérer ce site déjà en ligne depuis quelques années)

    J’ai essayé de désactiver toutes les extensions sans changement d’ailleurs.

    #2357037
    momofr@free.fr
    Modérateur
    Maître WordPress
    3749 contributions

    Salut, je pense que tu as des extensions un peu “antiques”, installe et active Enable jQuery Migrate Helper.

    #2357042
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    Hello, Je pense aussi que certaines extensions dataient… j’ai pourtant fait toute les mises à jours…

     

    Je viens d’effectuer l’installation de  Enable jQuery Migrate Helper….  mais ça m’a planté l’admin à l’activation (comme quand je touche à  wp-config.php) j’ai fait une capture

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2357053
    momofr@free.fr
    Modérateur
    Maître WordPress
    3749 contributions

    Salut, avec “30 66030 660 commentaires en modération” tu as déjà un souci, il faudrait faire le ménage dans ta base de données.

    Pour cela j’utilise WP Cleaner, vide tout, révisions, transients.

    Ne sachant pas ce que tu as fait dans ton fichier wp-config.php ce n’est pas évident de savoir ce qui peut coincer, je referais ce fichier de A à Z avec tes identifiants SQL (à partir de wp-config-sample.php).

    #2357062
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    merci je vais faire ça…

    c’est le problème de récupérer un site qui n’a pas été suivit depuis longtemps

    #2357096
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    Ne sachant pas ce que tu as fait dans ton fichier wp-config.php ce n’est pas évident de savoir ce qui peut coincer, je referais ce fichier de A à Z avec tes identifiants SQL (à partir de wp-config-sample.php).

     

    fait, aucun changement, je remonte une sauvegarde et essaye WP Cleaner, a suivre

    #2357108
    nicolasnjw
    Participant
    Initié WordPress
    13 contributions

    alors, le nettoyage a fait du bien, même si c’est pas encore ça.. mais j’ai accès à la Mediatheque si je désactive le Plugin  “Bellevue Shortcodes” le bouton ajouter un media ne fonctionne toujours pas, mais ça progresse.

    a suivre

    • Cette réponse a été modifiée le il y a 4 semaines par nicolasnjw.
15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.