[Résolu] Ajout de « index.php » dans les URLs des pages

Suite à la migration du forum, chaque utilisateur devra lancer une procédure de réinitialisation du mot de passe pour pouvoir se connecter. Merci !

  • WordPress :4.7
  • Statut : résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #1647227

    slackito
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de WP : 4.7.5
    • Version de PHP/MySQL : PHP 5.6.30/MySQL 5.5
    • Thème utilisé : Customizr pro
    • Extensions en place : simply static (qui ne fonctionne pas correctement…)
    • Nom de l’hébergeur : NA (dev local)
    • Adresse du site : NA (dev local)

    Problème(s) rencontré(s) : Ajout de « index.php » dans les URLs des pages

    Par défaut, il y a un ajout de « index.php » dans les URLs vers les pages entr’autre dans les menus). J’ai regardé dans  le menu admin « settings >> permalink » sans succès. Il semble que le sujet ait déjà été traité sur ces forums dans ce sujet  (dont j’ai trouvé le lien via cet autre sujet  ) mais il a apparemment été effacé. Je suis preneur de toute info à ce sujet. Cet ajout de « index.php » dans l’URL est vraiment très bizarre comme comportement par défaut…

    Merci d’avance

     

    • Ce sujet a été modifié le il y a 1 semaine et 1 jour par  slackito.
    • Ce sujet a été modifié le il y a 6 jours et 17 heures par  Flobogo. Raison: déplacé en rubrique "support"
    #1647230

    slackito
    Participant
    Initié WordPress
    7 contributions

    Problème résolu : j’avais mal regardé les options dans les permalinks. Une fois mises à jour, tout est rentré dans l’ordre.

    Par défaut, « index.php » est ajouté.

    #1647232

    slackito
    Participant
    Initié WordPress
    7 contributions

    Mmmmmhhhhhh….

    En fait, le problème est à moitié résolu : les « index.php » ont disparu des URLs mais depuis, j’ai des 404 lorque je clicke sur ces nouvelles URLs….

    Pour info,  dans settings>>permalinks, j’ai essayé de cocher:

    1/ Post name

    2/ custom structure puis http://localhost/wordpress2/%postname%/

    Même comportement : URLs correctes mais 404 après click sur les liens.

    • Cette réponse a été modifiée le il y a 1 semaine et 1 jour par  slackito.
    #1647234

    slackito
    Participant
    Initié WordPress
    7 contributions

    Pour info (et je subodore que le problème se trouve par là). VOilà mon .htaccess et les rewrite rules qui ne semblent pas avoir changé :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress2/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress2/index.php [L]
    </IfModule>

    # END WordPress

    Wordpress n’est-il pas sensé mettre ces règles à jours suite aux changements dans les options de permalinks de l’admin ?!

     

    #1647235

    slackito
    Participant
    Initié WordPress
    7 contributions

    Résolu (merci gogole) : https://wordpress.stackexchange.com/questions/211351/404-with-post-name-permalinks

    En espérant que ça aidera d’autres utilisateurs de WP

    #1647271

    Flobogo
    Modérateur
    Maître WordPress
    12769 contributions

    Bonjour,

    Au final, c’était un problème de configuration Apache sur votre serveur personnel, si je comprends bien.

    En général, quand des utilisateurs ont ce problème de /index.php/, c’est parce que OVH l’inclus dans les URL des installation avec le module « en une clic » (pourquoi ? Mystère 🙄 Peut-être lié à ce problème de config’ Apache 😕 )

    En tous cas, l’une des solutions consiste à modifier toutes les URL dans la base de données à l’aide du script search and replace db (selon ce tuto)

    #1647334

    slackito
    Participant
    Initié WordPress
    7 contributions

    Bonjour Flobogo,

    Merci pour cette précision qui, je l’espère, aidera d’autres utilisateurs d’ovh. J’avoue ne pas avoir été très précis dans les explications de ce long monologue. Je vais essayer d’y remédier.

    Le problème d’ajout de « index.php »venait de la conf WP de l’option relative aux permalinks. Par défaut (custom structure), les URLs contenaient « index.php ».

    Une fois cette dernière option changée pour « page name », toutes les URLs étaient correctes (sans « index.php »).

    Maljeureusement, cela a mené à des problèmes de 404 pour toutes les URLs. Cela effectivement dû à une mauvaise configuration du serveur apache. La page sur stackoverflow explique la marche à suivre pour modifier la conf apache et ainsi résoudre le problème.

    Par ailleurs, serait-il possible de déplacer ce sujet en retirant la référence à customizr dans le le titre ? En effet, il n’a aucun rapport avec le thème utilisé. Désolé, je débute sur WP….

     

    • Cette réponse a été modifiée le il y a 1 semaine par  slackito.
    #1647434

    Flobogo
    Modérateur
    Maître WordPress
    12769 contributions

    La page sur stackoverflow explique la marche à suivre pour modifier la conf apache et ainsi résoudre le problème

    –> Ce qui est possible sur votre propre serveur, que vous gérez vous-même, mais pas chez OVH.

    cela a mené à des problèmes de 404 pour toutes les URLs

    –> Et c’est là que le script search and replace db intervient, afin de modifier toutes les URL en base de données … et les erreurs 404 disparaissent.

    Par ailleurs, serait-il possible de déplacer ce sujet en retirant la référence à customizr dans le le titre ? En effet, il n’a aucun rapport avec le thème utilisé.

    –> pas de souci, je fais le nécessaire. Merci d’avoir partagé la solution du slack qui sera utile à ceux qui gèrent leur propre serveur 🙂

    #1647613

    slackito
    Participant
    Initié WordPress
    7 contributions

    Un GRAND merci, Flobogo,  pour avoir déplacé ce sujet et pour les éclaircissements différenciant mon cas particulier (serveur géré par moi même) et le cas général (hébergement OVH mutualisé). Cela aurait effectivement pu induire en erreur les utilisateurs d’OVH.

    Encore une fois merci et longue vie à ce forum qui m’est très utile sur de nombreux plans !

    • Cette réponse a été modifiée le il y a 4 jours et 18 heures par  slackito.
    #1647693

    Flobogo
    Modérateur
    Maître WordPress
    12769 contributions

    De rien 🙂

     

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.