[Résolu] Customiser une liste d’articles

  • WordPress :4.7
  • Statut : résolu
15 sujets de 16 à 30 (sur un total de 33)
  • Auteur
    Messages
  • #1640055

    stremblaym
    Participant
    Chevalier WordPress
    112 contributions

    Modifie un peut ton code pour mettre des quote dans un :before et un :after

    Ensuite, regarde ici, https://wpfr.net/support/sujet/balise-lire-la-suite-dans-ajout-dun-article/#post-1637909 c’est pas un content.php c’est plutot un custom code pour afficher des articles dans mon front-page.php avec chaque élément de façon séparé. Bien sur il y a pas tous les éléments donc si tu as des questions hésite pas. Il y a quelque petit truc a changer comme le new WP_Query, a effacé completement

    #1640068

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    ok mais ce serait possible que tu mettes des commentaires sur ton code?

    car là comme ça j’avoue que je ne le comprends pas du tout :-/
    aurais tu une capture d’écran de ce que ça doit donner?

    #1640070

    stremblaym
    Participant
    Chevalier WordPress
    112 contributions

    En gros, l’idée c’est ça: Pièce jointe.

    Mais là je vais aller te faire un petit code perso sur un site teste. Je vais t’envoyer le lien, on va paufiner et après je t’explique. Comme ça je vais être au même niveau que toi avec content-quote.php

    Tu vas comprendre au fil du temps que le principe pour call des articles, des pages et des custom post est pareil. Peut importe où tu veux l’ajouter. Simplement, quand on est pas sur une page prédifinie pour le sujet,  il faut mettre un new WP_Query pour specifier qu’est-ce que nous affichons.

     

    • Cette réponse a été modifiée le il y a 4 mois et 3 semaines par  stremblaym.
    • Cette réponse a été modifiée le il y a 4 mois et 3 semaines par  stremblaym.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1640338

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    Re!!

    désolée je t’ai pas répondu avant car j’ai pas eu le temps de travailler sur le site hier.
    Je vais regarder tranquillement ton exemple aujourd’hui

    je suis très intéressée par ton lien sur ton site de test, hésite pas à me l’envoyer quand c’est prêt.
    En attendant je regarde ton code, merci encore!

    #1640341

    stremblaym
    Participant
    Chevalier WordPress
    112 contributions

    Salut, je suis en train de monter un petit site teste ou l’accueil affiche des tutoriel et où j’ai des lien priver pour l’entraide comme toi et moi, je vais revenir d’ici la fin de la fin de semaine avec un petit outil pour vous apporter de l’aide 🙂 Simplement dire que je ne t’oublie pas.

    #1640563

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    Bonjour à tous,

    @flobogo

    Remarque suite à mon coup d’œil au site en ligne : tu as créé le thème-enfant, ok, c’est très bien. Mais il faut mettre tout ton CSS personnalisé dans ton fichier style.css (à la suite de ce qui y est déjà de base), parce que là, tout le code CSS additionnel est visible dans le code-source (donc, chargé sur chaque page), ce qui est parfaitement inutile.

    concernant mon thème enfant, je n’ai pas réussi à le faire seule smiley j’ai utilisé le plugin advanced twentyseventeen

    effectivement j’avais remarqué qu’il y avait un truc pas clair avec le css, car dans le dossier de ce theme enfant, je ne vois pas de fichier css.
    Pour modifier le css, je vais directement dans le costumizer, à l’intérieur de l’admin wordpress (pratique par rapport à l’affichage à la volée)

    Concernant ta remarque, j’ai créé un fichier .css à la racine de mon thème enfant. Puis j’ai copié tout le code que j’avais mis dans l’admin wordress (et supprimé ce dernier). Mais là je vois bien que ce fichier css n’est pas pris en compte.

    A vrai dire, si j’ai installé ce plugin, c’est parce que je n’avais pas réussi à m’en sortir sur le fichier css. Je n’avais pas réussi à faire en sorte que soient pris en compte à la fois le css du thème, et à la fois celui du thème enfant.

    que dois-je faire pour parer au problème que tu as souligné?

    #1640564

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    NB : j’ai aussi essayer de copier intégralement le fichier css d’origine.
    puis je l’ai collé dans mon thème enfant. J’ai ensuite ajouté au code, tout ce que j’avais dans l’admin wordpress.

    résultat : certains trucs sont pris en compte et d’autres pas

    #1641248

    Flobogo
    Modérateur
    Maître WordPress
    13411 contributions

    Désolée, j’étais en vacances sans accès Internet, me revoici 😉

    Concernant le thème-enfant : je ne connais pas l’extension advanced twentyseventeen mais elle semble permettre d’ajouter des éléments à TwentySeventeen, peut-être par le biais d’un thème-enfant, je ne sais pas. Pourtant j’ai vu dans le code source  qu’il y a un fichier de style d’un thème-enfant.

    Franchement, ce n’est pas très compliqué de le créer. Tu peux suivre ce tuto très complet : https://wpmarmite.com/child-theme-wordpress/

    Si vraiment tu n’y arrives pas, utilise une de ces extensions :

     

    #1642478

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    Bonsoir à tous,

    Il me semble que mon thème enfant est correct, si quelqu’un veut bien confirmer?!

    en revanche j’ai un problème, en copiant tout ce que j’avais mis dans le « customizer » dans le fichier css du theme enfant, j’ai perdu quelques styles.
    Il semble que mes titres aient été surclassés.

    notamment ceux-ci :

    .colors-dark.page:not(.twentyseventeen-front-page) .entry-title,

    du coup sur cette page, mon titre est redevenu blanc (theme twentyseventeen) et mon css du theme enfant ne le modifie pas (je le voulais orange)

    que dois-je faire sans hack?

    • Cette réponse a été modifiée le il y a 4 mois et 1 semaine par  wordpresseuse.
    #1642490

    Flobogo
    Modérateur
    Maître WordPress
    13411 contributions

    Il me semble que mon thème enfant est correct, si quelqu’un veut bien confirmer?!

    Non, le début du fichier style.css est incorrect ! Il doit absolument commencer comme indiqué dans le tuto :

    /*
     Theme Name:   Mon thème enfant
     Theme URI:    (adresse de votre site)
     Description:  Description de mon thème enfant
     Author:       vous
     Template:     twentyseventeen
     Version:      1.0.0
    */

    Et vous virez ces lignes, qui ne servent à rien dans le fichier style.css du thème-enfant :

    /*
    You can add your own CSS here.

    Click the help icon above to learn more.
    */

    #1642843

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    Bonsoir Flobogo,

    merci pour ce conseil, ça y est c’est fait!
    mon thème enfant est-il maintenant conforme?

    Pour mon problème de couleur perdue, je ne comprends pas pourquoi mes h1.entry-title sont surclassés.
    Du coup j’ai mis des !important un peu partout et ça a l’air de marcher :s

    @stremblaym : des nouvelles de ton petit tuto/test?

    #1642863

    Flobogo
    Modérateur
    Maître WordPress
    13411 contributions

    Salut,

    Oui, cette fois le thème-enfant semble bien installé.

    Pour mon problème de couleur perdue, je ne comprends pas pourquoi mes h1.entry-title sont surclassés.
    Du coup j’ai mis des !important un peu partout et ça a l’air de marcher

    –> C’est exactement ce qu’il faut faire, j’allais te le dire hier soir et j’ai oublié.

    #1643040

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    Super, je te remercie pour ta confirmation !!

    Voilà, concernant le sujet de départ, avant de clore le sujet, j’ai un nouveau problème.

    Tout allait bien dans le meilleurs des mondes jusqu’à ce que j’ajoute une image à la une à mes quotes.
    J’en ai en effet besoin pour illustrer une petite grille.

    du coup j’ai perdu tout mon texte! (je confirme que si je vire l’image à la Une ça marche très bien)
    Voici le lien

    pour récapituler, l’affichage est définit dans mon content-quote.php
    le voici :

    <?php
    /**
     * Template part for displaying QUOTE posts
     *
     * @link https://codex.wordpress.org/Template_Hierarchy
     *
     * @package WordPress
     * @subpackage Twenty_Seventeen
     * @since 1.0
     * @version 1.0
     */
    ?>
    
    <article id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    	<?php
    		if ( is_sticky() && is_home() ) :
    			echo twentyseventeen_get_svg( array( 'icon' => 'thumb-tack' ) );
    		endif;
    	?>
    	<header class="entry-header">
    		<?php
    			if ( 'post' === get_post_type() ) :
    				echo '<div class="entry-meta">';
    						echo twentyseventeen_edit_link();
    				echo '</div><!-- .entry-meta -->';
    			endif;
    		?>
    	</header><!-- .entry-header -->
    
    	/*<?php if ( '' !== get_the_post_thumbnail() && ! is_single() ) : ?>
    		<div class="post-thumbnail">
    			<a href="<?php the_permalink(); ?>">
    				<?php the_post_thumbnail( 'twentyseventeen-featured-image' ); ?>
    			</a>
    		</div><!-- .post-thumbnail -->
    	<?php endif; ?>*/
    
    	<div class="entry-content">
    
    		<?php if ( is_single() || '' === get_the_post_thumbnail() ) :
    
    			// Only show content if is a single post, or if there's no featured image.
    			/* translators: %s: Name of current post */
    			the_content( sprintf(
    				__( 'Continue reading<span class="screen-reader-text"> "%s"</span>', 'twentyseventeen' ),
    				get_the_title()
    			) );
    
    			wp_link_pages( array(
    				'before'      => '<div class="page-links">' . __( 'Pages:', 'twentyseventeen' ),
    				'after'       => '</div>',
    				'link_before' => '<span class="page-number">',
    				'link_after'  => '</span>',
    			) );
    
    		endif; ?>
    	</div><!-- .entry-content -->
    	
    	
    	
    	<?php if ( is_single() ) : ?>
    		<?php twentyseventeen_entry_footer(); ?>
    	<?php endif; ?>
    
    </article><!-- #post-## -->

    j’ai essayé de bidouiller et d’enlever des lignes mais ça ne marche pas 🙁

    help!

     

     

    #1643075

    Flobogo
    Modérateur
    Maître WordPress
    13411 contributions

    Et tu peux nous (re)donner le code qui fonctionnait sans les images ?

    #1643088

    wordpresseuse
    Participant
    Padawan WordPress
    65 contributions

    c’est ce code là, celui que j’ai posté

    si tu veux j’enlève une image pour te montrer ce que ça donne
    toujours ici

     

    • Cette réponse a été modifiée le il y a 4 mois par  wordpresseuse.
15 sujets de 16 à 30 (sur un total de 33)
  • Vous devez être connecté pour répondre à ce sujet.