Custom Taxonomy & Gutenberg (Créer un compte)

  • WordPress :4.9.9
  • Statut : non résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2195638
    chezmat
    Participant
    Chevalier WordPress
    183 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.5 / 5.5
    • Thème utilisé : twenty fourteen customisé
    • Extensions en place :
    • Nom de l’hébergeur : easy-hebergement
    • Adresse du site : http://geekroniques.fr

    Problème(s) rencontré(s) : J’utilise un nombre important de custom taxonomy sur mon site. En testant Gutenberg, j’ai vu qu’elles ne s’affichaient pas dans la barre de droite lors de la rédaction d’articles, sauf à mettre ‘show_in_rest’ => true, dans la déclaration de mes taxonomy.

    Ce que j’ai fait pour toutes mes custom taxonomy. Mais seulement certaines s’affichent et d’autres pas. J’ai mis à jour mes permaliens, désactivé, puis réactivé gutenberg. Rien n’y fait, certaines taxnomy ne s’affichent toujours pas. Et j’avoue que je ne comprends pas la différence de comportement alors que j’ai fait la même chose pour toutes.

    Quelqu’un à une idée?

    Merci!

    • Ce sujet a été modifié le il y a 2 années et 2 mois par chezmat. Raison: MAJ SQL
    #2196763
    Flobogo
    Modérateur
    Maître WordPress
    16343 contributions

    Bonjour,

    Sur ce forum, nous avons peu de questions (et d’ailleurs, peu de compétences) au sujet de Gutenberg, qui est encore en phase de “finalisation” et n’est pas installé par tous.

    Je vous invite à poser votre question dans le support de cette extension : https://wordpress.org/support/plugin/gutenberg

    Vous aurez plus de chances d’y recevoir une réponse précise et adaptée.

    #2196971
    Li-An
    Modérateur
    Maître WordPress
    24375 contributions

    Bonjour, c’est un problème référencé ici https://github.com/WordPress/gutenberg/issues/3369 vaguement résolu par l’ajout d’un code (lire la discussion). Comme semble-t-il beaucoup de problèmes liés à Gutenberg, les réponses données par l’équipe sont évasives et on ne peut qu’espérer que ce sera corrigé à la sortie définitive.

    #2196975
    Li-An
    Modérateur
    Maître WordPress
    24375 contributions

    Pour un peu plus de précision : https://chezmat.fr/gutenberg-et-les-customs-posts-taxonomy

    #2197292
    chezmat
    Participant
    Chevalier WordPress
    183 contributions

    Merci à tous pour vos retours.

    Ce qui me rend dingue, c’est que la solution ne marche que partiellement.

    J’arrive malgré tout à modifier ces taxonomy en mode “modification rapide”, mais je trouve ça hyper agaçant. Et oui, le problème est remonté depuis presque un an à wordpress qui ne fait pas grand chose…

    #2197293
    Li-An
    Modérateur
    Maître WordPress
    24375 contributions

    Gutenberg est un gros morceau et ils courent dans tous les sens en colmatant les fuites. Installez Classic Editor en attendant une éventuelle mise à jour qui corrigera ça.

    #2197450
    Flobogo
    Modérateur
    Maître WordPress
    16343 contributions

    Merci à vous 2 des précisions apportées sur la solution et le problème soulevé par cette question.

    Je pense que les questions sur l’utilisation de Gutenberg (et ses bugs) s’intensifieront ici lorsqu’il sera inclus dans la v 5.0

     

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.