CSS: positionnement relatif & absolu d’une image (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 8 réponses, 2 participants et a été mis à jour pour la dernière fois par Fran6, le il y a 13 années.
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #453849
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress :2.2.2
    – Thème utilisé :Sandbox
    – Plugins en place :
    – Nom de l’hebergeur : OVH
    – Adresse du site :

    Problème(s) rencontré(s) :

    Hello,

    J’ai un petit problème pour donner une source d’image à mon template single.php… En fait, j’utilise un plugin qui me permet d’inclure ce que les US appelent des “post_icons”, donc donner une icone pour chaque article. Pour ce faire j’utilise les custom fields. Il suffit d’entrer le nom de l’image et elle apparaît où l’on veut. Enfin bref, mon souci c’est que quand je demande d’aller chercher la photo via un chemin relatif du style “/images/posticons/…”, il ne m’affiche rien, alors que quand je le fais via un chemin absolu, donc http://etc… tout se passe bien. J’ai vraiment tout essayé. J’ai même mis la photo directement au même niveau que le template et donc img src=”photo.gif” mais rien ne s’affiche…

    est-ce que c’est normal docteur ? J’ai loupé un truc ?

    Merci d’avance pour votre aide !! 😉

    #608796
    alakhnor
    Participant
    Maître WordPress
    996 contributions

    En général, on utilise une fonction d’info de WP suivant l’emplacement des fichiers :

    <link rel="shortcut icon" href="/images/favicon.ico” />

    ou bien

    #608797
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Merci Alakhnor,

    En fait mon code est sous cette forme ci:

    <img alt="post icon" class="posticon" src="http://www.xxx.com/blog/wp-content/themes/sandbox/images/posticons/icon.gif" />

    Je ne vois pas trop comment introduire ce genre de requête là-dedans. Tout ce que j’ai tenté ne fonctionne pas… 😉

    Merci d’avance !

    Francis

    #608798
    alakhnor
    Participant
    Maître WordPress
    996 contributions

    Tu as essayé :

    <img alt="post icon" class="posticon" src="/images/posticons/icon.gif” />

    ?

    #608799
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Oui mais ça me donne ça:

    Parse error: syntax error, unexpected T_STRING in …..

    #608800
    alakhnor
    Participant
    Maître WordPress
    996 contributions

    En recopiant mon code ça te donne cette erreur ?

    Tu peux montrer un bout du code autours de ça pour voir ?

    #608801
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Bien sûr !

    <?php echo c2c_get_custom('post_icon', '<img alt="post icon" class="posticon" src="http://www.xxx.com/blog/wp-content/themes/sandbox/images/posticons/', '.gif" />‘, ‘blank’); ?>

    En fait, c’est l’utilisation d’un plugin qui permet l’insertion d’une photo dans l’article sur la home en saisissant son nom au niveau du custom field…

    #608802
    alakhnor
    Participant
    Maître WordPress
    996 contributions

    Ah bah oui, ça pouvait pas marcher comme ça. 😉

    <?php echo c2c_get_custom('post_icon', '<img alt="post icon" class="posticon" src="'.get_bloginfo('template_directory').'/images/posticons/', '.gif" />‘, ‘blank’); ?>

    #608803
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Ah ben oui con !!! (c’est de moi que je parle là !! :D ) Qu’est-ce que ça me prend la tête le php…. pouloulou…. bon je vais tester de ce pas !! merci !

    Edit: Vérifié et validé. Merci Alakhnor, t’es l’plus fort !! 🍺

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.