Correction officielle pour la 2.9

Suite à la migration du forum, chaque utilisateur devra lancer une procédure de réinitialisation du mot de passe pour pouvoir se connecter. Merci !

  • Statut : non résolu
  • Ce sujet a 19 réponses, 9 participants et a été mis à jour par  addy, il y a 7 ans.
15 sujets de 1 à 15 (sur un total de 20)
  • Auteur
    Messages
  • #477150

    Lumiere de Lune
    Participant
    Maître WordPress
    19611 contributions

    http://www.semiologic.com/2009/12/21/wp-2-9-three-bugs-and-how-to-fix-them/

    http://www.lumieredelune.com/encrelune/patch-non-officiel-pour-les-bugs-de-wordpress-2-9,2009,12

    Bonjour,

    Vous trouverez sur ce blog en anglais un fichier zip qui corrige les problèmes majeurs de la mise à jour en v2.9 (non liés à la version de php), c’est à dire :
    1. l’impossibilité de publier des posts dans le futur (et sans doute d’envoyer des mails, ou de planifier des backup)
    2. des problèmes avec les widgets rss, dont on n’a pas eu écho ici.

    Il s’agit d’une solution « utilisateur », suite aux nombreux problèmes, des utilisateurs de wordpress ont laissé tester sur leurs systèmes, et trouvé l’origine des problèmes, qui était en réalité dans des configs serveurs pas mises à jour. (Les techos comprennent suffisamment l’anglais pour lire les détails sur le post, et les autres s’en fichent, donc je ne traduis pas).

    Solution non officielle, mais avec uniquement des retours positifs sur wordpress.org et sur le blog, et intégrée dans le trac pour une prochaine mise à jour si j’ai bien compris.

    Edit : j’ai bien compris, la solution pour les problèmes de posts futurs est d’ores est validée et intégrée dans la 2.9.1

    Ces fichiers n’ont pas d’impact sur la base de données, donc vous pouvez simplement les télécharger, et les mettre dans votre dossier wp-includes en remplacement de ceux qui s’y trouvent déjà (mais gardez toujours un back up des anciens, on ne sait jamais)

    Et un grand bravo à la communauté wordpress 🙂

    #705850

    chamomor
    Participant
    Maître WordPress
    1914 contributions
    #705851

    Lumiere de Lune
    Participant
    Maître WordPress
    19611 contributions

    Oui 🙂

    ou tout simplement de passer à la 2.9.1 qui intègre ces corrections

    #705852

    itamaso
    Membre
    Initié WordPress
    5 contributions

    Bonjour et avant tout bonne année!
    J’ai installé le patch mais malheureusement j’obtiens toujours un message d’erreur:

     » Warning: Cannot modify header information – headers already sent by (output started at /homez.131/kulturel/www/natalyandria/wp-config.php:1) in /homez.131/kulturel/www/natalyandria/wp-login.php on line 302

    Warning: Cannot modify header information – headers already sent by (output started at /homez.131/kulturel/www/natalyandria/wp-config.php:1) in /homez.131/kulturel/www/natalyandria/wp-login.php on line 314

    Warning: Cannot modify header information – headers already sent by (output started at /homez.131/kulturel/www/natalyandria/wp-config.php:1) in /homez.131/kulturel/www/natalyandria/wp-includes/pluggable.php on line 674

    Warning: Cannot modify header information – headers already sent by (output started at /homez.131/kulturel/www/natalyandria/wp-config.php:1) in /homez.131/kulturel/www/natalyandria/wp-includes/pluggable.php on line 675

    Warning: Cannot modify header information – headers already sent by (output started at /homez.131/kulturel/www/natalyandria/wp-config.php:1) in /homez.131/kulturel/www/natalyandria/wp-includes/pluggable.php on line 676

    Warning: Cannot modify header information – headers already sent by (output started at /homez.131/kulturel/www/natalyandria/wp-config.php:1) in /homez.131/kulturel/www/natalyandria/wp-includes/pluggable.php on line 868 « 

    visivle à l’adresse :http://www.kulturelabel.com/natalyandria/wp-login.php

    Que dois-je faire…
    Je note que le serveur est OVH…
    Merci

    #705853

    piekes
    Membre
    Maître WordPress
    726 contributions

    Hello

    Il serait judicieux, pour obtenir une réponse :

    – de commencer par une recherche sur le forum, des problèmes analogues ayant été largement traités
    – de créer, si l’étape précédente n’a pas abouti, ton propre fil

    #705854

    riri1310
    Membre
    Initié WordPress
    15 contributions

    Patch installé et qui fonctionne à merveille! Merci

    #705859

    wassy
    Membre
    Initié WordPress
    47 contributions

    Bonjour à tous,

    Ma configuration WP actuelle
    – Version de WordPress : WP 2.6
    – Thème utilisé : Zinmag Redux
    – Plugins en place : tous désactivés
    – Nom de l’hebergeur : ovh
    – Adresse du site : http://www.2870.fr/blog

    Problème(s) rencontré(s) :

    Bon, je suis sûr que je vais me faire jeter mais j’ai beau regarder dans les autres fils, je ne trouve pas exactement le problème que j’ai rencontré en tentant d’upgrader vers la v 2.9.1. Si par hasard, j’avais mal cherché, je vous prie de m’excuser et de redirigé doucettement vers le bon fil… 😉

    Donc, voici : la mise à jour (automatique via l’extension ad’hoc) semblait s’être déroulée parfaitement quand, soudain, à l’étape finale, juste avant de ré-activer les plug-in, surgit cette erreur en plein dans ma face :
    [img]http://www.2870.fr/images/errsql.PNG[/img]

    Et, donc, ma question est la suivante : dois-je mettre à jour MySql et, si oui, comment ; ou bien la mise à jour de php5 suffit-elle et, auquel cas, comment se fait-il que la modif de .htaccess ne change rien au fait que je n’accède plus à l’admin ?

    Merci,

    a+
    BB.

    #705855

    Lumiere de Lune
    Participant
    Maître WordPress
    19611 contributions

    Oui tu dois upgrader vers Mysql (sinon wordpress ne te le demanderais pas). Mysql et php sont deux choses différentes.

    #705856

    wassy
    Membre
    Initié WordPress
    47 contributions

    Re,

    Lumière de Lune wrote:
    Oui tu dois upgrader vers Mysql (sinon wordpress ne te le demanderais pas). Mysql et php sont deux choses différentes.

    Bon, d’accord, mais comment fait-on ? MySql, c’est pas sur le serveur d’Ovh ?

    Merci de ta réponse aussi rapide, en tous cas.

    a+
    BB.

    #705857

    Lumiere de Lune
    Participant
    Maître WordPress
    19611 contributions

    Je ne connais pas OVH, c’est à voir avec eux

    #705858

    wassy
    Membre
    Initié WordPress
    47 contributions

    Re,

    Lumière de Lune wrote:
    Je ne connais pas OVH, c’est à voir avec eux

    Certes mais après vérification dans le « manager d’Ovh », les tables en question sont bien en MySQL v 5.0. M’est avis que c’est plutôt un bug de la mise à jour automatique…

    On dirait que ça t’embête de répondre, me trompe-je ?

    Merci,

    a+

    BB.

    #705860

    prof.heureux
    Membre
    Initié WordPress
    14 contributions

    Bonjour,

    J’ai le même genre de problème, et cela fait au moins 5 fois que je dois recharger un fichier php du dossier includes, default-filters ou plugins. Je l’ai encore fait cet après-midi et, quelques heures plus tard, le fichier default-filters s’est à nouveau « gonflé » de je ne sais quoi (750 ko environ), dont un « <" quelque part qui bloque l'accès (pour moi comme pour les visiteurs… quand leur navigateur ne les alerte pas quant à un cheval de Troie ou à un virus !).

    Je ne comprends pas du tout comment ce fichier peut se modifier « tout seul », j’ai réinstallé plusieurs fois WP en automatique, mais le problème persiste.

    Si quelqu’un peut m’expliquer ce qui se passe, j’en serais très heureuse ! merci d’avance.

    Prof.heureux

    blogdeprof.fr

    #705861

    Lumiere de Lune
    Participant
    Maître WordPress
    19611 contributions

    Si les visiteurs ont ce genre d’alerte il y a de fortes chances qu’il y ait effectivement un virus -> soit sur ton serveur, soit sur ton ordinateur.

    @wassy ça ne « m’embête pas » de te répondre, je ne peux pas. Chaque hébergeur a ses spécificités, et je ne connais pas OVH

    #705862

    prof.heureux
    Membre
    Initié WordPress
    14 contributions

    D’après ce qu’un ami (prof d’informatique en BTS) m’a dit, c’est ce signe supplémentaire qui est mal interprété par les navigateurs – lesquels réagissent d’ailleurs différemment : alerte virus OU cheval de Troie OU blocage du site avec l’affichage d’un message annonçant un problème php.

    La première chose que j’avais faite, d’ailleurs, c’était de récupérer tout le site et de le scanner avec Antivir…

    De toutes façons, ce n’est pas sur mon ordinateur que se passe le problème : c’est dans WordPress, où certains fichiers php sont modifiés, sans que je comprenne comment ni pourquoi…

    #705863

    wassy
    Membre
    Initié WordPress
    47 contributions

    Bonjour à tous,

    Pour ce qui me concerne et avec l’aide précieuse du service technique d’Ovh – mon hébergeur – j’ai tenté de passer en MySQL5.0 et, pour ce faire, supprimer ma base de données puis la recréer. Ce qui a eu pour effet, effectivement, de passer à la version 5 mais j’ai une nouvelle erreur qui s’affiche tant à l’index qu’à wp-admin.php :

    Warning: Cannot modify header information – headers already sent by (output started at /homez.63/wassy/www/blog/wp-config.php:1) in /homez.63/wassy/www/blog/wp-includes/functions.php on line 2861
    
    Error establishing a database connection

    Apparemment, la recréation de ma base a foiré mais, en plus, je n’arrive plus à accéder à l’admin… Je cherche du coté du fichier indiqué (fonctions.php) mais je n’ai encore rien trouvé !

    Rageante, cette mise à jour ! Comme c’est la première fois que ça se passe mal, je suis un peu désorienté…
    Merci,
    a+
    BB.

15 sujets de 1 à 15 (sur un total de 20)
  • Vous devez être connecté pour répondre à ce sujet.