Contact Form 7 – Envoi impossible (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 19)
  • Auteur
    Messages
  • #2376112
    serge152
    Participant
    Maître WordPress
    588 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Ma configuration WP actuelle :
      – Version de WordPress : 5.7.1
      – Version de PHP/MySQL : 7.3.27 / 5.5.5
      – Thème utilisé : Virtue
      – Thème URI : https://kadencewp.com/product/virtue-free-theme/
      – Extensions en place : Advanced Editor Tools (previously TinyMCE Advanced) (5.6.0), Better Search Replace (1.3.4), Captcha Code (2.7), Classic Editor (1.6), Contact Form 7 (5.4), Disable Comments (2.1.1), Duplicator (1.4.0), Elementor (3.2.1), Forum_wordpress_fr (4.2), Gwolle Guestbook (4.1.1), Kadence Blocks – Gutenberg Blocks for Page Builder Features (1.10.9), Really Simple SSL (4.0.14), Redirection (5.1.1), UpdraftPlus – Backup/Restore (1.16.53), Virtue/Ascend/Pinnacle Toolkit (4.9.6), Wordfence Security (7.5.2), WP-Optimize – Clean, Compress, Cache (3.1.8), WP Last Modified Info (1.7.6), WP Sitemap Page (1.6.4)
      – Adresse du site : https://paramourdeschiens.fr
      – Nom de l’hébergeur : Apache : Planet Hoster

    Problème(s) rencontré(s) :

     

    Bonjour,

    Je viens de faire migrer mon site d’un hébergement gratuit (PlanetHoster Lite) à un hébergement payant (PlanetHoster World)
    et je rencontre un souci avec mon onglet contact https://paramourdeschiens.fr/contact/

    En effet dès que l’on envoie un message avec une adresse en @free.fr, @yahoo.fr, @gmail.com, @laposte.net par exemple, je reçois le message d’erreur (voir image)
    Et si je mets une adresse mail “bidon” par exemple @free.com ou même @truckmuche.com cela fonctionne !!!

    Auriez-vous une idée s’il vous plaît ?

    D’avance merci
    Serge

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2376147
    momofr@free.fr
    Modérateur
    Maître WordPress
    4111 contributions

    Salut, étrange je n’ai ce problème sur les sites de mes clients et les adresses génériques passent très bien.

    Regarde si ton hébergeur n’a pas une politique anti-spam un peu sévère, tu peux installer une extension de SMTP pour essayer avec un autre serveur d’envoi, ça te donnera une idée si ça vient de l’hébergeur ou non.

    #2376184
    serge152
    Participant
    Maître WordPress
    588 contributions

    Merci de ta réponse !

     

    Regarde si ton hébergeur n’a pas une politique anti-spam un peu sévère,

    je ne pense pas car sur un autre site, je n’ai pas ce souci, je ne l’avait pas non plus avant la migration !?
    et cela fonctionne avec une autre extension de formulaire style “Simple Basic Contact Form”

    tu peux installer une extension de SMTP pour essayer avec un autre serveur d’envoi, ça te donnera une idée si ça vient de l’hébergeur ou non.

    Houla peux-tu stp m’expliquer comment faire ?

    Mais je ne pense pas puisque j’ai essayé avec d’autres extensions de formulaire et  que cela fonctionne !
    Ce qui voudrait dire que ce serait plutôt lié à l’extension elle-même non ?

    Merci

     

    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    #2376188
    momofr@free.fr
    Modérateur
    Maître WordPress
    4111 contributions

    Salut, j’utilise CF7 sur plusieurs sites sans rencontrer de problème (sur 2 hébergeurs différents).

    Sans audit de ton site il est difficile de savoir ce qui peut bloquer.

    Déjà Really Simple SSL ne sert pas à grand chose sur les hébergements actuels.

    Si tu ne gardes que CF7 sans les autres extensions ça donne quoi ?

    #2376189
    serge152
    Participant
    Maître WordPress
    588 contributions

    Moi non plus avant jamais de soucis

    C est juste depuis la migration

    Je vais essayer en désactivant les autres extensions, ou sinon je choisirai un autre plugin de formulaire

     

    Comment faire un audit de mon site svp, je ne suis qu amateur

    #2376196
    Li-An
    Modérateur
    Maître WordPress
    25020 contributions

    Bonjour, il n’y a pas de raison que ça marche pour une adresse et pas une autre. Ce n’est pas CF7 qui décide à quelle adresse envoyer. J’ignore si ça peut vous aider mais j’ai trouvé ça https://degliame.net/resolu-soucis-contact-form-7/

    #2376199
    serge152
    Participant
    Maître WordPress
    588 contributions

    Merci à vous deux

    Voici la réponse de mon hébergeur,  qu en pensez vous s il vous plaît

     

    Bonjour,

    Le problème provient du serveur qui essaye d’envoyer un mail avec la fonction phpmail + l’ancien domaine de votre site wordpress paramourdeschiens.zd.fr/.

    Le service free détecte une erreur d’expéditeur et bloque la réception (possible de voir le par cPanel -> Suivre la remise).

    Trois solutions s’offre à vous :

    1. Refaire votre site à neuf avec le bon nom de domaine wordpress.

    2. Engager un webmaster pour régler le soucis de changement de domaine + formulaire

    3. Utiliser une solution de contournement avec le plugin wp-mail-smtp et un service externe comme smtp2go.
    Il serait aussi possible de créer un e-mail noreply@paramourdeschiens.fr sur votre cPanel et utiliser les identifiants smtp.
    https://en-ca.wordpress.org/plugins/wp-mail-smtp/

    Notre équipe vous remercie de votre confiance et se tient à votre disposition pour toute information complémentaire.

    Cordialement/Best regards,

    </div>
    </div>

    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    #2376201
    Li-An
    Modérateur
    Maître WordPress
    25020 contributions

    Comme je m’en doutais, c’est un problème hébergeur – assez surréaliste. Lorsque vous êtes passé de la version gratuite à la version payante, que s’est-il passé pour votre site ? Vous avez fait des modifications quelconques ou vous avez laissé tel quel ?

    #2376204
    serge152
    Participant
    Maître WordPress
    588 contributions

    Moi aucune modification

    L’hébergeur s est chargé de la migration.

    Voilà ce que je leur ai répondu :

    Je suis très déçu de votre réponse

    Tout d abord parce que dans votre offre vous proposez la migration gratuite, cette dernière devrait donc être totalement fonctionnelle  ce qui n est pas le cas.

    Ensuite vous me parlez d envoi de mail, et que free détecterai une erreur d’expéditeur je n y crois pas du tout, ce serait pareil pour yahoo, gmail etc … ? et pourquoi cela fonctionnerai avec d autres adresses mail dont la vôtre ???

    De plus c est l envoi du formulaire qui ne fonctionne pas et non pas l envoi de mail, car je les reçois bien quand l adresse mail renseignée sur le formulaire passe à l envoi.

    Ensuite dans le Cpanel/suivre la remise cela n indique pas que le mail n a pas été envoyé pour la raison que vous donnez, les suivis que l on voit sont le résultat des envois du formulaire avec d autres adresses que free  yahoo etc …

    Ce qui prouve également que le serveur fonctionne bien et qu il n est pas perturbé par l ancien nom en zd.fr

    Ensuite vous me proposer de refaire le site en entier !!!!! Vous plaisantez

    Surtout que c est uniquement avec le plugin “contact form 7” que cela ne fonctionne pas alors pourquoi refaire tout le site ???</div>

    Engager en Webmaster …. je vais en contacter un mais j ai de gros doutes.

    De plus lors de ma prise d abonnement on m a bien confirmé que mes connaissances étaient suffisantes et que les besoins d un professionnel n étaient pas nécessaires.

    Et puis si c est un problème serveur que pourra donc bien faire le webmaster.

    Et enfin utiliser un service externe alors que je viens de prendre un abonnement chez PlanetHoster !!!

    Si vous ne me trouvez pas le souci, je me ferai une raison et  j’utiliserai à regrets un autre plugin de formulaire.

    ***********

     

    Qu en pensez vous ?
    Ai je la possibilité de régler ce problème  ?

    Pouvez-vous me conseiller une autre extension ?

    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    #2376210
    serge152
    Participant
    Maître WordPress
    588 contributions

    En plus je viens d’essayer toujours le même formulaire avec Contact Form 7 MAIS  sans devoir mettre l’adresse mail du demandeur, cela fonctionne

     

    #2376211
    serge152
    Participant
    Maître WordPress
    588 contributions

    @momofr a écrit :

     

    tu peux installer une extension de SMTP pour essayer avec un autre serveur d’envoi, ça te donnera une idée si ça vient de l’hébergeur ou non.

    excuse moi mais ce n’est pas un problème d’envoi de mail
    en fait sur ContactForm 7, dans les champs à renseigner, si je mets une adresse mail du type @free.fr, @yahoo.fr, @gmail.com, @laposte.net etc….

    le formulaire ne part pas !
    si je met une adresse “bidon” il part donc ce n’est pas un souci d’envoi de mail mais de champ dans le formulaire
    mais pourquoi puisque cela fonctionnait très bien avant la migration ?

    Bonne soirée

    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    #2376216
    Li-An
    Modérateur
    Maître WordPress
    25020 contributions

    Alors plusieurs choses : 1. chaque provider analyse les messages qui arrivent chez lui et regarde les en-têtes. Free ne les trouve pas orthodoxes et bloque les mails. Pourquoi ? Votre hébergeur l’a expliqué, le domaine d’envoi n’est pas le même que celui utilisé (visiblement, le domaine d’envoi correspond à l’ancien domaine utilisé (gratuit ?)).

    2. si c’est l’hébergeur qui s’est chargé de la migration, il aurait peut-être en effet dû faire certaines modifications pour que tout fonctionne normalement.

    On va faire quelques vérifications mais pas sûr que nous puissions y faire quelque chose puisqu’une partie du problème vient de l’hébergeur. Faites nous déjà une capture d’écran de Réglages>général

    #2376217
    serge152
    Participant
    Maître WordPress
    588 contributions

    1. chaque provider analyse les messages qui arrivent chez lui et regarde les en-têtes. Free ne les trouve pas orthodoxes et bloque les mails.

    Mais Free, Yahoo, Gmail etc…  ne reçoivent rien, puisque mon formulaire ne part pas de mon site.

    2. si c’est l’hébergeur qui s’est chargé de la migration, il aurait peut-être en effet dû faire certaines modifications pour que tout fonctionne normalement.

    On est bien d’accord 😉

    On va faire quelques vérifications mais pas sûr que nous puissions y faire quelque chose puisqu’une partie du problème vient de l’hébergeur. Faites nous déjà une capture d’écran de Réglages>général

    C’est très gentil de vouloir m’aider, je fait çà dès que possible

    Bonne soirée

    • Cette réponse a été modifiée le il y a 1 semaine et 5 jours par serge152.
    #2376222
    momofr@free.fr
    Modérateur
    Maître WordPress
    4111 contributions
    Cette réponse a été marquée comme privée.
    #2376223
    serge152
    Participant
    Maître WordPress
    588 contributions

    Voilà

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
15 sujets de 1 à 15 (sur un total de 19)
  • Vous devez être connecté pour répondre à ce sujet.