[Résolu] Contact Form 7 bouton envoi invisible sauf en survol (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
  • Ce sujet contient 17 réponses, 5 participants et a été mis à jour pour la dernière fois par ferman, le il y a 8 mois.
15 sujets de 1 à 15 (sur un total de 18)
  • Auteur
    Messages
  • #2368715
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    Bonjour,

    Ma configuration WP actuelle 5,6

    • Version de PHP/MySQL : 7,2
    • Thème utilisé : OceanWP
    • Extensions en place : 12
    • Nom de l’hébergeur : OVH
    • Adresse du site : lesombresdepicpus.fr

    Problème(s) rencontré(s) :

    Bonjour,

    Sur mon formulaire de contact, le bouton « envoi » est invisible et n’apparaît qu’en survol. Comment faire pour le rendre visible de manière permanente ?

    Merci.

    Jiclo

    #2368720
    momofr@free.fr
    Modérateur
    Maître WordPress
    7108 contributions

    Salut, évite d’ouvrir plusieurs sujets sur le même problème STP.

    Sans accès à ton site il est impossible de t’aider.

    #2368726
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    Ah… désolé… je ne le savais pas… Le site est en ligne, vous pouvez aller voir le problème.

    Merci.

    #2368784
    ferman
    Participant
    Maître WordPress
    7016 contributions

    Bonjour,

    C’est parce-que texte et couleur de fond sont blancs. Normalement, vous devriez pouvoir modifier cela dans les réglages de l’extension. Autrement pour info et si vous voulez le même aspect que le bouton « recherche », copiez/collez le code ci-dessous dans vos CSS additionnelles.

    .wpcf7-form-control.wpcf7-submit {
    background: #f7f7f7;
    border: 1px solid #ccc;
    padding: 1.5em 1.5em;
    color: #32373c;
    margin-left: .625em;
    word-break: normal;
    }

    #2368785
    momofr@free.fr
    Modérateur
    Maître WordPress
    7108 contributions

    Salut, n’ayant pas la liste des extensions utilisées je ne sais pas si l’une d’elles peut agir sur la couleur du bonton de base (certainement que oui).

    Tu peux modifier la couleur du bouton avec cette règle CSS :

    .wpcf7-form-control.wpcf7-submit {
    background-color: #666;
    }

    Tu modifies le code hexadécimal de la couleur selon tes besoins. Si ça ne marche pas il faudra peu-être « forcer » la couleur en mettant !important après le code couleur.

    La règle est à copier dans Apparence -> Personnaliser -> CSS additionnel.

    #2368869
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    Merci de vos réponses…

    Le problème c’est que suis débutant et que j’apprends doucement…

    J’ai regardé dans « apparence » puis « personnaliser » cela m’ouvre alors la page de réglage du thème et je ne vois nulle part « css additionnels »…

    • Cette réponse a été modifiée le il y a 3 années et 4 mois par Jiclo.
    #2368871
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    Mes extensions sont : Advanced editor tools / Askimet / Chronological Post / Classic Editor / Contact Form 7 / Easy Table of Contents / Fonts Plugin Google / Gutenberg / Ocean Extra / Rally Simple SSL / Relevanssi / SEO Press / Worfence Security / WP Faste Cache / WP maintenance.

    Merci.

    #2368875
    ferman
    Participant
    Maître WordPress
    7016 contributions

    Vous ne voyez pas ce qui est en pièce jointe? Ce serait inquiétant.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2368877
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    Merci pour la pièce jointe… Si, si, je la vois très bien mais malheureusement chez moi ce ne sont pas du tout les mêmes onglets… je n’ai ni « couleurs » ni « css additionnel »… pourquoi…? Je ne sais pas et pourtant c’est bien le même thème…

     

    #2368879
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    Voilà ce que j’ai…

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2368883
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    J’ai trouvé, le problème pour le fait que le onglets du thème soient différents… Il fallait désactiver Ocean Extra… Maintenant cela apparaît bien comme sur votre pièce jointe…

    Merci

    #2368886
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    C’est bon, problème réglé ! J’ai pu rentrer les lignes que vous m’avez indiquées dans css addionnel et ça marche parfaitement, le bouton envoi est redevenu visible.

    Merci beaucoup à vous deux.

    Je pense en fait que Ocean Extra ne me sert à rien et que je vais le supprimer.

    Bonne journée à vous.

    Jiclo

    • Cette réponse a été modifiée le il y a 3 années et 4 mois par Jiclo.
    #2368887
    momofr@free.fr
    Modérateur
    Maître WordPress
    7108 contributions

    Salut, activer ou non Ocean Extra ne change rien à l’affaire si ce n’est qu’avec cette extension (très conseillée) la section change de nom.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2368890
    Jiclo
    Participant
    Padawan WordPress
    51 contributions

    Certes mais avec l’extension, les onglets « couleur » et « css addionnel » n’apparaissent pas… en la désactivant les deux onglets manquant reviennent…

    J’ai encore appris quelque chose de nouveau… merci à vous.

    Jiclo

    #2370700
    epuup
    Participant
    Initié WordPress
    2 contributions

    bonjour, je possède le même problème, j’aurai besoin d’aide (édit modération : retrait du lien) Merci d’avance.

    • Cette réponse a été modifiée le il y a 3 années et 3 mois par epuup.
    • Cette réponse a été modifiée le il y a 3 années et 3 mois par Flobogo. Raison: édit modération
15 sujets de 1 à 15 (sur un total de 18)
  • Vous devez être connecté pour répondre à ce sujet.