[Résolu] Connexion FTP manuelle (Créer un compte)

  • WordPress :5.0.3
  • Statut : résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2252496
    ucan
    Participant
    Initié WordPress
    31 contributions

    Ma configuration WP actuelle :

    • – Version de WordPress : 5.1.1 multi-site
    • – Version de PHP/MySQL : 7.2.13 / 5.5.5
    • – Thème utilisé : Enfold-Child
    • – Extensions en place : UpdraftPlus – Backup/Restore (1.16.8), Yoast SEO (10.0.1)
    • – Extensions réseau en place : Forum_wordpress_fr (4.1), Jetpack by WordPress.com (7.1.1), WP Mail SMTP Plugin by Mail Bank (4.0.5)
    • – Adresse du site : http://c-serp.fr
    • – Nom de l’hébergeur : Apache/2.4.29 (Unix)

    Bonjour,

    Ma connexion FTP fonctionne bien, sauf que chaque fois que je la sollicite (pour une mise à jour, un ajout d’extensions ou une suppression de plugin) il faut que systématiquement je saisisse et confirme le mot de passe pour valider et lancer l’action. C’est la grande différence avec un autre site que j’héberge chez OVH, la connexion FTP est transparente, je clique sur ajout d’un plugin, le téléchargement s’effectue automatiquement sans ressaisir le mot de passe.

    Dernière précisions, j’héberge moi-même le site sur un NAS Synology, le routeur est une FreeBox et je précise que j’avais ce problème avant de basculer en version multi-sites.

    Je n’arrive pas à voir quelle option où réglage j’ai pu oublier, j’aimerai bien avoir un usage plus classique à ce niveau-là.

    Exemple, je n’avais pas mis à jour le réseau depuis qq temps, il y avait 5 plugins à mettre à jour, il a fallu que je les mette à jour un à un, en saisissant chaque fois le mot de passe. Pas très efficace 🙁

    Je tourne en rond, si vous avez des suggestions, je suis à l’écoute.

    Merci d’avance.

    #2252517
    Li-An
    Participant
    Maître WordPress
    28556 contributions

    Bonjour, le FTP étant indépendant de WP, je ne vois pas trop le rapport entre les deux présentement.

    #2252730
    ucan
    Participant
    Initié WordPress
    31 contributions

    Trouvé !

    Cela venait tout simplement du fait qu’au moment de l’installation, le proccess n’avait pas déclaré dans le fichier wp-config.php les identifiants de connexion ftp. Du coup, j’ai rajouté ces 4 lignes juste après les réglages MySQL et tout est rentré en ordre… plus besoin de ressaisir le mot de passe… la connexion ftp est automatisée.

    Le bonheur, tout du moins le confort ne tenait qu’à ça :

    /** FTP login settings **/
    define('FTP_HOST', 'hostname');
    define('FTP_USER', 'username');
    define('FTP_PASS', 'password');

    P.S J’ai trouvé l’information ici

    • Cette réponse a été modifiée le il y a 5 années et 4 mois par ucan. Raison: oubli de préciser ou j'ai trouvé l'info. Rendons à César
    #2252733
    Li-An
    Participant
    Maître WordPress
    28556 contributions

    Oula, heureusement que vous avez trouvé, ça dépassait mes compétences.

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.