[Résolu] Connection au back office impossible et front office down

  • WordPress :4.7
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • #1611058
    MaximeDurand
    Participant
    Initié WordPress
    31 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Integrity
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour à tous et merci d’avance pour votre aide.

    Je rencontre un gros problème depuis hier, l’accés au back office est impossible :

    <h1>Ce site est inaccessible</h1>
    monsite.com n’autorise pas la connexion.

    Et de même pour les pages de mon site web.

    Voici mes sources d’erreurs potentielles :

    J’ai acheté un certificat SSL chez Gandi.net qui est bien opérationnel sur mon domaine et sous domaine.

    j’ai opté pour l’installation d’un plugin pour m’aider dans le passage du site en https : https://fr.wordpress.org/plugins/really-simple-ssl/

    Après installation et activation du SSL, cela ne marchait pas bien, alors j’ai décidé de le désactiver et de le désinstaller.

    Dernière erreur, j’ai modifié les adresses du site dans le back office pour rajouter manuellement https.

    Résultat je ne peux plus accéder à la console d’administration sela me renvoi sur https://monsite.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.monsite.com%2Fwp-admin%2Findex.php&reauth=1

    Merci d’avance pour votre aide !

    #1611073
    Li-An
    Modérateur
    Maître WordPress
    21520 contributions

    Une solution https://wpchannel.com/corriger-changement-accidentel-url-wordpress/

    Vous pouvez aussi passer par phpmyadmin – l’ensemble des méthodes est listé ici https://codex.wordpress.org/Changing_The_Site_URL

    Le passage en https se fait en cinq minutes en suivant le tuto https://wpmarmite.com/wordpress-https/

    #1611307
    Inglebard
    Participant
    Padawan WordPress
    64 contributions

    Bonjour,

    La solution de Li-An devrait fonctionner. Je pense qu’une modification via phpmyadmin est la meilleur solution bien qu’elle puisse faire peur

    Cependant, je tiens à signaler que de passer un site de http vers https peut être dangereux.

    Bon nombre de configuration htaccess/apache/nginx et quelque plugins, effectue des redirections automatique vers http -> https de façon permanente.

    Cela peut empêcher un retour vers https -> http.

    #1611316
    Li-An
    Modérateur
    Maître WordPress
    21520 contributions

    « Malheureusement », aussi bien Google que les instances européennes vont pousser au passage au https. Je pense que tous les propriétaires un peu sérieux de site vont y passer. Moi j’ai fait le saut mais mon hébergeur permet le retour en arrière en toute transparence.

    #1611363
    Inglebard
    Participant
    Padawan WordPress
    64 contributions

    @Li-An je sais et je pense que c’est une bonne chose.

    C’était pour dire qu’il risque d’y avoir des erreurs supplémentaires lors d’un retour de son wordpress en http notamment l’erreur 310 « Too many redirect »

    #1611453
    MaximeDurand
    Participant
    Initié WordPress
    31 contributions

    Bonjour Li-an & Inglebard,

    Tout d’abord merci pour votre aide, car je suis en panique totale.

    J’ai ajouté par FTP les deux lignes pour réaccéder à la console mais cela ne fonctionne toujours pas, j’ai toujours le message :

    <h1>Ce site est inaccessible</h1>
    monsite.com n’autorise pas la connexion

    Je vais essayer de voir du coté de la solution par MyPHP et je reviens vite à vous.

    Encore merci et bon week-end.

     

    #1611455
    Li-An
    Modérateur
    Maître WordPress
    21520 contributions

    Désactiver le SSL et réessayez.

    #1611513
    MaximeDurand
    Participant
    Initié WordPress
    31 contributions

    J’ai réussi à récupérer mon accés backoffice intégralement, mais le site reste down.

    L’interface admin est bien en https.

    Quand je cherche à me rendre sur le frontoffice, il semble enlever les www… pour passer de https://www.monsite.com à https://monsite.com avec un message d’erreur

    soit une multiple redirection, soit un refus de connexion.

    Je ne suis pas expert, mais je pencherais pour un problème de redirection au niveau du 3w dans le fichier .htaccess…

    Plausible ?

    Encore merci pour votre précieuse aide.

    #1611514
    Li-An
    Modérateur
    Maître WordPress
    21520 contributions

    Si vous avez accès à l’admin c’est que ça marche. Mettez un thème par défaut et désactivez les extensions. Utilisez le tuto indiqué pour passer vraiment en https sans extension.

    #1611515
    MaximeDurand
    Participant
    Initié WordPress
    31 contributions

    D’accord merci beaucoup j’essaie de suite et je reviens à vous !

     

    #1611516
    Inglebard
    Participant
    Padawan WordPress
    64 contributions

    Bonjour,

    Pour le message d’erreur « multiples redirections » : je pensais bien que cela pouvait arriver cf post.

    Il faut vérifier le .htaccess puis vider le cache de votre navigateur. Cependant si des utilisateurs externe se sont connecté à votre site, ils peuvent eux aussi avoir le problème.

    #1611526
    MaximeDurand
    Participant
    Initié WordPress
    31 contributions

    Bonsoir Li-an & Inglebaard,

    J’ai mis un thème défaut, désactivté l’ensemble des extension, et tjrs ce problème de

    <h1>Ce site est inaccessible</h1>
    hubertcloix.com n’autorise pas la connexion.

    Voici mon fichier htaccess, si vous y voyiez une erreur par hasard…

    # BEGIN SecuPress readme_discloses
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule (/|^)(readme|changelog)\.(txt|md|html)$ – [R=404,L,NC]
    </IfModule>
    # END SecuPress
    # BEGIN WPSuperCache
    # END WPSuperCache

    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.4.3]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL
    # Redirection du site sans www vers www
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^monsite.com [NC]
    RewriteRule ^(.*)$ http://www.monsite.com/$1 [L,R=301]

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Merci pour votre aide et bonne soirée !

    #1611527
    Inglebard
    Participant
    Padawan WordPress
    64 contributions

    Tu pourrais enlever les redirections temporairement.

    Commente ceci :

    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.4.3]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL

    Pour obtenir cela :

    # BEGIN rlrssslReallySimpleSSL #rsssl_version[2.4.3]
    #<IfModule mod_rewrite.c>
    #RewriteEngine on
    #RewriteCond %{HTTP:X-Forwarded-Proto} !https
    #RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    #</IfModule>
    # END rlrssslReallySimpleSSL

    Ton erreur doit également venir du faite que ton DNS ne soit pas configurer correctement.

    http://www.monsite.com pointe sur ton serveur

    monsite.com ne pointe pas sur ton serveur.

     

    De plus ce n’est pas normal que tes « www » aient disparu. Ne les auraient tu pas supprimer avec phpmyadmin ou lors de tes modifs ?

    Sur les doc si tu vois ceci « monsite.com », tu dois mettre cela « www.monsite.com ».

    #1611541
    MaximeDurand
    Participant
    Initié WordPress
    31 contributions

    Bonjour Inglebard,

    J’ai bien mis un # en commentaire sur le .htaccess comme tu me l’a recommandé.

    Je ne me suis pas connecté sur phpmyadmin, mais c’est possible que j’ai fais une fausse manipulation.

    Il faut que je vérifie dans le fichier wp-login ?

    Merci pour votre aide !

    #1611544
    MoiMM
    Participant
    Chevalier WordPress
    378 contributions

    Bonjour Maxime,

    Je ne suis pas un expert loin de là, du coup je me garderai bien de donner un conseil qui serait plus qu’hasardeux … mais j’ai fait le passage de 2 sites en https ce we en utilisant cet article de WPMarmite qui contient moules infos et liens utiles !

    J’espère que cela aidera ! 🙂

    Bonne année ! 😉

15 sujets de 1 à 15 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.