Comment changer l’emplacement d’un blog sur pageperso.free.fr ?

  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #542599
    thymeho
    Membre
    Initié WordPress
    4 contributions

    Bonjour,

    – Version de WordPress : 4.0
    – Version de PHP/MySQL : 3.1.5 / 5.0 ou 5.1
    – Nom de l’hebergeur : FREE.fr !
    – Adresse du site : thymeho.free.fr/wordpress

    Problème(s) rencontré(s) :

    passer de thymeho.free.fr/wordpress à thymeho.free.fr/blog



    Bonjour
    après m’être enregistré sur ce forum, j’ai parcouru plusieurs fils à propos des pages persos free…
    J’ai posté ma question également sur les forums USENET de free, mais sans réponse.
    Je me permets donc de poster ici ma question, n’hésitez pas à ré-orienter si cela ne convient pas…

    J’ai créé un blog avec wordpress sur ma page perso free à l’adresse :
    thymeho.free.fr/wordpress
    C’est dommage car à la réflexion, je préfère (pour référencement et autres, bref…) :
    thymeho.free.fr/blog

    Quand je pense qu’en 1 clic sur l’interface de gestion de wordpress on peut déplacer l’adresse…
    …mais pas quand on est hébergé chez free.
    Je suis passé par les manips de Luciole135 (merci à lui !) pour installer wordpress sur mapageperso.free.fr
    mais du coup, l’interface de gestion est limitée –> erreur 500 dès qu’on touche au changement d’adresse

    Comment faire SVP ? Est-ce que je suis obligé de passer par toute une manip du genre, installer apache sur mon mac, copier tout en local ? Avant de faire des étapes supplémentaires pour tout remettre en distant chez free sur la nouvelle adresse (je saurais même pas comment) ?

    Je cherche la solution la plus facile et rapide car étant béotien complet, toutes ces manips sont source de plantage…

    À la relecture des commentaires sur le site de luciole135, je suis tombé sur une de ses remarques à AZZA :
    « — AZZA : mon site en cours de creation est donc http://fr.azza.photos.free.fr/website. Pensez vous qu’il y ait un inconvenient à laisser les choses ainsi […] ou serait il preferable que je refasse mon upload à la racine ?
    [NDLR c’est quasiment le même problème que moi aussi]

    — LUCIOLE135 : En terme de référencement, il parait que oui. Sinon, vous pouvez utiliser le script searchreplacedb2.php pour copier votre site à la racine. »

    Rhhaaa c’est possible comme ça alors ? Luciole135 donne effectivement une façon de faire pour la copie locale. Mais je pose une question bête si on veut faire ça directement sur le site distant free.fr :

    Est-ce qu’il y a juste à changer l’étape 4 (sous MAC) en
    « Remplacez le nom de domaine pseudo.free.fr/wordpress par pseudo.free.fr/blog et cliquez sur le bouton « Submit Search string »
    Ou faut-il ré-installer wordpress avant ? Ou… j’en sais rien en fait !
    Je n’ose toucher à rien avant d’être sûr : c’est tellement fragile sur free.fr, dès que je touche à quelque chose, paf ! erreur 500…

    Pourriez-vous détailler SVP comment faire dans ce cas avec searchreplacedb2.php ?

    Merci BEAUCOUP pour votre aide.

    #974870
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Pour ls erreurs 500, c’est simple, chez FREE elles sont causées par les REWRITE RULES qu’écrit WordPress dans le fichier .htaccess.
    Il suffit de les supprimer pour que l’erreur disparaisse.

    Pour déplacer votre site, il suffit avec Filezilla de sélectionner tous les fichiers et dossier de votre site situés dans le dossier /wordpress (ils apparaissent en bleu) et de faire un glisser déposer sur le dossier situé tout en haut qui est suiovi de 3 points de suspension (qui symbolise le niveau supérieur, donc la racine dans ce cas).

    Une fois ce déplacement fait, vous placez à la racine le script searchreplacedb2.php (après avoir changé son nom pour ne pas que l’on puisse vous pirater) et de remplacer thymeho.free.fr/wordpress par thymeho.free.fr.

    Ensuite vous allez sur l’admin, et vous réenregistrez les permaliens, ce qui va créer une erreur 500. Vous laissez votre navigateur sur cette erreur 500, vous corrigez le .htaccess, puis vous retournez sur votre navigateur et vous actualisez cette page en erreur.
    Si elle persiste, vous recommencez la même manip :
    -> nettoyer le .htaccess
    -> actualiser la page en erreur 500

    Ensuite, cela devrait rouler.

    #974871
    thymeho
    Membre
    Initié WordPress
    4 contributions

    Merci, merci BEAUCOUP Luciole135 !

    Bon, j’ai fait toutes les manips : impec le blog est bien transféré de
    thymeho.free.fr/wordpress à thymeho.free.fr/blog
    Merci encore pour les indications.

    J’ai fait ensuite la manip pour les permaliens.
    Et là, je crois que ça coince : j’ai des “ERREUR 404 – Document non trouvé” dès que je clique sur un article..!?

    J’ai fait :
    1- connexion à http://thymeho.free.fr/blog/wp-admin
    2- réglages/permaliens –> enregistrer les modifications
    3- j’ai bien une erreur 500
    4- je vais dans Filezilla, je supprime le .htaccess qui vient d’être créé dans thymeho.free.fr/blog
    5- j’actualise la page en erreur 500 dans firefox ; il me demande confirmation de renvoyer le formulaire, OK, puis m’affiche bien une page, même si elle est en format dégradé (sans le thème, les fonts, les polices, mais bon…)
    6- je retourne sur un article : non, toujours pas.
    J’ai refait la manip trois fois d’affilée : pas mieux…?

    Une idée STP ?
    Tu m’auras bien aidé, je te remercie encore vivement !!!

    #974872
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Bon alors modifiez les pêrmliens via phpmyadmin comme le recommande lashon ici :
    http://lashon.fr/changer-permaliens-wordpress-hebergeur-free/

    perso, avec Firefox, j’arrive à les modifier comme je vous ai dit, mais sinon, la méthode de Lashon fonctionne très bien.

    #974873
    thymeho
    Membre
    Initié WordPress
    4 contributions

    SUPER !

    Alleluia !

    Merci ! Merci !

    J’ai donc essayé ça, sur le site que tu as indiqué et ça marche :

    La seule méthode sûre et rapide pour changer les permaliens chez Free est passer directement par la console SQL phpmyadmin de votre hébergeur. Et non pas via le tableau de bord de WordPress, parce que le mode Rewrite Rules est interdit chez Free. Or WordPress génère automatiquement un Rewrite lors du changement de permaliens, ce que vous pouvez voir dans .htaccess (lignes ajoutées).

    Pour changer les permaliens, osez braver la console SQL et allez dans votre console SQL ou phpmyadmin. C’est-à-dire allez chez votre hébergeur dans votre espace accueil. Trouvez la console SQL (ou Base de données ou phpadmin). Go!
    Vous voyez maintenant votre base de données.
    Affichez la table wp-options. Une fois là, cherchez l’option permalink-structure.
    Dans options_value de cette option, insérez la structure de permaliens que vous désirez. Dans le cas précis de Free, mettre au début de la structure personnalisée /index.php au début est impératif. Par exemple
    /index.php/%category%/%postname%/
    Tant que vous y êtes, vous devez également choisir les préfixes pour la catégorie et le tag. Comme dans l’option du tableau de bord de WordPress. Là aussi on le fait via SQL dans wp-options. Dans wp_options, trouvez l’option nommée category_base. Cliquez sur le petit crayon pour modifier. Indiquez ce que vous voulez (attention, ne mettez jamais d’accent ni d’espace dans une url!). Par exemple categorie.
    Maintenant, le préfixe du tag. Toujours dans wp_options, trouvez tag_base (probablement une page plus loin). Modifier selon votre choix, de la même façon. Mettez tag ou motcle (pas d’accent).

    Merci à ce généreux contributeur, et un GRAND MERCI à toi Luciole135 !

    #974874
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    De rien ! :wp:

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.