[Résolu] Comment centrer l’image de tête.

  • WordPress :5.0
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 28)
  • Auteur
    Messages
  • #2241047
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Spacious
    • Extensions en place :
    • Nom de l’hébergeur : Hostinger
    • Adresse du site : https://site-ra-t.000webhostapp.com/

    Problème(s) rencontré(s) :

    Version: 5.0.3

    Bonjour,

    J’ai réduit l’image qui reste à gauche.

    Je cherche à la centrer. Pour cela j’ai testé plusieurs codes, sans effet.

    Les discussions sur le Forum ne m’aident pas ou je n’ai pas trouvé la bonne.

    Merci pour un code CSS pour centrer l’image.

     

    #2241077
    Noaneo
    Participant
    Maître WordPress
    29952 contributions

    Bonsoir,
    Vous avez indiqué la largeur pour centrer la bannière ?
    Par exemple :

    div.wp-custom-header {
        text-align: center;
        width: 100%;
    }

     

    #2241122
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    Bonjour Noaneo,

    Le code est bon, l’image est centrée. Merci.

    Cordialement.

    #2241123
    Noaneo
    Participant
    Maître WordPress
    29952 contributions

    Bonjour,
    Ravi pour vous, d’après la fonction Outils de développement de Chrome, l’espace de la bannière fait 1 038 x 297 pixels.
    Il faut ajouter ce code pour avoir la taille réelle de votre bannière, là, elle ne fait que 80% de sa largeur réelle.

    .header-image {
    width:100%;
    }

    Bonne continuation

    #2241131
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    C’est voulu, j’ai ajouté un code pour réduire la taille.

    #2241133
    Noaneo
    Participant
    Maître WordPress
    29952 contributions

    Ah bon, vous préférez avoir des bandeaux noires que chaque côté.
    Ne pas mettre d’accent, de caractères spéciaux dans la nomination de images.
    « cropped-782-Hommage-au-Vendée-Globe-1999-hsb-35×95-cm.-1.jpg »

    https://site-ra-t.000webhostapp.com/wp-content/uploads/2019/01/cropped-782-Hommage-au-Vende%CC%81e-Globe-1999-hsb-35x95-cm.-1.jpg

    C’est ce que j’ai lu dans cet article
    https://dianebourque.com/comment-optimiser-vos-images-dans-wordpress-pour-le-referencement-et-google/

    #2241144
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    Êtes-vous sur la nouvelle version de WordPress: 5.0.3

     

    #2241147
    Noaneo
    Participant
    Maître WordPress
    29952 contributions

    oui

    #2241157
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    Je ne vois pas comment éditer du texte.

    Voir fichiers joints.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2241202
    Noaneo
    Participant
    Maître WordPress
    29952 contributions

    La première image est l’ancien éditeur.
    La deuxième image est le nouveau éditeur, Gutenberg.
    Il ne fonctionne pas comme l’ancien éditeur, mais pas bloc, un bloc titre, un bloc paragraphe, un bloc image, galerie, etc.
    Ce n’est pas le même aspect, cela est différent.
    https://wpmarmite.com/gutenberg-wordpress/

    Si vous voulez ravoir l’ancien éditeur, ce plugin https://wordpress.org/plugins/classic-editor/
    Je n’utilise pas TinyMCE Advanced.

    #2241267
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    Bonjour Noaneo,

    C’est la même extension « Classic-editor » que j’ai sur mon Site mais elle n’a pas les mêmes options.

    Toutefois, suffisante sur ce Site. Merci.

    #2241271
    Noaneo
    Participant
    Maître WordPress
    29952 contributions

    Bonjour,
    Même en ajoutant le plugin TinyMCE Advanced, il vous manque des options ?
    Vous avez essayé le nouvel éditeur Gutenberg ?

    #2241292
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    J’avais déjà installé « TinyMCE Advanced  » qui ne s’affichait pas.

    Avec Classic-editor ça me suffit.

    Je constate que vous avez de bonnes réponses et vous en avez certainement une pour cette nouvelle question:

    J’ai rajouté pas mal de codes dans « Personnaliser ». Dans mon Site 4.9, je les ai versé dans la « Feuille de style » et supprimé de « Personnaliser » et ça va bien.

    Sur ce Site ça n’a aucun effet ?

    Dois-je les laisser dans « Personnaliser » ou faut-il faire autrement ?

    #2241315
    Noaneo
    Participant
    Maître WordPress
    29952 contributions

    Pour certains sites, Gutenberg, remplace TinyMCE Advanced.
    TinyMCE Advanced ne fonctionne pas avec Gutenberg, sauf avec le bloc classique.

    Comme là, vous avez l’extension Classic Editor,  l’extension TinyMCE Advanced devrait fonctionner avec.

    Vous parlez de codes que vous aviez ajoutés dans Personnaliser, c’était avec le même thème ?
    Quel genre de code ?
    Vous avez bien vidé le cache de vote navigateur ?
    Merci

    #2241318
    contact.b.henri@gmail.com
    Participant
    Chevalier WordPress
    333 contributions

    Il s’agit des codes CSS comme celui que vous m’avez donné un peu plus haut.

    Il y en a une douzaine. Réduire l’image – changer la couleur du menu – Supprimer certaines lignes blanches – etc…

15 sujets de 1 à 15 (sur un total de 28)
  • Vous devez être connecté pour répondre à ce sujet.