[Résolu] Comment ajouter la capacité « edit_users » aux admins des sites ?

  • WordPress :4.9.8
  • Statut : résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2208946
    vfavrat
    Participant
    Initié WordPress
    10 contributions

    Bonjour,

    J’utilise WP en multisite pour environ 280 blogs pédagogiques (extensions et thèmes variés).

    Problème(s) rencontré(s) : les utilisateurs ayant le rôle « administrateur » pour un site n’ont pas la possibilité de modifier les utilisateurs de ce site.

    Cela est très ennuyeux, puisque cela les oblige à me contacter pour tout changement (1140 utilisateurs…).

    Pour le moment la seule solution que j’ai trouvée, c’est de leur faire faire un « Import par CSV » avec l’extension  « Import users from CSV with meta ».

    Mais ce n’est pas satisfaisant, surtout que la plupart des admins de blogs ont très peu de compétences Web et veulent simplement un outil simple pour travailler avec leurs élèves.

    Quand j’installe une extension de type « Members » ou « Capability Manager Enhanced », le rôle « Administrateur » a bien la capacité « edit_users ». Mais quand on est dans le menu « Utilisateurs » -> « Tous les utilisateurs » les seules possibilités qui apparaissent sont « Retirer » et « Afficher » pour les comptes des autres utilisateurs (sauf si on est SuperAdmin bien-sûr).

    En cherchant sur le Net, j’ai trouvé ceci : https://thereforei.am/2011/03/15/how-to-allow-administrators-to-edit-users-in-a-wordpress-network/

    Comme cela date de 2011/2012, je ne sais pas si c’est toujours d’actualité, mais il semblerait que la configuration du multisite n’a pas changée.

    Par contre si cela vous semble LA solution, merci de m’indiquer où ajouter ces lignes sans tout casser 😉

    Si vous avez trouvé une autre solution, merci de bien vouloir m’aider.

    #2213427
    vfavrat
    Participant
    Initié WordPress
    10 contributions

    Aujourd’hui je m’aperçois que le rôle « Administrateur » peut modifier les autres utilisateurs. Je ne sais pas quelle mise à jour l’a permis. Mais il semble que mon problème soit réglé 😉

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.