Comment afficher tous les auteurs d’un article ? (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #2365017
    arthur36-
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de WordPress : 5.6
    • Version de PHP/MySQL : 7.4.8 / 5.6.50
    • Thème utilisé : Newslite
    • Thème URI : https://evisionthemes.com/product/newslite
    • Extensions en place : Advanced Editor Tools (previously TinyMCE Advanced) (5.6.0), Akismet Anti-Spam (4.1.8), Authors List (1.2.2), Classic Editor (1.6), Contact Form 7 (5.3.2), Cookie Notice (1.3.2), Edit Author Slug (1.8.1), Forum_wordpress_fr (4.2), Hide/Remove Metadata (1.2.2), Jetpack by WordPress.com (9.2.1), Last Modified Timestamp (1.0.5), Molongui Authorship (4.2.13), PHP Compatibility Checker (1.5.0), Show Current Template (0.3.4), TablePress (1.12), The Events Calendar (5.3.1.1), WPFront Scroll Top (2.0.2)
    • Adresse du site : https://clgbeaulieu36.fr
    • Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    Bonjour,

    Quand un article est écrit par plusieurs auteurs, j’aimerais que l’ensemble des auteurs s’affichent dans l’article et pas seulement le nom du créateur de l’article. Seulement, je ne sais absolument pas dans quel fichier faire la modification ni même quel code je devrais ajouter.

    Quelqu’un pourrait-il m’aider sur ce sujet ?

    Avec mes remerciements par avance.

    Bien cordialement,

    Arthur36-

    • Ce sujet a été modifié le il y a 2 mois et 2 semaines par arthur36-.
    #2365080
    Kler
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    Je vois tu utilises Molongui Author Box ? Il me semble que ce plugin permet d’assigner plusieurs auteurs à un article, puis de l’indiquer dans les métadonnées de ton article, non ?

    • Cette réponse a été modifiée le il y a 2 mois et 2 semaines par Kler.
    #2365265
    arthur36-
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Le plug-in me permet en effet d’assigner plusieurs auteurs à un article dans l’espace de rédaction, mais seul le premier de la liste se trouve affiché sur la page en ligne, et non tous les auteurs. Et je ne vois rien dans le plug-in qui le permette. Ce qui me fait penser qu’il faut ajouter du code, mais lequel et où ?

    Merci de votre aide.

    #2365292
    mathieu42
    Participant
    Maître WordPress
    517 contributions

    avec les réglages par défaut de l’extension, les auteurs s’affichent à plusieurs endroits.

    donc c’est le thème qui pose problème, vous aurez peut-être plus d’aide en contactant le vendeur du thème.

    #2365293
    PhiLyon
    Modérateur
    Maître WordPress
    27432 contributions

    Bonjour.

    donc c’est le thème qui pose problème,

    J’ai testé dans le thème et ça fonctionne…

    C’est soit un réglage dans l’extension ou un conflit avec une autre extension, désactive-les une par une pour tester.

    🙂

    #2365296
    arthur36-
    Participant
    Initié WordPress
    4 contributions

    Je crois qu’on s’est mal compris PhiLyon.

    Le plug-in permet en effet d’afficher le nom de différents auteurs, mais sous la forme de lourdes bannières avec l’avatar et le nom. Effectivement, j’ai essayé cette option en l’activant dans le plug-in et ça fonctionne, mais ce n’est pas ce que je veux obtenir.

    Je souhaite que les noms des auteurs apparaissent là où il y a écrit “Par” tout en haut des articles (je te joins une capture d’écran d’une page article avec un cerclage).

    Et donc, j’aimerais trouver l’endroit dans le thème où il y a ce “Par” (“by”) pour changer le code et permettre l’affichage des autres noms. Et j’avoue que je ne sais pas où chercher.

    Encore merci pour votre aide.

    • Cette réponse a été modifiée le il y a 2 mois et 1 semaine par arthur36-.
    • Cette réponse a été modifiée le il y a 2 mois et 1 semaine par arthur36-.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2365300
    mathieu42
    Participant
    Maître WordPress
    517 contributions

    arthur36-, cela se règle dans l’extension, onglet “en ligne”, “On co-authored posts display” -> “all authors names”.

    cela est le réglage par défaut donc si PhiLyon a testé avec ce thème, il a surement aussi vu cette option.

    #2365301
    PhiLyon
    Modérateur
    Maître WordPress
    27432 contributions

    J’obtiens ce qu’il y a dans l’image jointe.

    🙂

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2365307
    arthur36-
    Participant
    Initié WordPress
    4 contributions

    Merci pour vos réponses.

    Mais du coup, le problème vient de chez moi, car j’ai bien coché l’option indiquée par mathieu42, et cela ne produit aucun effet contrairement à toi PhilLyon.

    J’ai désactivé également l’intégralité de mes extensions, et pas plus d’effet.

    J’avoue que je ne comprends pas !

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.