CODE HTML DANS PAGE OU ARTICLE

  • WordPress :4.9.9
  • Statut : non résolu
15 sujets de 16 à 30 (sur un total de 54)
  • Auteur
    Messages
  • #2247541
    Li-An
    Modérateur
    Maître WordPress
    22211 contributions

    Je vous conseillerai même de passer à php 7.1+

    #2247542
    Patrice
    Participant
    Padawan WordPress
    80 contributions

    je n’avais que 2 suspects : le Forum_wordpress_fr que j’avais installé ce matin !! et le détective …!

    Bon ! toujours aucune avancée ! je vais essayer de les désactiver un par un …

     

    #2247546
    Patrice
    Participant
    Padawan WordPress
    80 contributions

    en 7,1 , pas de contradictions pour le site ?

     

     

    #2247547
    Li-An
    Modérateur
    Maître WordPress
    22211 contributions

    C’est à dire que si votre thème ou une extension n’est pas compatible, il faudra sérieusement penser à la changer (en théorie il faudrait même php 7.2+).

    #2247548
    Li-An
    Modérateur
    Maître WordPress
    22211 contributions

    Et je suis curieux de voir si ça va corriger votre problème.

    #2247549
    Patrice
    Participant
    Padawan WordPress
    80 contributions

    a changer l’extension ou le thème ?

    on me déconseille le 7.2 car non stable !  c’est vrai ?

    #2247551
    Li-An
    Modérateur
    Maître WordPress
    22211 contributions

    C’est votre hébergeur qui vous dit ça (on est quand même à la 7.3) ? Perso j’évite la 7.2 qui est incompatible avec l’extension AMP mais bon.

    #2247569
    Flobogo
    Modérateur
    Maître WordPress
    15664 contributions

    Bonjour,

    @ferman :

    Vous pouvez aussi vous armer de patience et dans le tableau de bord désactiver les plugins les uns après les autres

    Quand la personne a accès à son tableau de bord, elle peut facilement désactiver toutes les extensions d’un seul clic : il suffit de cocher la 1ère case tout en haut de la liste des extensions, puis de cliquer sur “actions groupées” –> “désactiver”, et “appliquer”

    Passer par le FTP pour renommer le dossier plugins n’est nécessaire que lorsqu’on n’a pas accès au tableau de bord.

    @ pat de bo : passez tranquillement en PHP 7.0 ou 7.1, si possible, ce sera déjà bien. Et ça ne devrait rien changer au fonctionnement du site, sauf si vous avez une extension (ou un thème) non mis à jour depuis des années.

    Mais commencez déjà par désactiver vos extensions, car si il y en a une qui provoque ce bug dans l’éditeur, elle risque de ne pas être compatible non plus avec une version PHP récente, donc on n’avancera pas. Et autant modifier la version PHP quand les extensions sont désactivées, ainsi, si l’une d’entre elles n’est pas compatible avec la nouvelle version PHP, vous le saurez en la réactivant.

    Donc, une fois toutes les extensions désactivées, réactivez-les une par une, en commençant par celles qui vous semblent indispensables.

    #2247572
    ferman
    Participant
    Maître WordPress
    867 contributions

    Bonsoir,

    @flobogo.

    Exact j’aurais dû y penser.

    @pat de bo  (et ceux qui sont intéressés par le problème)

    Vous ne dites pas quand le problème est apparu. A la suite de quelle action? J’ai pas mal cherché et il y a pas mal d’exemples du problème mais pas de solution générale. En voici trois faciles à tester qui ont donné des résultats dans certains cas:

    1. aller dans la page profil, cocher la case “désactiver l’éditeur visuel” enregister puis décocher la case et enregister de nouveau
    2. ajouter la ligne suivante dans wp-config  :
      define( 'CONCATENATE_SCRIPTS', false );
    3. dans phpmyadmin, table user_meta: ligne meta_key “rich editing” vérifier que meta_value soit “true” vérifier aussi qu’il y a un “nickname”
    • Cette réponse a été modifiée le il y a 6 mois par  ferman.
    • Cette réponse a été modifiée le il y a 6 mois par  ferman.
    #2247617
    Patrice
    Participant
    Padawan WordPress
    80 contributions

    Bonjour à tous et merci de vos conseils !

    Je vais essayer de répondre à chacun :

    FERMAN : Je ne sais pas quand le problème est apparu. Ce site n’est pas  le mien, je viens de prendre des parts dans cette société et le reprend en cours de fonctionnement. Ce site est passé entre maintes mains et son proprio ne sait pas le comment du pourquoi …!

    J’ai activé et désactivé plusieurs fois l’éditeur visuel : aucun changement
    Concernant la prog, ne suis pas un pro, le ferais en dernier recours…

    FLOBOGO & LI-AN : je vais mette à jour certaines de mes extensions et vais passer en 7.1 . On me déconseille la 7.3 (OVH) en me disant que toute les extensions ne sont pas compatible (pour l’instant ! )

    D’après vous, dans mes extensions en place y aurait il des brebis galeuses 😉 . J’ai re-refais passer le plugin Detective. rien a signaler …aucun conflit, aucun trouble.

    je vais donc m’armer de patience et essayer de trouver l’extension qui cause ce problème.

     

    #2247621
    Li-An
    Modérateur
    Maître WordPress
    22211 contributions

    Évitez en effet 7.3, seul WP est compatible ou quasi. Désactivez tout et regardez. Ce n’est peut-être pas une extension (cela peut être le thème). Si vous ne savez pas si c’est un choix, il y a d’autres endroits où enquêter.

    #2247632
    ferman
    Participant
    Maître WordPress
    867 contributions

    @Li-An

    Bonjour,

    J’espère que les manips classiques (désactivation plugins et changements de thèmes) suffiront mais c’est un problème vraiment embêtant qui semble avoir ces causes multiples (et autant de solutions et parfois pas de solution trouvée). Ce post sur wordpress.org donne une petite idée du problème et il y en a d’autres du même tonneau sur le support wp, sur stack exchange, etc. Il y a encore quelques petites choses simples à essayer (voir ma réponse précédente) mais si ça ne marche pas je ne vois rien d’autre à faire. Je me demande s’il ne serait pas plus simple de réinstaller WP? Qu’en pensez-vous?

    D’un autre côté ce serait vraiment bien d’avoir la solution du pb qui ne semble pas être si rare que ça.

    #2247638
    Li-An
    Modérateur
    Maître WordPress
    22211 contributions

    Le problème arrive mais dans des conditions très particulières qui ne concerne pas la plupart des utilisateurs avec surtout des éléments indédendants de WP si j’en crois le lien que vous nous donnez où l’utilisation de Cloudflare semble être une des raisons invoquées régulièrement. Vous êtes chez quel hébergeur ?

    #2247650
    ferman
    Participant
    Maître WordPress
    867 contributions

    @Li-An

    Je suis chez OVH (comme pat de bo) mais je n’ai pas de problème. J’ai bien vu que cloud flare  peut être souvent impliqué mais ce n’est pas la seule raison, loin  de là. En fait sous une forme ou sous une autre le problème a été épisodiquement reporté depuis plusieurs années. Il est surprenant que pour un tel problème récurrent aucune vraie solution n’existe. Mais bon, on peut toujours réinstaller.

    @Pat de bo

    Avez-vous essayé avec un autre ordi ou un portable. Il a été reporté que le problème pouvait être spécifique à un ordi.

    • Cette réponse a été modifiée le il y a 5 mois et 4 weeks par  ferman.
    #2247652
    Li-An
    Modérateur
    Maître WordPress
    22211 contributions

    Parce que dans la plupart des cas, c’est une incompatibilité extension ou thème et que ce n’est pas à WP de corriger le problème.

15 sujets de 16 à 30 (sur un total de 54)
  • Vous devez être connecté pour répondre à ce sujet.