CODE HTML DANS PAGE OU ARTICLE

  • WordPress :4.9.9
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 54)
  • Auteur
    Messages
  • #2247360
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    Bonjour,

    Ma configuration WP actuelle :

    • – Version de WordPress : 4.9.9
    • – Version de PHP/MySQL : 5.4.45 / 5.6.42
    • – Thème utilisé : Shandora
    • – Thème URI : http://www.bonfirelab.com/themes/shandora
    • – Extensions en place : Akismet Anti-Spam (4.0.8), BackWPup (3.6.0), Bon Toolkit (1.3.2), Categories to Tags Converter Importer (0.5), Contact Form 7 (5.0.4), Duplicate Page (2.7), Facebook Like Box (2.9), Forum_wordpress_fr (4.1), Gravity Forms (1.9.13), Gravity Forms + Custom Post Types (3.1.13), Jetpack by WordPress.com (7.0.1), MailChimp for WordPress (4.2.4), POEditor (0.9.10), Search Everything (8.1.9), Taxonomies Filter Widget (2.0), UpdraftPlus – Backup/Restore (1.14.13), User Stats (1.0.7), WP-Members (3.2.2.1), WP-SpamShield (1.9.9.8.7), WP-UserOnline (2.87.1), WP Content Copy Protection & No Right Click (1.6.2), WP Simple Booking Calendar (1.5.3), Yoast SEO (8.1.2), ZenCache (160316), Zendesk Chat Widget (1.4.12)
    • – Adresse du site : https://fluvial-passion.com
    • – Nom de l’hébergeur : Apache / OVH

    Problème(s) rencontré(s) :
    Bonjour à tous.
    Je reprends plus clairement ma demande d’hier.
    lorsque j’écris un article ou une page directement dans wordpress le texte s’inscrit en langage HTML , alors qu’auparavant on pouvait écrire sans avoir à se soucier des balises.
    Il est donc maintenant difficile de faire les corrections …
    Comment puis je faire afin de ne plus avoir le code html lors de mon écriture. (voir pièce jointe)
    Merci de votre aide
    Patrice

    • Ce sujet a été modifié le il y a 3 mois par  Patrice.
    • Ce sujet a été modifié le il y a 3 mois par  Flobogo. Raison: suppression des balises HTML inutiles
    • Ce sujet a été modifié le il y a 3 mois par  Flobogo.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2247362
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    OUPS !

    pourquoi ces balises ??

     

    #2247379
    ferman
    Participant
    Maître WordPress
    542 contributions

    Bonjour,

     

    Sur votre site les pages apparaissent normalement. Je crois simplement que votre éditeur visuel est désactivé. Comment et pourquoi je ne sais pas. Allez dans votre profil et vérifiez  déjà que la case « désactiver éditeur visuel pour écrire » n’est pas cochée.

    Autrement, désactivez les plugins et voyez si le problème persiste.

    • Cette réponse a été modifiée le il y a 3 mois par  ferman.
    #2247386
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    Effectivement tout est ok sur mes pages en front end, mais dans le back c’est l’éditeur de texte qui me fait apparaitre les balises

    Je ne peux pas faire un gras sans avoir les balises strong et ainsi de suite pour chaque balise …

    Notez bien que tous les bateaux sont à visiter en Hollande

    <h4 style= »font-style: normal; »><span style= »color: #000000; »>Tous nos bateaux n’étant pas répertoriés sur le site, n’hésitez pas à nous contacter pour votre recherche !</span></h4>

    Je n’arrive pas a comprendre pourquoi je ne peux pas écrire sans code ….Dans cette éditeur je peux mettre en gras ou en italique sans subir les balises !!

    Merci du soutien

    #2247388
    ferman
    Participant
    Maître WordPress
    542 contributions

    Normalement vous avez deux éditeurs : texte et visuel et vous pouvez basculer entre les deux. Là il semble que votre éditeur visuel ait disparu (on ne voit pas les onglets visuel et texte en haut à droite) . Avez-vous vérifié dans votre profil. Sinon, ça peut-être un problème de plugins et, comme dit plus haut, pour le savoir il faut les désactiver.

    • Cette réponse a été modifiée le il y a 3 mois par  ferman.
    #2247392
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    j’ai vérifié dans mon profil et mon éditeur visuel est activé.

    pour le plug in .. il faut trouver le bon … 🤔 un moyen afin de le trouver ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2247398
    ferman
    Participant
    Maître WordPress
    542 contributions

    On désactive tous les plugins en renommant le dossier plugins en pluginX par exemple. Si le problème ne disparaît pas, réactivez vos plugins. Si le problème disparaît on les réactive un à un jusqu’à ce que le problème réapparaisse. Pensez à vider le cache de votre navigateur à chaque fois.

    Je viens juste de me rendre compte que votre php est dépassé. Il faut au moins passer en 5.6 ou mieux 7 ou 7.2

     

    • Cette réponse a été modifiée le il y a 3 mois par  ferman.
    • Cette réponse a été modifiée le il y a 3 mois par  ferman.
    • Cette réponse a été modifiée le il y a 3 mois par  ferman.
    #2247405
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    oups, ne suis qu’un amateur ! qui essaye de comprendre le fonctionnement de WP …

    Donc je désactive toutes mes extensions ( les 25 qui sont dans ma config.? )

    Avant de tout désactiver … D’après vous , y en aurait il une qui serait susceptible de causer problème ?

    et comment faire pour renommer le dossier Extensions ?

     

    #2247436
    ferman
    Participant
    Maître WordPress
    542 contributions

    Non, je n’ai pas d’idée concernant le plugin éventuellement coupable. Peut-être sont-ils tous innocents! Autrement, pour renommer le dossier plugin Il faut passer par FTP et accéder aux fichiers et dossiers de votre hébergement. Le dossier « plugins » est dans le dossier « content ».

    Vous pouvez aussi vous armer de patience et dans le tableau de bord désactiver  les plugins les uns après les autres  en vérifiant à chaque fois le résultat.

    Mais en premier lieu, passez à une version acceptable de PHP: OVH espace client; c’est très facile et on peut revenir en arrière mais attention pas jusqu’à php 5.4 qui n’est plus dans la liste de choix car complètement dépassé. Peut-être que ça suffira.

    • Cette réponse a été modifiée le il y a 3 mois par  ferman.
    #2247443
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    merci de tout ces conseils. Je vais donc améliorer mon PHP !  pas d’incidence sur le bon fonctionnement du site ?

    et ensuite je pars à la recherche du coupable …🧐

    #2247450
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    pas mal de mise en garde !! sur la compatibilité !! dois je vraiment les suivre ?

    je suis sous environnement d’exécution Légacy. dois je modifier en stable comme le préconise OVH ?

    #2247466
    ferman
    Participant
    Maître WordPress
    542 contributions

    Pour ce qui est du changement d’environnement de Legacy à stable je ne sais pas. Apparemment on peut revenir en arrière mais il peut y avoir des problèmes côté serveur Donc je ne peux rien conseiller.  Vous pouvez déjà essayer de voir côté plugins mais un jour il faudra bien franchir le pas pour aller vers une configuration stable..

     

    #2247503
    ferman
    Participant
    Maître WordPress
    542 contributions

    Au sujet du passage Legacy > Stable, voir ce post  sur ce forum.

    #2247526
    Li-An
    Modérateur
    Maître WordPress
    21692 contributions

    Pour simplifier les recherches des plugins coupables https://www.echodesplugins.li-an.fr/plugins/plugin-detective/

    #2247534
    Patrice
    Participant
    Padawan WordPress
    77 contributions

    Merci de vos conseils. suis passé en php 5,6 , environnement stable. Pour l’instant tout va bien …. wait & see

    et vais chercher le coupable grâce au plugin . Merci

    Je vous tiens au courant

     

15 sujets de 1 à 15 (sur un total de 54)
  • Vous devez être connecté pour répondre à ce sujet.