Code apparaît dans le lien hypertexte (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 19)
  • Auteur
    Messages
  • #557529
    Reivax
    Participant
    Initié WordPress
    44 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.4
    – Version de PHP/MySQL : 5.5
    – Thème utilisé : Perso
    – Extensions en place :
    – Nom de l’hebergeur : OVH
    – Adresse du site :

    Problème(s) rencontré(s) : Code apparaît dans certains lien externes.

    Bonsoir à tous,

    Voilà ce que j’ai parfois sur certains lien qui pointent vers d’autres sites. Une partie du code apparaît en clair et le lien ne fonctionne pas alors qu’il dirige bien vers les sites en question. Je n’arrive pas à savoir ce qu’il se passe alors que tout était bon avant.
    J’ai beau changer le lien d’une manière ou d’une autre, en le raccourcissant mais rien n’y fait. J’ai aussi cherché un peu partout sans trouver une explication ou solution.

    Merci par avance.

    [img]https://lh3.googleusercontent.com/rdSLBqWQfcFJYms35GJ7dMeq1Il1tPeykWaI3B6jAUW3GyK8gBXse06-MthhbZAgEUlDxPdvld1Kj_pm4FcRZQuN_mkPRrRregKS-tXEsaQuESSLDVBkFqbjbz378W9AAg6YoRUQ4rlgvASyd17lsO491OlO4TMMwwE1RnONqc-zAnMk8GZy7YuWn92kNBwbUmdHSuI32BBVQkn2ifT3O9gImCqy0ZlKGevw27w_KNH8n3add9nQ3knJPGGtwiHV-OEomXy1UCkPQSosTv4lgdRGLofFj-3p4k3cC2KqqeGdP_yhOOvj4KPhpBnstPM8GZNpHeKxx49hpo2CSGqx0If4unIEhGBgoUGdqZLY3xDeZQX0wdbEAK7FiSlH3NBOPjb6CIFpkIMe90yvbSQBQ2j5Yi86RepNYnCKFzzng1Vx6WjLDebMcm6LedMmtaiK03vt8jn_JCDC1PqMb5PGaLhlWi5_Wnh8qDd8pFV-pAqdCC16GvaKRWQ7u0yi4gPSbjJ8sgBtjoKPXhEBst5VS6rm5suK0ne48DuqGC4GODRVtNbzZ3bgc4u_lli2HLQgBKmW=w167-h42-no[/img]

    #1032843
    ouistiti.net
    Participant
    Maître WordPress
    1879 contributions

    Bonjour,

    Vous mettez votre code directement dans le fichier concerné ou via le panel de WordPress ??

    Si c’est via WP, vérifier que vous le mettez bien via l’onglet « Texte »

    Possible qu’il y a une erreur dans le html, mais ainsi, avec si peu de renseignement accompagné, difficile de vous en dire plus.

    #1032844
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    Bonjour,

    Si c’est target= »_blank » qui vous inquiète, vous pouvez être rassuré : ça veut juste dire que lors de l’insertion du lien, vous avez coché la case pour qu’il s’ouvre dans une nouvelle page.
    C’est tout, pas de quoi s’inquiéter, c’est le code normal pour faire ça 😎

    #1032845
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Bonjour.

    @ Flobogo – clexav a dit

    Une partie du code apparaît en clair

    Je pense qu’il veut dire sur le site en ligne.

    @ clexav – Peux-tu nous envoyer la partie de l’article/page en mode texte. C’est bien dans une page/article ou dans un widget.

    L’url aurait été plus pratique.

    🙂

    #1032846
    ouistiti.net
    Participant
    Maître WordPress
    1879 contributions

    J’ai même pas été foutue de finir ma phrase : Possible qu’il y a une erreur dans le html, mais ainsi, avec si peu de renseignements accompagnés d’une toute petite image, difficile de vous en dire plus. :fouet:

    #1032847
    Reivax
    Participant
    Initié WordPress
    44 contributions

    Bonjour,
    Merci de vos nombreuses réponses. Je vous met le lien vers un article qui montre ce que cela donne. C’est effectivement sur la partie en ligne que ça apparaît. Flobogo, je sais que c’est normal puisque cela redirige vers des site externes, en rajoutant que cela ne le fait pas avec tous les sites, ce sont que certain liens sur lequel le problème se pose. ouistiti.net j’ai rentré le lien aussi bien par le panel de WordPress que via l’onglet texte.

    Une petite précision tous les liens sont bons, je les ai testé directement par mon navigateur, parfois ils revoient vers une page type « La page est introuvable » ou bien rien ne se passe au clique. Dans l’exemple de cette page : http://asso-phénix.fr/note-dactualite-vih-hepatites-ist/, dans le premier lien c’est « La page est introuvable ».

    #1032848
    Reivax
    Participant
    Initié WordPress
    44 contributions

    Oups !!!

    Avec ça c’est mieux
    [url]http://asso-phénix.fr/note-dactualite-vih-hepatites-ist/[/url]

    #1032850
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    Bon, OK je me suis trompée … mais vos liens sont (semble-t-il) très mal insérés :fouet:

    Par exemple, le 1er lien renvoie vers la « page suivante » : http://www.inpes.sante.fr/30000/actus2015/063-journee_mondiale_lutte_contre_<span class=
    Qu’est-ce que ce <span class= fout dans le lien ? C’est normal qu’il renvoie vers une page introuvable :rolleyes:

    Et voilà ce que donne le HTML :

    <a data-wpel-target="_blank" class="ext-link ext-icon-8" rel="external nofollow" title="<p><span class="st">Syndrome d'Immunodéficience Acquise</span></p>
     » act-tooltip »= » » href= »http://www.inpes.sante.fr/30000/actus2015/063-journee_mondiale_lutte_contre_<span class= »>sida.asp » target= »_blank » rel= »nofollow »>Nouvelle campagne de sensibilisation au dépistage du sida

    Bref, les balises de span n’ont rien à faire dans vos liens !
    A mon avis, c’est quand vous mettez les liens dans l’éditeur de Text (HTML) que vous vous trompez.

    #1032851
    Reivax
    Participant
    Initié WordPress
    44 contributions

    Je suis tout aussi étonné je ne fais que sélectionner un mot ou une phrase, je clique sur le bouton lien, je colle le lien, j’ajoute blank et c’est tout. Et pourquoi ça le fait que sur certain lien vu que je fais la même manipe pour tous les liens l’erreur se répéterai sur tous les liens. Doit y avoir un truc sur certain lien que je copie, je crois que je devrait les coller dans un éditeur de texte avant de faire les liens dans wordpress.

    #1032852
    Reivax
    Participant
    Initié WordPress
    44 contributions

    Voilà un copie collé d’une partie de cet article que j’ai collé dans notepad++ les balises span n’apparaissent pas. Je ne suis pas un grand spécialiste du codage, mais les liens me semblent correctes.

    VIH

    Nouvelle campagne de sensibilisation au dépistage du sida

    Pour la Journée mondiale de lutte contre le sida 2015, l’INPES a lancé une campagne d’incitation au dépistage du VIH et des autres IST.

    VIH : Les autotests… et vous ?

    #1032853
    Reivax
    Participant
    Initié WordPress
    44 contributions
    <p style="text-align: justify"><!--more--></p>
    <h2 style="text-align: justify">VIH</h2>
    <p style="text-align: justify"><a href="http://www.inpes.sante.fr/30000/actus2015/063-journee_mondiale_lutte_contre_sida.asp" target="_blank" rel="nofollow">Nouvelle campagne de sensibilisation au dépistage du sida</a><br />
    Pour la Journée mondiale de lutte contre le sida 2015, l’INPES a lancé une campagne d’incitation au dépistage du VIH et des autres IST.</p>
    <p style="text-align: justify"><a class="lien" href="http://corevihaa.limequery.com/index.php/survey/index/sid/692588/newtest/Y/lang/fr" target="_blank">VIH : Les autotests… et vous ?</a><br />

    #1032849
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Bonjour.

    je clique sur le bouton lien, je colle le lien, j’ajoute blank

    Pourquoi ajouter blank alors qu’il suffit de cocher la case Ouvrir le lien dans un nouvel onglet ?

    🙂

    #1032854
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    Par ailleurs, même si ça n’a sans doute rien à voir, il est tout à fait inutile de mettre style= »text-align: justify; » à chaque ligne.
    Si vous voulez que l’ensemble de vos textes soient justifiés, il faut le définir dans le CSS. (fichier style.css)

    Idem si c’est pour certains paragraphes. Vous créez une class justify comme ça :

    .justify {text-align: justify;}

    Et vous appliquez la class à la

    contenant votre paragraphe à justifier.

    A l’inverse, ça n’a rien à faire sur un titre h2 : je doute que vous ayez un titre important sur plus d’une ligne ! :rolleyes:
    Attention à ne pas confondre les h1 / h2 / h3 … qui sont réservés aux titres avec la balise pour mettre les mots importants en gras, ou même avec la taille des caractères : il suffit d’augmenter la font-size si c’est pour écrire plus gros.

    Un peu d’aide sur le HTML ?
    http://css.mammouthland.net/balises-html.php
    http://www.deepintheweb.com/les-bases-du-html-pour-les-nuls-les-balises-principales-12/
    – et bien sûr : https://openclassrooms.com/courses/apprenez-a-creer-votre-site-web-avec-html5-et-css3/comment-fait-on-pour-creer-des-sites-web

    #1032855
    ferryd
    Participant
    Chevalier WordPress
    297 contributions

    Bonjour,

    Il semblerait que vos liens ne fonctionne pas correctement lorsque vous avez des mots associés à Tooltips dans la balise « title » du lien. Essayer de déactiver le plugin « advanced-custom-tooltips »

    #1032857
    Reivax
    Participant
    Initié WordPress
    44 contributions

    Merci de vos aides, les tooltips ne gênent pas d’autres liens en ont sans faire le moindre problème. Et pour ce qui est de justify, je ne fais que sélectionner un text ou un paragraphe et je clique sur justifier.

15 sujets de 1 à 15 (sur un total de 19)
  • Vous devez être connecté pour répondre à ce sujet.