CMS : probleme avec l’architecture wordpress (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 13 années et 5 mois.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #451663
    Anonyme
    Inactif
    Initié WordPress
    9 contributions

    Bonjour à tous !!!!!

    Déja en tant que nouveau sur ce forum je tient à tous vous dire un petit bonjour et un grand merci pour les eventuelles réponses que certains pourront m’apporter.

    Déja je précise que bien que je découvre à peine wordpress , je ne suis pas débutant en php/css/xhtml (pas la peine de s’embeter à la faire bien pédago) , c’est juste que j’ai un petit souçi , là dans le cadre de l’utilisation de wp en CMS.

    bon tout d’abord,
    – Version de WordPress : 2.1.2
    – Thème utilisé : inspiré de pool (cool pour apprendre)
    – Plugins en place : aucun
    – Nom de l’hebergeur : free
    – Adresse du site : http://audrasjb.free.fr/test/wordpressfr/

    Problème(s) rencontré(s) : alors voila je veut utiliser le menu de haut de page (“pages”) pour présenter mon site dans cet ordre :
    1er lien du menu – Lien page d’accueil : je ne veut pas d’articles dans cette page, je veut juste présenter le site ici, donc je ne veut pas y utiliser la boucle have_post ou rien du tout, mais par contre je veut que le bandeau de haut de page (logo du site) pointe vers cette page ainsi que tous les liens du genre retour à l’accueil. D’après moi ce fichier doit être le index.php (pour que ce soit cette page qui se charge à l’accueil) mais sans boucle have_post car je n’affiche pas les articles ici.

    2éme lien du menu – Page d’actualités : je veut ici afficher les articles publiés. donc je pensait faire un fichier actualités.php qui contient la boucle have_post normalement contenue dans index.php.

    En gros : si vous allez sur le site, vous verrez que ça marche presque. La page d’accueil se charge sans problème, mais par contre si on clique sur actualités , le lien vers actualités.php ne marche pas. Comment ce fait-ce ? pourtant le fichier actualites.php existe bien..
    chuis un gros :boulet: !!!!!!

    #598457
    yumiam
    Membre
    Padawan WordPress
    98 contributions

    ce que je ferais :
    – pour faire une page d’accueil spécifique, tu crées une page home.php…(elle prends le dessus sur index.php)
    – tu assignes à tous tes articles une catégories (“actualités” par exemple), le deuxieme element de ton menu renvoi vers le template “archive.php” qui cible ta catégorie “actualités”…

    #598458
    Anonyme
    Inactif
    Initié WordPress
    9 contributions
    yumiam wrote:
    le deuxieme element de ton menu renvoi vers le template “archive.php” qui cible ta catégorie “actualités”…

    Ok c’est bon j’ai capté, je fais comme ça et ça a l’air de tourner… merci beaucoup.

3 sujets de 1 à 3 (sur un total de 3)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.