Chaos dans les URLs et erreurs 404 suite à modifications permalinks (Créer un compte)

  • WordPress :4.9
  • Statut : non résolu
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #2072604
    YesICannes
    Participant
    Initié WordPress
    42 contributions

    Ma configuration WP actuelle
    • Version de PHP/MySQL : inférieure à 5.6
    • Thème utilisé : Viewport
    • Extensions en place : Askimet, AMP, Google Adsense, GADWP, Image Widget, Polylang, Publish to Apple News, Redirection, Simple Light Box, WP Rocket, Yoast
    • Nom de l’hébergeur : Infomaniak
    • Adresse du site : yesicannes.com et yesicannes.com/fr

    Problème(s) rencontré(s) : Chaos dans les URLs et erreurs 404 suite à modifications permalinks

    Bonjour,

    Suite à deux modification dans les permalinks, j’ai un chaos dans les URLs occasionnant d’innombrables erreurs 404

    YesICannes est un magazine web en 2 langues: yesicannes.com et yesicannes.com/fr. Les reportages sont indexés dans GoogleNews et donc, les URLs des articles doivent inclure des chiffres.

    Jusqu’à récemment, mes permalinks étaient ainsi: yesicannes.com/%postname%.
    Pour ajouter les chiffres souhaités par Google, je faisais un préview du post et ajoutais le “post id” manuellement séparé du titre de l’article par un “-“.

    Puis, j’ai pensé faire automatiquement cette insertion en modifiant les permalinks et avec la forme suivante:  yesicannes.com/%postname%/%post_id%/.
    Surprise, les liens s’affichaient: yesicannes.com/nomdupost/post_id/post_id/ avec donc deux fois le numéro inséré automatiquement (!?) mais je n’avais pas d’alerte.

    Or, je me suis dit qu’avec un “/” comme séparateur, cela ne ressemblait pas aux URLs créés jusqu’ici, et j’ai changé une 2ème fois les permalinks en passant du “/” au “-” pour obtenir yesicannes.com/%postname%-%post_id%/.

    J’ai alors commencé à recevoir des appels de visiteurs qui avaient des erreurs 404 dans les derniers reportages publiés et Goolge m’a envoyé un Mail “Augmentation des pages”404” sur http://yesicannes.com/ et http://yesicannes.com/fr/, message de type [WNC-658800].

    Bon, je comprends que passer du “/” au “_” puisse créer des erreurs 404, et je réalise mon erreur. Mais le problème est plus inquiétant: les erreurs 404 sont issues de ce genre de lien, (alors que l’URL normale est : http://yesicannes.com/fr/mouratoglou-tennis-academy-sophia-antipolis-33009)

     

     

     

    http://yesicannes.com/fr/mouratoglou-tennis-academy-sophia-antipolis-33009/33009/mouratoglou-tennis-academy-inauguration-10/

    Autre exemple d’erreur 404 : (alors que http://yesicannes.com/fr/mouans-sartoux-miel-ciel-provence-36831/ est bon)

    http://yesicannes.com/fr/mouans-sartoux-miel-ciel-provence-36831/36831/fete-du-miel-mouans-sartoux-2017-12/

    Le numéro se répète avec une sorte de réplication du nom du post… Quelqu’un aurait-il une idée de ce qui se passe et comment palier cette embarrassante situation?

    Merci par avance de votre aide.

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.