changement version PHP : quelles conséquences ?

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 29)
  • Auteur
    Messages
  • #551228
    Flobogo
    Modérateur
    Maître WordPress
    15328 contributions

    Bonjour,

    Ma configuration WP actuelle :

    – Version de WordPress : 4.2.2
    – Version de PHP/MySQL : 5.3.29 / 5.5.42-cll
    – Thème utilisé : Air Balloon – Child (personnalisé)
    – Extensions en place : Akismet (3.1.2), Autoptimize (1.9.4), Basic Google Maps Placemarks (1.10.4), Category Tag Pages (1.0), Cocorico Social (1.2.1), Conditional CAPTCHA (3.7.1), Contact Form 7 (4.2), Forum_wordpress_fr (3.9), Gwolle Guestbook (1.4.1), Links Shortcode (1.8.1), MMWW (1.0.6), PS Auto Sitemap (1.1.8), Really Simple CAPTCHA (1.8.0.1), Rocket Lazy Load (1.0.4), RSS Includes Pages (1.4.3), Slideshow (2.2.23), TinyMCE Advanced (4.1.9), WordPress Database Backup (2.2.4), WordPress SEO (2.2.1), WP-Optimize (1.8.9.10)
    – Adresse du site : http://www.mon-coin-de-bourgogne.fr
    – Nom de l’hébergeur : Archive-Host

    Problème(s) rencontré(s) : Il ne s’agit pas d’un problème, au contraire, j’anticipe 😉

    Actuellement, mon site utilise PHP 5.3 qui était proposé par défaut lorsque j’ai souscrit mon offre d’hébergement chez Archive-Host en 2012.
    L’hébergeur propose depuis plusieurs mois déjà de choisir la version 5.3 ou 5.4 ou 5.5, le changement se fait « en un clic » dans mon CPanel.

    Bien … mais quelles conséquences cela peut-il avoir sur le fonctionnement de mon site ? Tous mes plugins (nombreux, je sais) seront-ils compatibles ? (comment le savoir ?)
    Y a t-il des précautions indispensables à prendre avant de changer ? D’ailleurs, me conseillez-vous PHP 5.4 ou 5.5 ?

    Merci d’avance 🙂

    #1010533
    Li-An
    Modérateur
    Maître WordPress
    21533 contributions

    Il est conseillé d’utiliser toujours la version la plus récente qui est censé être plus rapide – il parait que php 7 fera des miracles avec WP. Si le plugin n’est pas compatible, il est bon pour la poubelle… En général, c’est plutôt le contraire, les plugins demandent des versions supérieures en php. Et rien n’empêche de revenir en arrière.

    #1010534
    C_Lucien
    Modérateur
    Maître WordPress
    3711 contributions

    Bonjour,

    la compatibilité de chaque plugin avec Php 5.4, s’ils ont été mis à jour dans les derniers mois, ne devrait pas poser de problème.
    OVH m’annonçait encore récemment « * PHP 5.3 (fin de vie depuis plus de 8 mois) »
    Sinon, leurs développeurs respectifs en ont peut-être annoncé la compatibilité sur leur support (FAQ, forum, changelog).

    Je suis passé directement à Php 5.5, pour ne pas avoir à m’en soucier pendant quelque temps. Il est vrai cependant que mon site n’a que très peu d’extensions.

    #1010536
    Flobogo
    Modérateur
    Maître WordPress
    15328 contributions

    Merci de vos avis 🙂

    OVH m’annonçait encore récemment « * PHP 5.3 (fin de vie depuis plus de 8 mois) »

    Oui, c’est parce que j’ai vu ce genre de message sur le forum que j’ai commencé à me poser des questions.
    Et quand je vois maintenant que même Free va passer ses espaces d’hébergement en PHP ++ je me dis qu’il est temps que je change.

    Je ferais le « grand saut » le WE prochain, là il est trop tard, en cas de bug je n’aurais pas le temps de m’en occuper.

    #1010537
    PhiLyon
    Modérateur
    Maître WordPress
    22314 contributions

    @ Flobogo – :hs:

    Tu as vu nous sommes attaqués par un essaim d’Abelle 😆

    Fallait que je la fasse.

    🙂

    #1010538
    Flobogo
    Modérateur
    Maître WordPress
    15328 contributions

    Oui, j’ai demandé qu’on les pique … supprime 😆

    #1010535
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    Tous mes plugins (nombreux, je sais) seront-ils compatibles ? (comment le savoir ?)

    Il n’y a pas vraiment de moyen de le savoir sans le tester ou analyser le code. Néanmoins, une bonne indication est la mise à jour régulière de l’extension. Si elle n’est plus mise à jour depuis plusieurs mois ou années le risque de compatibilité augmente si au contraire les mises à jour sont régulières on peut supposer que l’auteur aura corrigé d’éventuels problèmes de compatibilité.

    Y a t-il des précautions indispensables à prendre avant de changer ?

    Une sauvegarde comme d’habitude par précaution pour avoir une version du site à jour en cas de problème ou de fausse manip. En dehors de cela, il est toujours possible de revenir en arrière si la version ne convient pas le temps de corriger le problème, c’est donc nettement moins critique qu’une mise à jour.

    D’ailleurs, me conseillez-vous PHP 5.4 ou 5.5 ?

    La date de fin de support prévue pour PHP 5.4 est dans un peu plus de 2 mois en septembre 2015. Donc, si les extensions installées supportent PHP 5.5 mieux vaut directement utiliser cette version, tu seras tranquille pour 1 an au lieu de 2 mois et demi 😉

    #1010539
    Flobogo
    Modérateur
    Maître WordPress
    15328 contributions

    @ Fge :
    Merci pour ces précisions. Du coup, je tenterai le passage en PHP 5.5, on verra. Surtout si le retour arrière est facile.
    Et ce sera peut-être l’occasion de me débarrasser de quelques plugins ou d’en trouver des neufs 😉

    #1010540
    ouistiti.net
    Participant
    Maître WordPress
    1905 contributions

    Je l’ai fait pour une tierce personne chez infobulle (pour ne pas faire de la pub) et en plus, une migration du site sur leur nouvelle console (qui a posé plus de problèmes vu que je me suis retrouvée sur un autre serveur et que je continuais à mettre mes fichiers via FTP sur l’ancien 😉).

    Mais en ce qui concerne la mise à jour du PHP, cela a pris environs 24h00, je ne sais pas si c’est le cas chez tous les hébergeurs.

    N’ayant pour ainsi dire pas de plugins (2), je n’ai pas remarqué pour l’instant un quelconque bug.

    Voici mon partage d’expérience, les yeux fermés :D.

    Comme il a été mentionné ne pas oublier de faire un backup.

    #1010541
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    Les changements de serveurs sont rares, perso, je l’ai vu sur des changements de formule ou des changement de matériels mais je ne me rappelle pas l’avoir vu juste pour un changement de version de PHP. Dans ce cas, effectivement le retour en arrière n’est probablement pas possible. Généralement, chez la plupart des hébergeurs c’est un simple paramètre qui défini la version du moteur PHP à utiliser sans avoir à changer de serveur.

    #1010542
    ouistiti.net
    Participant
    Maître WordPress
    1905 contributions

    @fge J’ai bel et bien reçu un mail de l’hébergeur, mais ils sont restés très flou du pourquoi et du comment… Il était mentionné: pour diverses raisons nous avons …

    #1010543
    Flobogo
    Modérateur
    Maître WordPress
    15328 contributions

    Comme il a été mentionné ne pas oublier de faire un backup.

    C’est bien mon intention. 🙂
    J’ai une copie locale fraîchement réinstallée de mon site à l’identique + copie des fichiers dans un dossier + copie de la BDD et des tables une à une. Je crois que je suis « blindée » en sauvegardes 😉

    Mais c’est important de le redire pour d’autres qui passeraient par là.
    J’ai vu ce soir un autre topic du forum où il était question des versions de PHP.

    #1010544
    Marcall
    Membre
    Initié WordPress
    3 contributions

    Bonjour a tous,

    Je rencontre actuellement le meme probleme de necessite de migrer vers PHP 5.4 chez OVH.
    Je m’excuse a l’avance: je ne suis absolument pas « tech » – j’ai de grosses lacunes. Je recherché de l’aide pour comprendre comment savoir quelle version de WP mon site utilise actuellemernt, sachant qu’OVH m’indique que je dois verifier que si cette version est compatible avec PHP 5.4. (Mon site tourne actuellement sous pP 5.2)

    Merci par avance!

    #1010545
    ouistiti.net
    Participant
    Maître WordPress
    1905 contributions

    Bonjour Marcall,

    Il est conseillé d’ouvrir un nouveau topic…
    Pour répondre à votre question, il faut vous rendre dans l’admin avec votre identifiant et mot de passe. Ensuite via le tableau de bord, dans le coin du bas à droite, il est mentionné la version de WordPress installée pour votre site internet.

    #1010546
    Marcall
    Membre
    Initié WordPress
    3 contributions

    Bonjour,
    Merci infiniment pour votre reponse et desole de n’avoir pas ouvert un nouveau topic (je suis tout nouveau ici).
    L’admin m’indique simplement « Téléchargez la version 4.2.2 » – sans mention de la version actuelle..
    Je suis inquiet que mon site cesse de fonctionner en septembre et OVH me propose d’effectuer pour moi la migration vers PHP 5.4 (moyennant 40 euros HT), mais au prealable ils m’indiquent  » qu »il est que votre application Web ne soit pas compatible avec une version récente de PHP, et génère par exemple des pages blanches ou des messages d’erreurs suite à cette migration. Je vous invite donc à vous rapprocher du support de WordPress, afin de vous assurer que votre site sera compatible avec une version récente de PHP »
    Merci pour votre eclairage..

15 sujets de 1 à 15 (sur un total de 29)
  • Vous devez être connecté pour répondre à ce sujet.