Changement de domaine de site partiellement réalisé (Créer un compte)

  • WordPress :5.3
  • Statut : non résolu
  • Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par laclac, le il y a 3 mois.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2335598
    laclac
    Participant
    Initié WordPress
    22 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Thème utilisé : Divi
    • Extensions en place :
    • Nom de l’hébergeur : OVH

    Problème(s) rencontré(s) :

    Bonjour,

    J’avais changé le domaine de mon site wordpress. Je l’ai changé dans Réglage/Générale ainsi que sur OVH, c’est tout et ca a bien marché.

    Je voulais désormais désactiver mon ancien nom de domaine, mais je me suis rendu compte que dans le code source de mon wordpress, j’ai quelques images qui pointe sur lancien domaine: l’image du logo, une image en background etc…

    Je me demande si j’ai fais un mauvais truc, et si il y a une solution propre pour tout migrer ?

    Ou est ce que je dois checker toutes les pages et changer manuellement l’url des images concernées dans wordpress ?

     

    Merci davance,

    #2335620
    ferman
    Participant
    Maître WordPress
    2628 contributions

    Bonjour,

    Pour changer les liens, vous pouvez utiliser l’extension better search replace .   Soyez sûr d’avoir une sauvegarde de votre base de données actuelle. Better search replace est facile à utiliser mais comme il modifie la base de données, les erreurs peuvent être graves et on ne peut pas toujours revenir en arrière.

    On peut faire un essai à blanc qui vous donne le nombre de remplacements pouvant être effectués. Si le chiffre vous paraît anormal vous annulez.

    Cela dit, je n’ai jamais entendu parler de problème avec cette extension

     

    #2336699
    laclac
    Participant
    Initié WordPress
    22 contributions

    Bonjour ferman,

    Merci beaucoup. J’ai testé ce que tu disais et ca a très bien marché. J’avais environs 2000 références. Aucun probleme identifié sauf un.

    Mes icones de reseaux sociaux avaient disparu. Assez étrange puisqu’ils n avaient aucune référence de l ancien site meme aucun dépéndance. Mais apr(s 10min c’est revenu tout seul 🙂

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.