Changement d’adresse du blog, et plantage de Wp

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 26)
  • Auteur
    Messages
  • #447167
    cjuliet
    Participant
    Initié WordPress
    14 contributions

    bonjour à tous,

    Notre wordpress étant en fin satisfaisant niveau contenu on a crée un nom de domaine pour lui….les 2 sites marchaient : l’ancien adresse et le nouveau nom de domaine.
    Puis dans l’admin de WP j’ai changé les données concernant l’ « adresse de wordpress » et l' »adresse du blog » dans l’admin (ds « options »)
    et, en appuyant sur mise à jour
    tout a planté et impossible d’accéder ni a l’admin ni au site sur les deux adresses…A la place une erreur internal serveur 500 …. snif…..

    J’ai cherché sur le forum mais pas trouvé de problème exactement similaire…Quelqu’un peut il m’aider?

    merci d’avance

    #571254
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Lorsque tu fait cette opération e modification d’adressage de WP, il faut également que tu déplaces ton fichier index.php de WP et que tu l’édites avec ton éditeur de texte favoris (bloc-note…) afin de modifier dedans l’adressage aussi. C’est à l’endroit où est écrit : /wp-header-blog.php/
    Il faut que tu ajoutes devant /nomdetonnouveaudossier/wp-header-blog.php/

    Normalement tout devrait rentrer dans l’ordre.

    #571255
    cjuliet
    Participant
    Initié WordPress
    14 contributions

    merci beaucoup de la réponse

    je vais tester ça de suite 🙂

    #571256
    cjuliet
    Participant
    Initié WordPress
    14 contributions

    ok, je peux me permettre de demander une précision?

    le fichier index, je le déplace où ?

    #571257
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    En fait le fichier index.php doit se trouver dans le dossier dans lequel tu souhaites que ton blog apparaisse.

    Si ton WP se trouve dans monsite.com/blog et que tu veux que lorsque tu fais monsite.com ton blog s’ouvre il faut simplement que tu mettes index.php à la racine en faisant comme je t’ai dit précédemment.

    Suis-je clair dans ce je dis ?

    #571258
    cjuliet
    Participant
    Initié WordPress
    14 contributions

    Oui c’est cler 🙂

    mais bon ça marche toujours pas… je vais perseverer, et je donnerais des nouvelles…
    merci de ton aide en tout cas

    #571259
    AmO
    Participant
    Maître WordPress
    4452 contributions

    A la place une erreur internal serveur 500 …. snif….. ?

    Efface ton fichier .htacess?

    #571260
    cjuliet
    Participant
    Initié WordPress
    14 contributions

    même s’il est vdie, il faut le supprimer?

    #571261
    Aline
    Participant
    Padawan WordPress
    82 contributions

    oui

    justement si il est vide il ne sert a rien

    #571262
    cjuliet
    Participant
    Initié WordPress
    14 contributions

    le problème est toujours pas résolu…, ça devient très embetant…
    En fait il n’y a pas de fichier .htaccess, c’est une option sur le site de l’herbergeur qui porte ce nom (dreamhosters), donc rien a supprimer à priori.

    Quelqu’un a une idée ? Comment revenir en arrière ? comment récuperer l’admin ?

    #571263
    Aline
    Participant
    Padawan WordPress
    82 contributions

    désactive cette option (dreamhosters) !!!

    donne le lien de ton blog pour qu’on puisse voir ça !!!

    a tu vérifier que dans ton fichier index.php tu a bien changé toute les adresses ???

    #571264
    cjuliet
    Participant
    Initié WordPress
    14 contributions

    l’option .htaccess dans dreamhost est désactivée, aucune amélioration.

    Pour l’adresse du site je peux te la filer en mp? le site n’est pas encore officiellement lancé, donc ça serait embetant d’etre référencé par rapport à notre pb…

    en gros le wp se trouvait initialement à une adresse du type : http://nomdusite.dremhosters.com.
    un miroir a été crée http://nomdusite.com

    puis dans le panneau d’admin de wp, on a redirigé l’emplacement du site vers ce miroir.
    Depuis, tout a a planté : erreur 500 à l’adresse initiale et au miroir.

    « Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@rel.dreamhosters.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request. « 

    Avez vous une idée de ce qu’il faut faire ?

    #571265
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    En fait, puisqu’il ne s’agit que d’une simple redirecton effectuée via le nom de domaine, cela ne servait à rien, à mon avis, de toucher quoi que ce soit dans WP.

    #571266
    Aline
    Participant
    Padawan WordPress
    82 contributions

    Pas besoin d’envoyer l’adresse de ton blog (tu n’a pas été assez attentive tu l’a noté plus haut lol)

    sinon est-ce que tu peu acceder à quoi ??? console admin ???

    #571267
    Aline
    Participant
    Padawan WordPress
    82 contributions

    Si je ne me trompe tu n’a pas changé WP de repertoire ??? dans ce cas il fallait laisser ‘adresse de WordPress’ comme il était !!!

15 sujets de 1 à 15 (sur un total de 26)
  • Vous devez être connecté pour répondre à ce sujet.