certaines fonctions ajax ne marchent pas dans l’admin (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #555414
    Lionelwp
    Participant
    Maître WordPress
    629 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.3.1
    – Version de PHP/MySQL : 5.4.4.14
    – Thème utilisé : perso
    – Extensions en place : ultimate coming soon page
    – Nom de l’hebergeur : amen.fr
    – Adresse du site :

    Problème(s) rencontré(s) :

    Je viens d’installer un site wordpress, avec un 4.3.1 tout neuf, et je commence à créer des articles.

    Dans la création-édition d’articles ou de pages, certaines fonctions ajax ne marchent pas, par exemple:
    – si je veux déplacer les boites ‘Catégories’ ‘Etiquettes’ ‘image à la une’ par glisser-déplacer, je peux pas, j’ai bien le curseur à quatre flèches au survol mais rien ne bouge.
    – si je clique sur les liens ‘+ Ajouter une nouvelle catégorie’, ‘choisir parmi les étiquettes les plus utilisées’, ‘modifier’ le permalien , liens qui appellent des fonction Ajax, ça ne marche pas, rien ne se passe (le lien est bien envoyé dans le navigateur http://www.mon-site.com/wp-admin/post.php?post=14&action=edit#category-add par exemple, mais sans effet)
    – les liens ‘normaux’ fonctionnent, comme ‘mettre une image à la une’ ‘mettre à jour’ ‘Ajouter un média’

    Accessoirement, au niveau de la gestion des widgets, le ‘glisser-déposer’ fonctionne correctement.

    Je pense pas que ça vienne du Javascript puisque les fonctions incriminées fonctionnent parfaitement sur d’autres sites que j’ai construits et j’ai fait des test aussi sur d’autres PCs,et au final le problème ne se produit que sur ce nouveau site et quelque soit le navigateur employé.

    Que puis je tester ou vérifier?

    Merci

    #1025394
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    regarde dans laconsole si tu as une erreur de js
    active l’affichage des erreurs php pour voir les messages d’erreur

    tu es en quelle version de php ?

    #1025395
    Lionelwp
    Participant
    Maître WordPress
    629 contributions
    Gueblo wrote:
    regarde dans laconsole si tu as une erreur de js
    active l’affichage des erreurs php pour voir les messages d’erreur

    Je vais vérifier, il faut que j’active le débug dans wp-config.php?

    Gueblo wrote:
    tu es en quelle version de php ?

    5.4.4.14 , pour une fois je l’ai marqué dans l’entête du fil , lol

    #1025396
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    comme tu peux le lire ici : https://wordpress.org/about/requirements/
    la version minimale requise pour php est 5.6
    donc upgrade ta version et ça devrait aller.

    #1025397
    Lionelwp
    Participant
    Maître WordPress
    629 contributions

    J’ai activé define(‘WP_DEBUG’, true); dans le wp-config.php et activé la console: aucune erreur visible….

    Gueblo wrote:
    comme tu peux le lire ici : https://wordpress.org/about/requirements/
    la version minimale requise pour php est 5.6
    donc upgrade ta version et ça devrait aller.

    Je ne pense pas…
    J’ai un autre site wordpress en version de PHP 5.3 et ça fonctionne parfaitement.
    en local je suis en 5.5.12 et ça marche parfaitement
    et en plus chez Amen la version la plus élevée qu’ils proposent est 5.4.4.14 alors si il fallait absolument du 5.6 pour faire tourner WordPress ils auraient actualisé leurs serveurs..

    #1025398
    C_Lucien
    Modérateur
    Maître WordPress
    5115 contributions

    Bonjour,

    Lionel, tu peux suivre la durée de vie des versions Php ici http://php.net/supported-versions.php

    Si Amen est en retard, tu es en droit de leur passer un savon.
    Car

    Branch Initial Release Active Support Until Security Support Until
    5.4 1 Mar 2012 3 years, 7 months ago 14 Sep 2014 1 year, 1 month ago 14 Sep 2015 1 month ago

    #1025399
    Lionelwp
    Participant
    Maître WordPress
    629 contributions
    C_Lucien wrote:
    Bonjour,

    Lionel, tu peux suivre la durée de vie des versions Php ici http://php.net/supported-versions.php

    Si Amen est en retard, tu es en droit de leur passer un savon.
    Car

    Branch Initial Release Active Support Until Security Support Until
    5.4 1 Mar 2012 3 years, 7 months ago 14 Sep 2014 1 year, 1 month ago 14 Sep 2015 1 month ago

    alors pourquoi ça marche sur un autre site avec Php 5.3

    #1025400
    Lionelwp
    Participant
    Maître WordPress
    629 contributions

    déjà, voici la réponse de chez amen

    « Suite à votre demande au sujet du probleme du site du domaine xxxxxxxxxx.com, WordPress n’étant pas un produit Amen, nous ne donnons pas support dessus même si celui-ci viennent avec l’hebergement. Nous ne pouvons que vérifier s’il y a un probleme sur le serveur. Ceci est fait, le serveur ne présente aucun probleme.
    Nous vous recommandons de chercher d’aide sur les forums WordPress. Soit vous désinstallez le WordPress et la base de donnée pour faire une nouvelle installation. »

    #1025401
    Lionelwp
    Participant
    Maître WordPress
    629 contributions

    Je refais une installation d’un wordpress vierge, pour voir

    #1025402
    Lionelwp
    Participant
    Maître WordPress
    629 contributions

    Lorsque je veux réinstaller wordpress à partir d’une installation fraiche, j’ai ce message d’erreur maintenant:

    Warning: require_once(/htdocs/public/www/wp-includes/pomo/translations.php): failed to open stream: Permission denied in /htdocs/public/www/wp-includes/pomo/mo.php on line 10 Fatal error: require_once(): Failed opening required ‘/htdocs/public/www/wp-includes/pomo/translations.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /htdocs/public/www/wp-includes/pomo/mo.php on line 10

    (j’ai tout effacé, recopié un wordpress neuf et vidé la BDD pour repartir de zéro)

    #1025403
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    ooooh bizaaarre… et tu as essayé avec la bonne version de php ?

    #1025404
    Lumiere de Lune
    Participant
    Maître WordPress
    20531 contributions

    ça ça veut simplement dire que certains fichiers ne sont pas passés correctement via ftp

    #1025405
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    en fait, ce qui serait interessant ce serait d’installer une version de wp réputée compatible avec ta version de php
    si cette installation ne fonctionnait pas alors on peut se dire qu’il y a un probleme avec ton serveur par-exemple
    et si ça fonctionnait on pourrait se dire qu’il y aurait un probleme avec ta version de php par exemple

    #1025406
    Lionelwp
    Participant
    Maître WordPress
    629 contributions
    Gueblo wrote:
    en fait, ce qui serait interessant ce serait d’installer une version de wp réputée compatible avec ta version de php
    si cette installation ne fonctionnait pas alors on peut se dire qu’il y a un probleme avec ton serveur par-exemple
    et si ça fonctionnait on pourrait se dire qu’il y aurait un probleme avec ta version de php par exemple

    Gueblo…… je te dis que sur plusieurs autres domaines que j’ai chez Amen , la version 4.3.1 de WordPress fonctionne parfaitement avec PHP 5.3 !!!!

    #1025407
    Lionelwp
    Participant
    Maître WordPress
    629 contributions
    Lumière de Lune wrote:
    ça ça veut simplement dire que certains fichiers ne sont pas passés correctement via ftp

    c’est ce que j’ai pensé et j’ai donc tout rasé et fait comme ils m’ont suggéré chez amen, de passer par leur ‘App Manager » pour installer WordPress et là, dès le début il me sort une erreur :

    Could not unzip the Language files.

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.