Cannot modify header

  • Statut : non résolu
15 sujets de 46 à 60 (sur un total de 60)
  • Auteur
    Messages
  • #653960
    BertrandB21
    Participant
    Maître WordPress
    590 contributions
    wonse wrote:
    headers already sent by (output started at /mnt/162/sdc/9/5/wonse/blog/wp-config.php:2) in /mnt/162/sdc/9/5/wonse/blog/wp-includes/pluggable.php on line 865

    Pourtant le fil ne parle que de ça !!!!!!!!!!!!!!!!! je crois qu’il vous faut une paire de lunettes
    le problème vient de ce que vous utilisez NOTEPAD pour mettre à jour votre wp-config.php
    et ce logiciel de M$ (non ce n’est pas une insulte) met un caractère invisible en début de fichier qui entraine ce problème.
    Il vous faut impérativement utiliser un Véritable Editeur pour ce faire
    Ont été cités notepad2 ou notepad++ qui n’a rien à voir avec le logiciel de M$ et pour lequel le bill ne touche pas une thune.

    Le wp-config.php doit être impérativement sauvegardé en UTF-8 sans BOM

    et petite question annexe pourquoi la version 2.8.4 de wordpress ?

    pour ceux qui ont moins des cheveux blanc que moi M$ étaient les deux premiers octets des exécutables MSDOS

    #653961
    wonse
    Membre
    Initié WordPress
    9 contributions

    C’est pas vraiment d’une paire de lunette dont j’ai besoin mais plutôt de quelques neurones en plus.
    J’utilise Notepad2 et j’ai bien l’impression que le fichier wp-config est enregistré en UTF-8[/url] mais je peux me tromper.

    Et concernant la version de wp que j’utilise, c’est parce que je suis vilaine et que j’ai pas fait les maj.

    #653962
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    ça ressemble à quelque chose d’ok.
    donc deux pistes … soit ce n’est pas le wp-config.php que vous éditer qui est lu par le serveur (je sais c’est idiot mais ça arrive)
    soit il y a une merdouille à la … sur la première ligne du wp-config.php les premiers octets/caractères doivent être obligatoirement la chaîne même à la fin ça ne sert à rien sinon à poser des problèmes

    ah et changez le mot de passe de votre base de données maintenant il est connu 😉

    ce pourrait être une idée de faire un générateur de wp-config.php sur wordpress-fr

    #653963
    wonse
    Membre
    Initié WordPress
    9 contributions

    J’ai pourtant bien regardé et non il n’y a pas de caractères surprises. Ou alors je suis vraiment passé à coté quoi … Mais, tout cela n’a rien à voir avec le fichier pluggable.php dans le dossier includes ?

    parce que j’ai dans ma phrase d’erreur : in /mnt/162/sdc/9/5/wonse/blog/wp-includes/pluggable.php on line 865

    if ( php_sapi_name() != ‘cgi-fcgi’ )
    status_header($status); // This causes problems on IIS and some FastCGI setups
    header(“Location: $location”);

    header(“Location: $location”); étant la ligne 865.

    Je suis à la ramasse.
    Merci pour l’aide.

    Et si jamais c’est trop casse tête, je me demandais si en ré installant wp (la dernière version tant qu’à faire) ça réglerait le problème ?
    Et si oui (pasque je suis quand même une huitre noob en la matière) quels sont les fichiers que je dois garder tel quels pour ne pas perdre mes données (comme mes posts, pages, le thème modifié…) ?

    Et ce n’est pas le bon mot de passe que l’on peut voir 😉 mais merci tout de même de m’avoir prévenu.

    #653964
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    oui mais plugable n’a rien le message d’erreur est pourtant complètement explicite :
    output started at /mnt/162/sdc/9/5/wonse/blog/wp-config.php:2
    les headers ont déjà été émis déclenchés par la sortie d’un caractère dans wp-config.php

    et si j’avais mieux lu le message je me serrais aperçu que ça semble être soit le deuxième caractère ou la deuxième ligne (puis que wp-config.php:2)
    Malheuruesement la copie d’écran que vous avez déposé cachhe justement ces deux premières lignes

    test (toujours en sauvegardant en utf-8 effacer la chaine <?php et la réécrire
    insérer une ligne vide après la première

    avez vous encore une erreur ?

    #653965
    wonse
    Membre
    Initié WordPress
    9 contributions

    god damn god !

    j’ai donc effacé et ré écris et no sé porque mais ça remarche, je peux accéder de nouveau au dashboard.
    Merci beaucoup pour l’aide apportée, je comprenais absolument pas d’où venait l’erreur (je ne comprends toujours pas mais j’aurais pas eu l’idée de ré écrire).

    😉

    #653966
    ibazar
    Membre
    Initié WordPress
    1 contributions

    Besoin d’aide s.v.p. !

    J’ai lu la plupart des réponses qui se trouvent ici, et rien n’y fait.

    J’ai installé WordPress en français, selon les instructions de la page:
    http://fr.wordpress.org/

    et j’ai eu droit à un message de succès pour l’installation, accompagné d’un message d’erreur…
    Mon blog apparaît bien à l’adresse URL où je l’ai installé, mais je ne peux pas entrer dans la zone d’administration wp-admin, puisque je reçois les messages d’erreurs suivants:

    Warning: Cannot modify header information – headers already sent by (output started at /home/focu5086/public_html/JorkestreFr/wp-config.php:1) in /home/focu5086/public_html/JorkestreFr/wp-login.php on line 337

    Warning: Cannot modify header information – headers already sent by (output started at /home/focu5086/public_html/JorkestreFr/wp-config.php:1) in /home/focu5086/public_html/JorkestreFr/wp-login.php on line 349

    Warning: Cannot modify header information – headers already sent by (output started at /home/focu5086/public_html/JorkestreFr/wp-config.php:1) in /home/focu5086/public_html/JorkestreFr/wp-includes/pluggable.php on line 690

    Warning: Cannot modify header information – headers already sent by (output started at /home/focu5086/public_html/JorkestreFr/wp-config.php:1) in /home/focu5086/public_html/JorkestreFr/wp-includes/pluggable.php on line 691

    Warning: Cannot modify header information – headers already sent by (output started at /home/focu5086/public_html/JorkestreFr/wp-config.php:1) in /home/focu5086/public_html/JorkestreFr/wp-includes/pluggable.php on line 692

    Warning: Cannot modify header information – headers already sent by (output started at /home/focu5086/public_html/JorkestreFr/wp-config.php:1) in /home/focu5086/public_html/JorkestreFr/wp-includes/pluggable.php on line 890

    Merci 😉

    #653967
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    le premier caractère du fichier /home/focu5086/public_html/JorkestreFr/wp-config.php n’est pas un <
    vous avez probablement un problème avec un caractère caché … en général c’est le fameux BOM quand on utilise pas un éditeur de texte en utf-8 sans BOM … relisez les post précédent.
    il faut que les 5 premiers octets du fichier correspondent au caractère <?php
    a défaut vous supprimez la première ligne et vous recommencez

    #653968
    cimi
    Participant
    Initié WordPress
    4 contributions

    Bonjour,
    Je viens de créer un blog WordPress 3.0 sur mon site web et il semble que la mise à jour de l’entête pose toujours un problème.

    J’ai essayé de changer l’image d’entête et voici le message :

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/tmp/phpc3QiJf) is not within the allowed path(s): (/var/web/cimi/public_html/:/usr/share/pear/) in /var/web/cimi/public_html/wordpress/wp-includes/functions.php on line 2402

    Le fichier n’ a pas pu être déplacé vers /var/web/cimi/public_html/wordpress/wp-content/uploads.

    En fait, il n’y a pas de répertoire “/upload” dans “wp-content/” (!)

    une idée pour résoudre ce problème?

    pour info, le fichier config est bien encodé en UTF8 sans BOM.

    En attendant, j’ai remplacé l’image affichée par défaut par celle que je voulais, avec le même nom.

    Ah oui, j’oubliais:

    Ma configuration WP actuelle
    – Version de WordPress :3.0.3
    – Thème utilisé : Twenty Ten 1.1
    – Plugins en place : aucun
    – Nom de l’hebergeur : http://www.cimi.ulg.ac.be
    – Adresse du site : http://www.cimi.ulg.ac.be/wordpress/

    Merci d’avance!

    #653969
    LucG
    Participant
    Padawan WordPress
    79 contributions

    ÇA Y EST!!!!!!!!!!!!!!!!!!
    ???
    Sais pas comment mais ça marche!
    Peut-être en enregistrant sous UTF-8 (sans BOM)!!??
    Pourtant je croyais l’avoir fait!?
    Merci en tous cas de votre aide!

    #653970
    cimi
    Participant
    Initié WordPress
    4 contributions

    Je suis très content pour toi!

    Mais, euh… çà ne répond pas vraiment à MA question! :o((

    #653971
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    Il serait sans doute judicieux de créer ton propre sujet, car ce n’est pas un problème de codage du fichier wp-config, mais de paramétrage de ton serveur

    #653972
    cimi
    Participant
    Initié WordPress
    4 contributions

    Mais encore… ?

    Merci pour votre réponse, mais de quels paramètres (de serveur) voulez-vous parler?
    Le sujet me semblait pourtant bien à propos… quel autre sujet pourrais-je proposer à votre avis?

    D’avance, merci.

    Michel

    #653973
    Odium
    Membre
    Padawan WordPress
    92 contributions

    Bonjour,

    site : http://terredetrail.free.fr/

    Je sais que le sujet a été evoquer 1000 fois, mais malgres mes recherches impossibles de me depanner …
    le message (pas tres original) :

    Warning: Cannot modify header information – headers already sent by (output started at /mnt/159/sdc/9/a/terredetrail/wp-content/themes/iBusiness/functions.php:1) in /mnt/159/sdc/9/a/terredetrail/wp-includes/pluggable.php on line 865

    J’ai deja verifié mon wp-config

    Je cale un peu là…

    Merci

    #653974
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    Merci de créer vos propres sujets ce qui permettra au passage de remplir les infos nécessaire au support

15 sujets de 46 à 60 (sur un total de 60)
  • Le sujet ‘Cannot modify header’ est fermé à de nouvelles réponses.