Cannot modify header

  • Statut : non résolu
15 sujets de 31 à 45 (sur un total de 60)
  • Auteur
    Messages
  • #653945
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    Non ce n’esrt pas forcément celui qui annonce l’erreur qui en est la cause …
    Là un programme se plaint d’avoir une table mal initialisée .. ce qui par effet de bord le pousse à émettre un caractère donc des entêtes et par cascade déclencne l’anomalie can’t modify … plus loin.
    Pour solutionner le problème il faut trouver ce qui ne va pas dans les widget.
    les widgets sont gérer dans la table options par l’option de nom sidebars_widget.

    Faire une sauvegarde de la table et essayer de supprimer cette option.

    #653946
    souriskiclic
    Membre
    Initié WordPress
    23 contributions

    Merci aussi pour cette solution Lumière de lune.

    A force de « bidouiller » mon wp-config.php j’en avais perdu le codage d’origine.

    Je suis sous dreamweaver.

    #653947
    dunes
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    Ma configuration WP actuelle – la dernière 2.7.1 en Français
    – Version de WordPress :
    – Thème utilisé – standard d’origine :
    – Plugins en place- aucuns :
    – Nom de l’hebergeur – ovh :
    – Adresse du site : http://www.tanger-experience.com :

    Problème(s) rencontré(s) :

    J’ai suivi la procédure décrite et l’installation s’est déroulée « normalement » sauf que j’avais d’entrée 2 lignes d’erreurs avec :
    Warning: Cannot modify header information – headers already sent by (output started at /homez.145/tangerex/www/wp-config.php:85) in /homez.145/tangerex/www/wp-login.php on line 255

    Warning: Cannot modify header information – headers already sent by (output started at /homez.145/tangerex/www/wp-config.php:85) in /homez.145/tangerex/www/wp-login.php on line 267

    Et si j’en juge les posts déjà existants… déjà bien connus !

    On arrive à la page d’accueil standard du site (www.tanger-experience.com) et si je veux passer dans l’administration afin de pouvoir changer le thème et rajouter des plugins, j’ai une série de messages d’erreurs :

    Warning: Cannot modify header information – headers already sent by (output started at /homez.145/tangerex/www/wp-config.php:85) in /homez.145/tangerex/www/wp-includes/pluggable.php on line 658 et 659 et 660 et 850

    J’ai bien sûr vérifié le wp-config, et il est « normal ». la base de donnée est en UTF-8, etc….

    Pour info, je suis « encore » en IE7 et suis complètement novice avec WordPress (mais je vais me soigner !)
    Merci d’avances pour vos conseils d’experts

    #653948
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    Là c’est la ligne 85 de wp-config.php « qui émet » un caractère
    Donner nous le contenu des lignes du wp-config sans les mots de passes et les key
    si pour vous la ligne 85 est la dernière ligne vérifié que vous n’avez pas « femé » la balise php.
    Pour plus de sureté tous les fichiers include ne doivent pas se terminer par ?>

    #653949
    Skynii
    Membre
    Initié WordPress
    5 contributions

    Bonsoir, j’ai le meme probleme que cité précédement à savoir :
    Warning: Cannot modify header information – headers already sent by (output started at /home/skyniiweb/www/wp-config.php:1) in /home/skyniiweb/www/wp-login.php on line 287

    Warning: Cannot modify header information – headers already sent by (output started at /home/skyniiweb/www/wp-config.php:1) in /home/skyniiweb/www/wp-login.php on line 299

    Warning: Cannot modify header information – headers already sent by (output started at /home/skyniiweb/www/wp-config.php:1) in /home/skyniiweb/www/wp-includes/pluggable.php on line 662

    Warning: Cannot modify header information – headers already sent by (output started at /home/skyniiweb/www/wp-config.php:1) in /home/skyniiweb/www/wp-includes/pluggable.php on line 663

    Warning: Cannot modify header information – headers already sent by (output started at /home/skyniiweb/www/wp-config.php:1) in /home/skyniiweb/www/wp-includes/pluggable.php on line 664

    Warning: Cannot modify header information – headers already sent by (output started at /home/skyniiweb/www/wp-config.php:1) in /home/skyniiweb/www/wp-includes/pluggable.php on line 865

    Et voici la premiere ligne du wp-config.php: <?php

    Que faire ? Merci de votre aide

    #653950
    Annahbel
    Participant
    Initié WordPress
    2 contributions

    Bonjour, je me permets de remonter le sujet

    Ma configuration WP actuelle
    – Version de WordPress : 2.9.2
    – Version de PHP/MySQL :
    – Thème utilisé : un theme personnel
    – Extensions en place :
    – Nom de l’hebergeur : Zymic
    – Adresse du site : http://behind-the-virtual.zzl.org, http://beaming-heart.zzl.org, http://ageless-world.zzl.org

    Problème(s) rencontré(s) :

    j’ai lu ce que vous aviez écris dans ce message mais ca ne m’a malheureusement pas aidé.

    J’ai le meme souci sur mes 3 sites. Donc je pense soit à l’hébergeur qui pose problème ou wordpress. En fait quand on envoie des commentaires, il m’affiche la page suivante (je me permets un imprim écran) :
    100802032435977931.png

    J’ai cherché sur internet mais j’y comprend rien, je ne sais pas d’ou vient le problème.
    Bon les commentaires marchent mais je ne veux pas laisser ca comme ca car c’est pour acheter je ne sais quoi …

    Merci d’avance à quiconque pourra m’aider !

    #653951
    BertrandB21
    Participant
    Maître WordPress
    590 contributions

    Non cette fois c’est tout à fait différent. L’hébergeur a bidouillé & la fonction mail de php pour qu’elle émette un message vous invitant de payer pour y avoir accès.
    L’émission de ce message déclenche l’émission des headers qu’après coup wordpress ne peut modifier.

    Je ne sais pas s’il existe un moyen simple dans wordpress de contourner l’existence de la fonction mail.

    #653952
    Annahbel
    Participant
    Initié WordPress
    2 contributions

    Merci beaucoup pour ta réponse Bertrand.
    La je tente sur Free, voir si ca peut résoudre mon problème ou pas.
    Merci quand meme =)

    #653953
    Stephane Malhomme
    Membre
    Initié WordPress
    2 contributions

    Bonjour à tous! Mon tout premier post, je me sens un peu timide, ahah… C’est juste un mot de remerciement… Je suis tout débutant, me cognait la tête contre le mur (c’est une métaphore) à cause de ce problème depuis plus d’un jour, et j’ai trouvé la solution chez vous: Installer Notepad 2 (dont j’ignorais même l’existence) – Sauver UTF8 Sans signature (euhh, aussi). En tous cas, la courbe d’apprentissage va être rude, mais avec une communauté pareille, je me sens rassuré. Merci à tous. Dès que je comprends quelque chose je contribuerai en traduisant des textes en français. 🙂

    #653954
    caim
    Participant
    Initié WordPress
    14 contributions

    Bonjour à tous

    Je relance le débat car j’ai eu le même problème…j’ai tout essayé et ça n’a pas marché même si un moment wordpress c’est bien installé et que j’ai pu voir mon blog, mais comme vous je n’ai pu me connecter en tant qu’admin….

    Du coup je me suis dit que j’allais tout recommencer j’ai donc enlever tous les fichiers wordpress que mon serveur web contenaient et j’ai tout remis sauf que maintenant j’ai le problème suivant;

    « &19d’); define(‘SECURE_AUTH_KEY’, ‘qW+)z/wQl4I0~YB*%ncJ=u^E|_r+j`R hv|y,lTj’); define(‘SECURE_AUTH_SALT’, ‘?T=rs 3 Kh.o4vY#dC{9u-[~J3A[XTDZ0l2rt=wC5+G(FST$toT:wW C^15+8eZ’); define(‘LOGGED_IN_SALT’, ‘|Nh{_u)L@)Lj- O%Yll9cv=S~[W`S)0V>~fF-GGK!aPkDRMDXm3SOR6C!l,jY*MM’); define(‘NONCE_SALT’, ‘PYuznw%p)xn5/Kw:B9+P@$::-_5_,4#ogcBvg@]}a>2/)-5zxDL|tosv4e tR|<*'); /**#@-*/ /** * Préfixe de base de données pour les tables de WordPress. * * Vous pouvez installer plusieurs WordPress sur une seule base de données * si vous leur donnez chacune un préfixe unique. * N'utilisez que des chiffres, des lettres non-accentuées, et des caractères soulignés! */ $table_prefix = 'wp_'; /** * Langue de localisation de WordPress, par défaut en Anglais. * * Modifiez cette valeur pour localiser WordPress. Un fichier MO correspondant * au langage choisi doit être installé dans le dossier wp-content/languages. * Par exemple, pour mettre en place une traduction française, mettez le fichier * fr_FR.mo dans wp-content/languages, et réglez l'option ci-dessous à "fr_FR". */ define ('WPLANG', 'fr_FR'); /** * Pour les développeurs : le mode deboguage de WordPress. * * En passant la valeur suivante à "true", vous activez l'affichage des * notifications d'erreurs pendant votre essais. * Il est fortemment recommandé que les développeurs d'extensions et * de thèmes se servent de WP_DEBUG dans leur environnement de * développement. */ define('WP_DEBUG', false); /* C'est tout, ne touchez pas à ce qui suit ! Bon blogging ! */ /** Chemin absolu vers le dossier de WordPress. */ if ( !defined('ABSPATH') ) define('ABSPATH', dirname(__FILE__) . '/'); /** Réglage des variables de WordPress et de ses fichiers inclus. */ require_once(ABSPATH . 'wp-settings.php');
    Fatal error: Call to undefined function is_admin() in /home/games081/public_html/site/wp-admin/includes/comment.php on line 162″

    Voilà moi je n’y comprend rien si quelqu’un peut m’aider je lui serait reconnaissant

    J’ai essayé d’installer wp version 3.0.1 sur l’hebergeur hostpapa,
    l’adresse: http://www.gamespirits.com/site/wp-admin/install.php

    Merci

    #653955
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    Vérifie ton wp-config.php au besoin régénère le.
    Je pencherai pour un problème vers le AUTH_KEY (un caractère qu’il n’aime pas dans la clef par exemple ou une faute de frappe)

    #653956
    caim
    Participant
    Initié WordPress
    14 contributions

    bon alors j’ai pas précisé mais je suis de la catégorie « mauvais »… je te remercie de répondre aussi vite mais je ne comprends pas ce qu’il faut que je fasse…

    désolé

    #653957
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    Tu devrais supprimer le message puis ouvrir un nouveau sujet dans le forum de support ce n’est pas la place de cette discussion sur le format de fichier wp-config.php.

    #653958
    p_tit_dom
    Membre
    Initié WordPress
    17 contributions

    Bonjour

    Grâce à vous, j’ai put trouver un début de solution à l’installation de wordpress. J’avais le message ‘Cannot modify header ….’ que j’ai put résoudre via notepad . J’ai maintenant un autre problème suite à cette manipulation.

    « Oups ! Petit problème… Ce lien semble brisé. »

    A quoi cela est-il du?

    Avec mes remerciements

    p_tit_dom

    #653959
    wonse
    Membre
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : Version 2.8.4
    – Version de PHP/MySQL :
    – Thème utilisé : Gimpstyle bidouillé
    – Extensions en place :
    – Nom de l’hebergeur : Free
    – Adresse du site : http://wonse.free.fr/blog/

    Tout est bien en ligne, sauf quand je veux me connecter à mon dashboard, j’ai cette jolie phrase :
    Warning: Cannot modify header information – headers already sent by (output started at /mnt/162/sdc/9/5/wonse/blog/wp-config.php:2) in /mnt/162/sdc/9/5/wonse/blog/wp-includes/pluggable.php on line 865

    Et à vrai dire, je dois pas comprendre grand chose, j’ai cherché dans le fichier pluggable.php mais sans succès et j’avais aussi un peu peur de tout merdouiller alors j’ai rien touché.

    J’ai bien rajouté le fichier .htaccess
    Merci d’avance. 😉

15 sujets de 31 à 45 (sur un total de 60)
  • Le sujet ‘Cannot modify header’ est fermé à de nouvelles réponses.