Cannot modify header … problème avec functions.php (Créer un compte)

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #478325
    blandine
    Participant
    Padawan WordPress
    70 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé : atahualpa2
    – Extensions en place :
    – Nom de l’hebergeur : ovh
    – Adresse du site : http://www.onlyhappyinthesun.Fr

    Problème(s) rencontré(s) :

    Bonjour,

    Lorsque je rentre dans l’administration de mon blog, j’ai souvent des erreurs type;

    Warning: Cannot modify header information – headers already sent by (output started at /homez.157/onlyhapp/www/wp-content/themes/atahualpa2/functions.php:3) in /homez.157/onlyhapp/www/wp-includes/pluggable.php on line 865

    (le numéro de ligne varie souvent)

    Ca ne bloque pas le fonctionnement mais je voudrais bien régler ce probleme.

    Que dois je faire?

    J’ai cherché mais je n’ai pas compris grand chose

    merci

    #711641
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    Bonjour,

    merci de lire les sujets épinglés,depuis WordPress 2.8 il faut être sous php5 pour ne pas avoir de messages d’erreur ou de bug.
    Il serait bien d’installer WP 2.9.1

    #711642
    blandine
    Participant
    Padawan WordPress
    70 contributions

    je suis en php5 et sous wordpress 8

    Je vais mettre à jour pour 2.9

    j’ai lu les sujets, mais je ne comprends absolument rien… désolée

    #711643
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    je suis désolé de vous contredire mais avec l’extension Firebug ,sur l’onglet “réseau” j’arrive parfosi à voir la version du php d’un site,et votre site est sous X-Powered-By PHP/4.4.9
    http://www.onlyhappyinthesun.fr/

    dans votre fichier .htaccess avez vous ceci ??

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress
    SetEnv PHP_VER 5

    #711644
    blandine
    Participant
    Padawan WordPress
    70 contributions

    ah? autant pour moi alors pour le php j’ai du confondre avec autre chose. comment faire pour modifier ce paramètre?

    il n’y avait pas ces infos dans mon htaccess, du coup je les ai mises…

    #711645
    blandine
    Participant
    Padawan WordPress
    70 contributions

    autant pour moi, question idiote.

    j’ai donc rajouté ces infos dans mon htaccess.

    même problème :(

    #711646
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    d’accord ,c’est bien là vous êtes bien sous php5.
    c’est une installation ou une mise à jour ?
    si installation,je suppose manuelle, avez vous enregistré le fichier wp-config.php au format UTF-8 sans BOM ?
    comme indiqué là ?
    http://www.wordpress-fr.net/support/sujet-21204-cannot-modify-header-compatibilite-resume

    #711640
    blandine
    Participant
    Padawan WordPress
    70 contributions

    il s’agit d’une mise à jour.

    #711647
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    la mise à jour a été faite comment ? Automatique ou manuelle ?

    #711648
    blandine
    Participant
    Padawan WordPress
    70 contributions

    automatique

    #711649
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    pouvez vous essayer de renvoyer par ftp tous les fichiers de WordPress 2.9.1 SAUF le dossier wp-content et le fichier wp-config.php
    Automatique c’est bien,pratique mais moins sûr que la mise à jour manuelle.
    mise à jour manuelle en vidéo

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.