[Résolu] Bugs thème Legal (slider, traductions) (Créer un compte)

  • WordPress :5.4
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2348481
    E.
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 7.3 – MySQL 5.6
    • Thème utilisé : Legal (création d’un thème enfant de ce thème)
    • Extensions en place : Akismet anti-spam, Contact Form 7, Cookie Notice, iThemes Security, WP Maintenance
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://www.mervanbarazi.com

    Problème(s) rencontré(s) :

    • le slider de la page d’accueil ne prend pas en compte les urls des boutons “En savoir plus”, qui renvoient vers… la page d’accueil, ce qui ne sert donc à rien
    • toujours sur la home, les derniers articles du blog gardent le texte “Read more” dans le bouton alors que j’ai traduit les termes adéquats (via Poedit)
    • le format de la date des articles dans le blog reste sur le modèle du thème d’origine (du type “07 Juil, 2020”), alors que j’ai modifié cela dans des fichiers php + réglages WP

    Le site sera traduit en anglais et arabe, via l’extention Polylang que je ne connais pas. Malheureusement, les traductions ne se comportant pas comme il faut déjà à la base (thème anglais, pas complètement traduit en français), j’ai dû forcer un peu en changeant directement le texte dans des fichiers php. C’est donc sale et bancal 😉 Et surtout contre-productif puisque ce ne sera pas traduit par Polylang je pense… Comment traduire proprement les quelques termes restants qui ne sont pas dans des pages ou articles ?

    J’ai dû forcer le lien “Politique de confidentialité” pour qu’il soit présent dans le footer en modifiant le fichier correspondant en PHP, car le thème ne permet apparemment pas d’ajouter une url dans le widget prévu à cet effet. Du coup, c’est aussi sale, bancal et ce ne sera pas traduit par Polylang (enfin je suppose). Là aussi, comment faire ça proprement et intelligemment ?

    Ce sont probablement des trucs que je fais mal, car ma maîtrise de WP a ses limites… J’aimerais faire quelque chose de propre et qui permette surtout une traduction complète du site.

    Merci à vous pour vos lumières !

    #2348803
    momofr@free.fr
    Modérateur
    Maître WordPress
    3408 contributions

    Salut, pour les problème avec le thème il faut voir avec son support ici.

    Pour la traduction je viens de tester en local est les fichiers po/mo (legal-fr_FR.po + legal-fr_FR.mo) placés dans wp-content -> languages -> themes sont bien pris en compte (Cf. pièce jointe).

    Pour la date, le thème ne tient pas compte des réglages Wp c’est dommage et tu dois effectivement bricoler ou remonter le souci sur le support du thème.

    Pour terminer je pense qu’un thème aussi peu diffusé (700 installations) avec de tel défauts n’est sans doute pas un bon choix, tu as de nombreux thèmes traduits en FR et bien plus fiables disponibles sur le repo WP.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2348812
    E.
    Participant
    Initié WordPress
    11 contributions

    Bonjour et merci pour ce retour.

    Idem, en local tout se comportait bien et les traductions se pliaient bien à mes exigences !

    Pour tout un tas de raisons quand je suis passée à l’installation sur le serveur je n’ai pas importé le contenu et ai dû tout refaire manuellement. Ceci dit, j’avais bien reporté tout ce que j’avais fait, sans rien oublier. Qu’est-ce qui pourrait empêcher les traductions de bien se comporter ? Car là c’est un peu la mutinerie…

    Polylang n’a l’air de traduire que les pages, articles et menus. Et donc pas tout le reste (titre du site, contenu des widgets, textes des boutons…), ce qui va être problématique. Je pense me tourner vers un bon vieux traducteur automatique… Ca dépannera un temps 🙁

    S’il y a d’autres idées sur la traduction, je prends ! 😉

     

    #2348813
    momofr@free.fr
    Modérateur
    Maître WordPress
    3408 contributions

    Salut, lorsque je développe en local je migre le site de dev avec All in One Migration sans problème (sauf taille du site), rien de particulier à faire.

    Si tes fichiers po/mo sont bien dans le dossier général ça doit fonctionner.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2348883
    E.
    Participant
    Initié WordPress
    11 contributions

    Ok c’est bon pour la traduction, je n’avais pas placé les fichiers où il fallait (pas dans le dossier général justement). Pour le reste je vais poster sur le support du thème.

    Un grand merci pour ton aide 🙂

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.