Bug : WordPress semble déjà installé….

  • WordPress :5.2
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #2281925
    sebbultel
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.7
    • Thème utilisé : Quest
    • Extensions en place :
    • Nom de l’hébergeur : Local
    • Adresse du site : localhost

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai à ma dispo le dossier wordpress de mon site et sa base de données au format sql.

    J’ai essayé de le réinstaller avec wamp. La première fois j’ai réussi l’installation wordpress mais le site n’avait rien à voir avec ce qu’il était à la base.

    Ensuite j’ai tenté une autre installation mais impossible de la réaliser. Il est indiqué que wordpress semble déjà installé qu’il faut que je nettoie la base de données…

    Pourriez-vous m’aider svp cela fait 3 jours que je fais les tours des forums mais rien n’y fait….

    Cordialement

    Sébastien

    #2281926
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Bonjour,

    • le site n’avait rien à voir avec ce qu’il était à la base.Avez-vous modifié les liens dans la vase de données?
    • Il est indiqué que wordpress semble déjà installé qu’il faut que je nettoie la base de données. Si vous remettez les dossiers wordpress il faut que les précédents soient totalement enlevés, et il faut supprimer (pas seulement vider) toutes les tables de la base de données. Sans supprimer la base de données elle-même.
    #2281935
    sebbultel
    Participant
    Initié WordPress
    9 contributions
    • le site n’avait rien à voir avec ce qu’il était à la base.Avez-vous modifié les liens dans la vase de données?

    Comment faire pour mettre à jour stp ? Comment je peux retrouver l’adresse initiale ? Sachant que c’etait installé en local.

    • Il est indiqué que wordpress semble déjà installé qu’il faut que je nettoie la base de données. Si vous remettez les dossiers wordpress il faut que les précédents soient totalement enlevés, et il faut supprimer (pas seulement vider) toutes les tables de la base de données. Sans supprimer la base de données elle-même.

    Même question…. Comment supprimer les tables sans supprimer la base de données ?

     

    Merci pour ton aide

    #2281936
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Pour la première question “Comment je peux retrouver l’adresse initiale ? Sachant que c’etait installé en local.“. Je n’ai pas bien compris. Je croyais que vous essayiez de cloner en local un site que vous aviez chez un hébergeur. Là je comprends que c’est de local à local. Pourriez-vous dire plus exactement ce que vous essayez de faire?

    En principe l’adresse locale dans wamp est du genre  http://localhost /”le nom de votre site”/ .

    Pour la deuxième question, il suffit d’aller dans la base de données, de cocher à gauche toutes les tables puis, en bas, “avec  la sélection” -> menu déroulant->supprimer les données ou la table;  faire supprimer (et non vider). Cela vous donne une base de données vide, nécessaire pour pouvoir importer. En fait, comme vous êtes en local, vous pouvez aussi bien supprimer la base et la recréer sous le même nom.

    • Cette réponse a été modifiée le il y a 3 weeks et 4 jours par  ferman.
    #2281938
    sebbultel
    Participant
    Initié WordPress
    9 contributions
    • Là je comprends que c’est de local à local. Pourriez-vous dire plus exactement ce que vous essayez de faire?

    Oui c’est bien ça (du local au local). J’avais créé un site il y a 2 ans et là je voudrais le réinstaller en local.

    Pour la base de données je vais essayer et je te tiens au courant car il me semble que c’est ce que j’avais déjà fait.

     

     

    #2281957
    sebbultel
    Participant
    Initié WordPress
    9 contributions

    Alors voilà je reprécise un peu ma démarche.

    J’ai créé un site en local avec mamp il y a 2 ans et j’aimerais le retravailler.

    Il y a 2 ans j’avais un site semblable aux photos 3 et 4 en pjointes

    et aujourd’hui quand j’importe la base de données et je copie mon dossier wordpress en local j’ai un site uniquement conçu de texte vert et noir (comme sur la première photo en pjointe)

    Comment je peux faire pour retrouver mon site initial ? (sachant que si je me souviens bien j’avais bosser avec un site enfant…)

    Merci encore

    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  sebbultel.
    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  sebbultel.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2281967
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Oui, bizarre. Comme si aucun thème n’était activé. Quand vous cliquez sur un des titres verts, il se passe quelque chose?

    Est-ce que le thème parent est toujours dans les dossiers du site. Pouvez-vous vérifier dans votre base de données quel thème est activé? Table wp-options, 2e page  lignes template et stylesheet.

    Dans cette même table wp options, que disent les deux premières lignes (site url et home)?

    Vous devez avoir au moins un thème par défaut dans vos dossiers twentysixteen ou autre.  Remplacez les deux valeurs ci-dessus par celles du thème par défaut (voir pièce jointe) et regardez si c’est mieux.

     

    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2281971
    sebbultel
    Participant
    Initié WordPress
    9 contributions

    Maintenant il m’affiche une page d’installation de wordpress……Franchement c’est à n’y rien comprendre….

    Tout à l’heure quand je cliquais sur un lien ça me mettait une erreur… (ne trouvait pas le fichier)

    Si je refais tout comme il faut comment je dois procéder stp ? base de données puis copier du dossier wordpress original ?

    Merci

    #2281982
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Voilà comment je fais. Je précise que je n’utilise pas wamp mais xampp mais ce n’est pas très différent. Je vous mets aussi un lien. Il ne correspond pas exactement à votre cas puisqu’il concerne une migration local-> hébergeur  mais il est quand même utile. Donc pour local/local:

    • Dans wamp/www (xampp/htdocs) je crée un dossier avec le nom de mon site (www/monsite). Le nom du dossier n’est pas important mais c’est plus  simple comme ça. Dans ce dossier, je place tous les dossiers et fichiers de ma sauvegarde : wp-admin, content, et include, ainsi que tous les fichiers séparés y compris wp-config et .htaccess si vous l’avez dans votre sauvegarde.
    • Je crée une base de données et lui donne un nom (regardez dans votre wp-config le nom de la base dans votre installation précédente et donnez le même c’est plus simple). Je vérifie dans cette base de données les lignes 1et2 de la table wp-options. C’est l’adresse de votre site. Je regarde aussi le thème activé comme dit précédemment.
    • Je vérifie dans wp-config que tout est bon (wp-config doit ressembler à ce qui est dans le lien que je vous ai donné). Si le préfixe des tables dans votre base de données n’est pas wp (peut-être l’avez vous modifié il y a deux ans, il faut corriger dans wp-config éventuellement). Si vous n’avez touché à rien depuis deux ans, wp-config doit être bon.
    • Normalement, si vous avez tout gardé comme dans votre précédente installation, ça doit marcher.
    • Pour entrer dans la partie administration du  site, il vous faut un identifiant et un mot de passe. Le mieux est de se souvenir de ce que vous aviez il y a deux ans. Autrement, il faudra créer un nouvel administrateur avec un mot de passe. Regardez .
    • Vous aurez du travail de mise à jour wordpress, thèmes et extensions.

    J’espère que tout fonctionnera bien  autrement vous avez l’adresse du forum. Bon courage.

     

    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  ferman.
    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  ferman.
    #2282088
    sebbultel
    Participant
    Initié WordPress
    9 contributions

    Alors tout d’abord merci

    J’ai tout fait.

    Quand je me connecte sur localhost/monsite/ j’ai une erreur de connexion à la base de données. Sûrement un problème d’identifiant ou de mdp ? ou d’url car je vois comme url dans wp-options: localhost:8888 alors que pour me connecter à mon site je dois taper localhost/monsite dans la barre de recherche

    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  sebbultel.
    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  sebbultel.
    #2282094
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Bonjour,

    Localhost: 8888 me semble être une adresse pour mamp, pas wamp. Cette adresse date de votre précédente installation et n’a pas été modifiée? Votre précédente installation était déjà sur wamp ou sur mamp (Mac)?

    Sinon dans les deux lignes de la base de données remplacez localhost:8888 par localhost.

    #2282095
    sebbultel
    Participant
    Initié WordPress
    9 contributions

    En fait je suis passé sur Xampp. J’ai modifié comme tu m’as indiqué et voici ce que j’obtiens :


    <p class=”p1″><span class=”s1″><b>Warning</b>: Parameter 1 to wp_default_scripts() expected to be a reference, value given in <b>/Applications/XAMPP/xamppfiles/htdocs/destination-sport/wp-includes/plugin.php</b> on line <b>600</b></span></p>
    <p class=”p1″><span class=”s1″><b>Warning</b>: Parameter 1 to wp_default_styles() expected to be a reference, value given in <b>/Applications/XAMPP/xamppfiles/htdocs/destination-sport/wp-includes/plugin.php</b> on line <b>600</b></span></p>
    <p class=”p3″><span class=”s2″>Skip to content</span></p>
    <p class=”p4″><span class=”s3″>It looks like nothing was found at this location. Maybe try one of the links below or a search?</span></p>

    Je joins aussi une capture d’écran…

    Quand je clique sur un lien j’ai ça qui s’affiche :


    <p class=”p1″><span class=”s1″><b>Objet non trouvé!</b></span></p>
    <p class=”p2″><span class=”s1″>L’URL demandée n’a pas pu être trouvée sur ce serveur. La référence sur <span class=”s2″>la page citée</span> semble être erronée ou perimée. Nous vous prions d’informer l’auteur de <span class=”s2″>cette page</span> de cette erreur.</span></p>
    <p class=”p2″><span class=”s1″>Si vous pensez qu’il s’agit d’une erreur du serveur, veuillez contacter le <span class=”s2″>webmestre</span>.</span></p>
    <p class=”p3″><span class=”s1″><b>Error 404</b></span></p>
    <p class=”p4″><span class=”s3″><i>localhost</i></span></p>
    <p class=”p5″><span class=”s1″><i>Apache/2.4.41 (Unix) OpenSSL/1.1.1d PHP/7.1.32 mod_perl/2.0.8-dev Perl/v5.16.3</i></span></p>

    <address>”</address>

    • Cette réponse a été modifiée le il y a 3 weeks et 3 jours par  sebbultel.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2282099
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Pour xampp c’est absolument sûr: les adresses site url et home devraient être “http://localhost/nomdusite “.

    Pouvez vous taper dans votre navigateur localhost/phpmyadmin pour voir si ça vous conduit bien sur la bonne page.

    #2282107
    sebbultel
    Participant
    Initié WordPress
    9 contributions

    Oui j’y arrive

    #2282108
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Donc, modifiez dans votre base de donnée les deux adresses, mettez dans wp-config le nom  de la base de données et son préfixe (normalement wp_) et remplissez-le comme sur la pièce jointe. Ne touchez à rien d’autre. Cela devrait marcher et vous devriez avoir accès au site et à l’admin mais vous ne verrez probablement pas vos images (les liens seront brisés). C’est normal. On modifiera après.  Pour le moment, avez vous accès au site? Pour l’autre message, on verra aussi après que vous ayez rétabli l’accès à votre site.

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.