Bug commentaires+dailymotion avec IE7

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #459990
    bilibou
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.5.1
    – Thème utilisé :
    – Plugins en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    Problème(s) rencontré(s) :
    IE 7 me pose de gros problèmes, à chaques fois que je souhaites ouvrir un post qui contient une vidéo dailymotion et le formulaire pour poster des commentaires j’ai le droit à un message d’erreur “Internet explorer ne peut pas ouvrir… Opération abandonnée”. Comme toujours tout fonctionne parfaitement bien sur Firefox et Safari.

    Je précise aussi que c’est bien le couple formulaire de commentaires + vidéo dailymotion qui pose problème (si il n’y a que la vidéo dailymotion pas de problèmes). Le problème est observable ici.

    Merci de votre aide, ce bug est vraiment vraiment embétant car mon site utilise beaucoup dailymotion.

    #632186
    Soph
    Membre
    Chevalier WordPress
    149 contributions

    Le formulaire de wordpress ?

    En tout cas aucune erreur en passant par IE7 je n’ai.

    PS joli blog bien que je déteste scroller à l’intérieur d’une fenêtre.

    #632187
    bilibou
    Participant
    Initié WordPress
    7 contributions

    Merci pour le compliment :-D

    Pour le problème il venait apaprement du code de dailymotion, lorsque j’ai réactivé l’utilisation de l’éditeur visuel wordpress m’a modifiè le code d’embed de dailymotion et depuis tout va bien. Comme quoi bien que je n’aime aps que l’éditeur visuel modifie mon code des fois ça a du bon.

    A++

    #632188
    CurLy
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    J’ai le même problème mais ca m’affiche le message d’erreur sur l’index ….

    Ma configuration WP actuelle
    – Version de WordPress : 2.5.1
    – Thème utilisé : Personal
    – Plugins en place :
    – Nom de l’hebergeur : Plexiweb
    – Adresse du site : http://www.lelagon.org/

    Apparemment ça viendrait de l’extension Anarchy Media Player étant donné qu’en la désactivant, je n’ai plus l’erreur … comment corriger ça tout en gardant l’extension … mes vidéos ne vont plus s’afficher sans 😕

    Merci beaucoup pour votre aide 🙂

    #632189
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    Bonjour,
    J’ignore si l’extension est en cause – et ce serait dommage, on a bien envie d’y plonger dans ton lagon !- mais la validation de ta page, par exemple par Total Validator sous FF, donne une tripotée d’erreurs, que tu vas devoir corriger avant d’obtenir un affichage correct partout…
    Courage !

    #632190
    CurLy
    Participant
    Initié WordPress
    13 contributions

    Merci pour les conseils, je vais repasser ma page au validateur et tenter de résoudre certains des problèmes (bien que je soit pas un expert en programmation php/html/java ….).

    Edit> La plus part des erreurs proviennent de codes que j’ai rajouté ou alors d’extensions … quel noob je suis ^^

    #632191
    CurLy
    Participant
    Initié WordPress
    13 contributions

    Re,

    Donc … ça fait une 2 petites heures que je penche sur le problème. Je règle un problème et 10 autres sont détecté en contre partie, je sais pas si le site est fiable, surtout qu’il me détecte des liens mort qui ne le sont pas.

    De plus, dans un premier temps et le plus rapidement possible, j’aimerais corriger le problème d’inaccessibilité d’internet explorer, je fais partie d’un “concours” de blog et ça me fait chier (désolé pour l’expression) que les personnes souhaitant venir sur mon blog, ne peuvent le faire avec IE …

    Sachant que ça vient de Anarchy Media Player, si je le désactive, la page met une plombe pour se charger entièrement et les vidéos ne s’affiche plus. Je peux peut être modifier le code de l’extension mais je sais pas si je suis assez calé pour le faire … Apparemment, ça pourrait venir de la (?):

    538 next problemprevious problemE609 This tag or content is not allowed here. One of the following was expected: <sub> <bdo> <var> <img>
               <sup> <br> <kbd> <strike> <button>  <map>  <del> <samp> <acronym> <b>
               <font> <a> <ins> <abbr> <label> <code>  <i> <cite> <u>   <s> <strong>
              <tt> <textarea> <q> <em> <big>  <small> <span> <dfn>
                             <div id="fo_targ_x5vben1004478649" class="flashmovie">
     538                     </div>

    Encore merci pour votre aide 🙂

    #632192
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    Salut Curly,
    Je suis trop incompétent pour te répondre directement, mais je t’indique en tout cas, à toutes fins utiles, que sous IE7, tout s’affiche visuellement sans problème, mais qu’une erreur est signalée sur la page d’accueil : ligne 543, caractère 2, SWFObject’ est indéfini. Il m’en indique d’autres sur d’autres pages…
    Par ailleurs, ton blog n’affiche pas d’icône d’URL personnalisée, ce qui pour un concours de blogs peut peut-être te pénaliser ?
    Courage en tout cas..!

    #632193
    CurLy
    Participant
    Initié WordPress
    13 contributions

    Etonnant, j’ai toujours l’erreur ainsi que d’autres personnes et au boulot aussi comme le montre le screenshot suivant :

    sanstitre2oh6.th.jpg

    Ensuite je suis redirigé sur une page Serveur introuvable …

    Sous FF, ça marche très bien, même pas d’erreur 😕

    Concernant le favicon (icône d’URL personnalisée), c’est vrai que je peux en mettre en place … je vais corriger ça, merci 🙂

    #632194
    CurLy
    Participant
    Initié WordPress
    13 contributions

    Bon,

    J’ai bien avancé :

    – Désactivation de Anarchy media player
    – Il s’avère que même avec Wordress Plugin Video, le code pour les vidéos relatif à Dailymotion pose problème … même message d’erreur.
    – Points positifs, maintenant, les vidéos s’affichent bien, plus de message d’erreur sous IE, je vais tester l’extension Embedded Video with Link pour vois si je peux lire les vidéos dailymotion sans avoir le message sous ie.
    – Par contre, le favicon ne s’affiche pas sous ie et l’extension (Vril’s Transparent PNG Fix) corrigeant soit disant la transparence (.png) sous ie ne fonctionne pas.

    à suivre …

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.