Bouton téléverser une extension disparu et impossible via FTP (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
  • Ce sujet contient 19 réponses, 3 participants et a été mis à jour pour la dernière fois par Flobogo, le il y a 1 minute.
15 sujets de 1 à 15 (sur un total de 20)
  • Auteur
    Messages
  • #2375376
    Solene78
    Participant
    Initié WordPress
    10 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 7.3.27 / MySQL v5.6
    • Thème utilisé : The 7
    • Extensions en place : Contact form 7 + CFDB7 / cookie notice / formidable forms / mailPoet 3 / Newstat Press / SecuPress Pro / Spider Event Calendar / The 7 elements / The 7 slider Révolution / The 7 ultimate addons for WPBakery / The 7 WPBakery  Page builder / UpdraftPlus / WP Mail SMTP / WP Maintenance Mode / WP Test Email / WP to Buffer / WP2Social Auto Publish / WPS Hide Login
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://www.catholiquesmantois.com/

    Problème(s) rencontré(s) : Le bouton pour téléverser une extension a disparu et lorsque je la télécharge via FTP, FileZila me dit que le transfert a réussit mais elle n’apparait pas dans le back-end. Je peux toujours ajouter une extension proposée par WP.

    J’ai désactivé tous les plugins 1 par 1 ainsi que le thème sans succès. J’ai aussi supprimé les extensions inactives et vérifié la santé du site via l’outils de tableau de bord, mais ça n’a rien changé. J’ai aussi fait une recherche sur google mais les rares personnes à avoir eu le problème n’ont pas l’air de l’avoir résolu…

    Est-ce que quelqu’un aurait une idée ?

    Merci d’avance pour votre aide ! 🙂

    #2375386
    PhiLyon
    Modérateur
    Maître WordPress
    27687 contributions

    Bonjour.

    WordPress n’est pas à jour CMS: WordPress 5.4-5.4.2

    Fais donc la mise à jour en 5.7, cela ne t’est pas proposé dans ton admin ?

    🙂

    #2375479
    Solene78
    Participant
    Initié WordPress
    10 contributions

    Bonjour PhiLyon,

    La mise à jour a été le 24/03 et quand je regarde les infos dans l’admin, il me dit bien que WP est en 5.7.1

    Cependant, si tu as trouvé cette info, c’est peut-être qu’il y a eu un bug lors de la mise à jour. Comment puis-je vérifier ?

    #2375480
    PhiLyon
    Modérateur
    Maître WordPress
    27687 contributions

    Bonjour.

    C’est indiqué en bas à droite de l’écran dans Tableau de bord/Accueil, et sinon dans Outils/État de santé du site/Informations.

    🙂

    #2375485
    Solene78
    Participant
    Initié WordPress
    10 contributions

    Oui, je confirme que c’est bien la version 5.7.1 Mais où as-tu eu l’info que WordPress était en  5.4-5.4.2 ? 

    #2375486
    PhiLyon
    Modérateur
    Maître WordPress
    27687 contributions

    Sur un site d’analyse https://sitecheck.sucuri.net/results/https/www.catholiquesmantois.com

    Mais ils se trompent parfois, la preuve.

    Tu n’as pas une extension de cache ?

    Tu n’as pas atteint le maximum de ton offre chez ton hébergeur ?

    🙂

    • Cette réponse a été modifiée le il y a 2 semaines et 6 jours par PhiLyon.
    #2375977
    Flobogo
    Gestionnaire du forum
    Maître WordPress
    17236 contributions

    Bonjour,

    Le bouton pour téléverser une extension a disparu (…). Je peux toujours ajouter une extension proposée par WP

    Ces 2 informations sont contradictoires. Comment pouvez-vous ajouter une extension WP, si vous n’avez pas accès au bouton “ajouter une extension” ? Que ce soit une extension WP ou une extension payante, c’est la même procédure pour l’installer.

    #2375997
    Solene78
    Participant
    Initié WordPress
    10 contributions

    Bonjour Flogobo,

    Vous me dites :

    Ces 2 informations sont contradictoires. Comment pouvez-vous ajouter une extension WP, si vous n’avez pas accès au bouton “ajouter une extension” ? Que ce soit une extension WP ou une extension payante, c’est la même procédure pour l’installer.

    Ben non en fait, ce n’est pas contradictoire et ce n’est pas la même procédure. Je n’ai pas dis que je n’avais pas accès au bouton “ajouter une extension” mais que le bouton “téléverser une extension” a disparu.

    Lorsque vous êtes dans l’onglet Ajouter une extension, vous avez la possibilité d’en chercher via le bouton “rechercher des extension” et vous n’avez plus qu’à cliquer dessus. Mais si vous voulez en télécharger une qui ne figure pas dans le catalogue WP, vous devez la télécharger via le bouton “téléverser une extension” ou via FTP. Ce n’est pas du tout la même chose. Ci-joint 2 capture d’écran d’admin. Vous pouvez voir en haut que sur l’une le bouton figure bien mais pas sur l’autre.

    Et quand j’essaie via ftp, FileZila me dit que le transfert a réussit mais elle n’apparait pas dans le back-end.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2376018
    PhiLyon
    Modérateur
    Maître WordPress
    27687 contributions

    Bonjour.

    Tu es bien en administratrice ?

    🙂

    #2376110
    Flobogo
    Gestionnaire du forum
    Maître WordPress
    17236 contributions

    @philyon vous propose une piste ci-dessus.

    Si ce n’est pas ça le problème, j’ai une autre piste : peut-être que votre WP est mal passé en version WP 5.7.1, ce qui expliquerait que Sucuri le voit encore en 5.4.2. Vous étiez passé par les versions intermédiaires 5.5.x et 5.6.x ? Ou bien vous avez mis directement à jour, de la 5.4.x à 5.7.1 ?

    #2376117
    Solene78
    Participant
    Initié WordPress
    10 contributions

    Bonjour,

    C’est un site dont j’ai repris la maintenance il y a peu donc, je suis effectivement passé de Widows 5.4.2 à 5.7.1 directement.

    Comment puis-je vérifier que le problème vient de là et y remédier ?

    #2376165
    Flobogo
    Gestionnaire du forum
    Maître WordPress
    17236 contributions

    Il faut revenir en arrière pour mettre à jour version par version.

    Puisque vous êtes chez OVH, faites une restauration à J – 2 semaines (tuto)

    Ensuite, suivez soigneusement ces consignes pour mettre à jour version par version, pour passer de 5.4.2 à 5.4.5 d’abord, puis à 5.5.4, puis à 5.6.3, avant d’arriver en 5.7.1.

     

    #2376431
    Solene78
    Participant
    Initié WordPress
    10 contributions

    Bonjour Flobogo,

    Je vous remercie pour vos messages. Je vais essayer votre solution mais j’ai un pb d’accès à ovh pour l’instant.
    Je vous tiendrais au courant si je réussis ou non à résoudre mon problème.

    Bonne journée.

    Édit : retrait du mode “privé”, réservé aux messages contenant des informations confidentielles.

     

    • Cette réponse a été modifiée le il y a 1 semaine et 2 jours par Flobogo. Raison: retrait du mode "privé" (aucune info compromettante)
    #2376540
    Flobogo
    Gestionnaire du forum
    Maître WordPress
    17236 contributions

    OK, pas de souci. Pour accéder au FTP ou à la restauration, il faut en effet connaître vos identifiants OVH. Attention, la restauration n’est possible que jusqu’à 3 semaines.

    Vous n’aviez pas répondu @philyon : vous êtes bien connectée en tant qu’administratrice du site ? Sinon, c’est normal de ne pas avoir accès à certaines fonctions comme l’ajout d’extension.

    #2376769
    Solene78
    Participant
    Initié WordPress
    10 contributions

    Bonjour,

    Oui, je suis bien connectée en tant qu’administratrice. J’ai enfin pu récupérer les codes d’ovh. Le pb c’est qu’effectivement la mise à jour a plus de 3 semaines. J’ai voulu ré installer la sauvegarde que j’avais fais avant via FTP, mais ça a complètement planté le site…

    Je l’ai remis grâce à OVH mais je me retrouve de fait, au point de départ. J’ai d’ailleurs d’autres buggs qui apparaissent mais j’ai un peu peur de retenter une ré installation…

     

15 sujets de 1 à 15 (sur un total de 20)
  • Vous devez être connecté pour répondre à ce sujet.