• Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #565420
    bertrand1303
    Participant
    Initié WordPress
    16 contributions

    Bonjour à tous,

    Merci, avec votre aide et beaucoup de recherche et patience, j’ai réussi à modifier ma barre de recherche roll-life.fr .
    Toutefois, lorsque l’on clique sur « Quand » une liste de mois se déroule. Et là, il manque OCTOBRE et DECEMBRE.
    Ces mois ont pourtant été traduit comme les autres. ( Il manquaient déjà avant traduction ) !
    Avez-vous une idée pour régler ce problème parceque là je ne sais même pas par ou commencer les recherches.
    Merci.

    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    Problème(s) rencontré(s) :

    #1064422
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Bonjour.

    Ouvres ton fichier fr_FR.po avec Notepad++ et vérifies que les traductions ajoutées ont le même code que les autres, comme ça

    #: ../archive.php:26
    #, php-format
    msgid « Yearly Archives: %s »
    msgstr « Archives annuelles: %s »

    Les guillemets, etc.

    🙂

    #1064421
    Lumiere de Lune
    Participant
    Maître WordPress
    20531 contributions
    bertrand1303 wrote:
    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    ???

    ça aiderait à aider….

    #1064423
    bertrand1303
    Participant
    Initié WordPress
    16 contributions

    Bonjour,

    Merci…. j’ai ouvert avec note pas effectivement, il manquait une ligne par rapport aux autres mois :

    Voici un mois visible :
    #: post-types/tours/lib/template-helpers.php:619
    #: post-types/tours/shortcodes/templates/tours-filters-holder.php:38
    msgid « September »
    msgstr « Septembre »

    et un mois non visible :
    #: post-types/tours/lib/template-helpers.php:620
    msgid « October »
    msgstr « Octobre »

    J’ai donc rajouter la ligne en changeant le numéro (car j’ai remarqué que chaque mois su suivait. ) :
    #: post-types/tours/shortcodes/templates/tours-filters-holder.php:39

    Mais les mois manquant n’apparaissent toujours pas :(

    #1064424
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Il faut que tu ré-ouvres le fichier avec Poedit et que tu l’enregistres pour qu’il mette à jour le fichier .mo

    #1064425
    bertrand1303
    Participant
    Initié WordPress
    16 contributions

    Merci.
    Non toujours pas. J’ouvre avec Poedit, je l’enregistre. Je balance le .po et .mo sur le ftp mais ces 2 mois n’apparaissent toujours pas. Je trouve cela compliqué. Je ne trouve aucune solution sur le net. En tous cas merci de m’indiquer la marche a suivre !!

    #1064426
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Tu as vidé le/les caches ?

    #1064427
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Est-ce que tu as regardé dans post-types/tours/shortcodes/templates/tours-filters-holder.php s’il y avait bien une ligne 39 ?

    Sinon, signales le problème sur le support du thème.

    🙂

    #1064428
    bertrand1303
    Participant
    Initié WordPress
    16 contributions

    Il Manque les 2 mois dans le PHP:

    <?php

    Est-ce qu’il est possible de les rajouter vous pensez ??

    #1064429
    PhiLyon
    Modérateur
    Maître WordPress
    28260 contributions

    Tu n’as pas le choix, vas-y (repères les numéros des lignes), fais une sauvegardes du fichier avant et toujours avec Notepad++

    🙂

    #1064430
    bertrand1303
    Participant
    Initié WordPress
    16 contributions

    J’ai donc rajouté les lignes. Au début cela ne marchait pas car même en faisant un copier coller d’une ligne et en modifiant le nom et la valeur, la ponctuation se modifie toute seule sur notepad. Les guillemets n’étaients pas les memes. J’es donc copier chaque guillemets un par un…. ca ne marchait toujours pas.
    En écrivant lettre par lettre le mois concerné et en faisant CTRL Z à chaque lettre, les guillemets se sont mis comme il fallait….. TROP bieard tout ça, je vous l’accorde.

    En tous cas ça marche !!!!!

    Et je vous remercie énormément de m’avoir débloqué. Je ne sais pas comment je ferais sans ce forum d’entraide !!!

    A bientôt pour un prochain problème à résoudre 🙂 :p

    #1064431
    bertrand1303
    Participant
    Initié WordPress
    16 contributions

    Oui ca j’y avait pensé. Mais non ça ne fonctionne pas. Je vais recommencer toute la manip !!!!

12 sujets de 1 à 12 (sur un total de 12)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.