Blog qui ne s’affiche pas (Créer un compte)

  • WordPress :5.0
  • Statut : non résolu
9 sujets de 31 à 39 (sur un total de 39)
  • Auteur
    Messages
  • #2242196
    ouiouiphoto
    Participant
    Maître WordPress
    1539 contributions

    Donc tu n’es pas sur le bon hébergement 😉  la base WP c’est un truc totalement différent ?

    #2242203
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Si, c’est le bon hébergement ! C’est pour ça que je n’arrive pas à comprendre !

    En fait la base de données qu’utilise mon WordPress est située sur https://phpmyadmin.ovh.net/mysql51/ C’est donc bien chez OVH ! Et l’identifiant de cette base n’est pas le même que celui qui est affiché sur mon espace OVH !!! Étrange non ?

    J’ai un identifiant : 186044-1 et donc c’est avec cet identifiant que WordPress se connecte à la base (j’ai bien tous les bons éléments dans le fichier wp-config (avec entre autres 186044-1 comme usermane de la base) !

    En revanche, en effet, sur mon espace OVH il est indiqué josephis comme nom d’utilisateur et de base ! Or elle est vide et donc non utilisée ! Bref, mon blog est géré avec une base chez OVH mais pas celle qui apparaît dans mon espace ! ? C’est le binz ! Je vais voir ça avec eux, il y a un pataquès ce qui explique peut-être qu’ils n’arrivent pas à voir d’ou peu venir le problème !

    #2242209
    ouiouiphoto
    Participant
    Maître WordPress
    1539 contributions

    Attention a ne pas confondre le host de la base de donnée, la base de donnée  et le user pour s’y connecter. Mais bon si tu te connecte a la seule base de ton hébergement avec phpmyadmin et que c’est vide c’est qu’il y a en effet un problème

    #2242213
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    En fait je n’arrive pas à me connecter josephis avec phpmyadmin mais à 186044-1 et le host est sql6.modules (par le lien indiqué dans mon post précédent) !  C’est juste que dans mon espace OVH, la base indiquée n’est pas la bonne !

    Mon fichier ove.config est correct (avec les bons host, user et password) sinon, le blog ne fonctionnerais pas !

    #2242216
    ouiouiphoto
    Participant
    Maître WordPress
    1539 contributions

    Attendons la réponse d’OVH….. essaye sur twitter. Ils sont des fois plus véloce la bas

    #2242219
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Je vais voir ça ! le temps de bien préparer ma question pour qu’elle soit le plus limpide possible !

    #2242370
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Hello, la réponse de OVH.

    Bonjour Joseph,

    Rassurez-vous, ceci s’explique simplement par le fait que le module utilise une base de données de module (non incluse dans votre hébergement).

    Ces bases gratuites ne peuvent être gérées dans l’espace client. Cependant la base de module peut toujours être manipulée dans PhpMyadmin disponible ici : https://phpmyadmin.ovh.net/mysql51/

    En utilisant les informations de connexion à la base(que vous retrouvez dans la configuration de WordPress).

    Je reste à votre disposition pour toute demande complémentaire.

    Cordialement.

    Nicolas C.

    Technicien Support IT Expert – Dysfonctionnements Web

    Bon, c’est déjà plus clair. Ça fait, heureusement un bon moment que je sais me connecter à ma base de données, et ça m’a bien aidé, quand il m’a fallu réinitialiser mon mot de passe admin après un blocage. Après, il me semble, mais ça remonte à plus de 5 ans maintenant, que j’avais utilisé un module pour installer wordpress, ce qui explique sans doute cette base de données « différente » ! Mais assez vite, j’ai ré-installé un wordpress complet pour éviter les limitations du module wordpress d’OVH. mais j’ai sans aucun doute conservé la même base de données.

    Sinon, je n’ai toujours pas d’explications sur la « panne » qui a bloqué mon blog pendant plus de 5 jours. Et comme je n’ai pas accès au logs SQL à partir de mon espace OVH, difficile d’investiguer plus. J’espère que ça ne va pas se reproduire.

     

    #2242377
    ouiouiphoto
    Participant
    Maître WordPress
    1539 contributions

    Tu peux leur demander comment accéder au statistiques de cette base de module.  C’est la première fois que j’entends parler de cette base de module. Lorsque j’avais installé mon WP il y a déjà pas mal de temps de devais choisir une base de mon hébergement. Mais bon je ne connais pas tout chez eux 😉

    Une solution serait de migrer cette base sur ta vraie base

    #2242379
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    J’ai crée mon blog chez OVH en octobre 2013. Avant j’avais un blog sur un hébergement Free, sur la plate-forme Dotclear, depuis 2004. Mais comme j’avais par flemme laissé passé un bon nombre de mises à jour de Dotclear et que ça devenait un poil compliqué, j’ai décidé de tenté l’aventure sur WordPress. Après avoir pris pas mal de renseignement, vu que WordPress chez Free, ce n’était pas top, j’ai pris un hébergement OVH (en profitant d’une offre je crois bien). Et ne voulant pas me compliquer la vie, j’ai installé un module WordPress chez OVH. Sauf que au bout de quelques semaines, je me suis rendu compte que les mises à jours de WP étaient compliquées (voire impossibles) avec ce genre de module tout fait ! Quand j’ai utilisé ce module, la base de données « gratuite » était donc celle que j’utilise toujours. Je n’ai pas changé quand j’ai pris la décision de remplacer le « module » par une installation complète de WP.

    Bref, en dehors de la faire migrer vers la base indiquée sur mon espace client, apparemment on ne peut pas la gérer à partir de l’espace. Une limitation sans doute.

    Pour le moment la migration ne presse pas, mais quand j’ai essayé de passer (à partir des outils OVH) en PHP7.2, ça coupe le lien vers mon blog. À croire que cette base de données n’aime pas le PHP7.2, ni 7.1 d’ailleurs et même si j’essaye de passer en PHP7.00 stable (je suis en « legacy »), plus de connexion vers la base de données. Et blog inaccessible ! Bref, compliqué.

    De toute manière, la « vraie » base est vide, puisque je ne l’ai jamais utilisée. Et pire, je n’arrive pas à y accéder, je ne sais pas pourquoi.

9 sujets de 31 à 39 (sur un total de 39)
  • Vous devez être connecté pour répondre à ce sujet.