Blog inaccessible (Créer un compte)

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #564079
    founiouk
    Participant
    Padawan WordPress
    73 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.XX
    – Version de PHP/MySQL : 5.6
    – Thème utilisé : Saga (?)
    – Extensions en place : WpBackup, …
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://founiouk.com/

    Problème(s) rencontré(s) :

    Bonjour, j’ai récemment appelé le service assistance d’OVH par téléphone. Mon serveur PHP n’était pas à jour. Après l’avoir mis à jour un des plug ins de WordPress ne fonctionnait plus, j’ai donc supprimé via FTP ce plug in ce qui a provoqué ceci « Fatal error: Class ‘WP_Theme’ not found in /home/founiouk/www/wp-includes/theme.php on line 111 » et rendu le blog inaccessible.

    La line 111 indique : return new WP_Theme( $stylesheet, $theme_root );

    Pouvez-vous m’aider à résoudre ce problème svp ? Cas échéant je supprime tout et réinstalle ?

    Merci, Founiouk.

    #1059400
    bill57
    Participant
    Maître WordPress
    858 contributions

    salut, remets via ftp ton plugin qui ne fonctionne pas et regardes si tu peux te connecter
    puis desinstalles le

    #1059401
    founiouk
    Participant
    Padawan WordPress
    73 contributions

    Ca semble bizarrement un problème lié au thème. Il y a une astuce pour tout réinitialiser ? Au minimum les thèmes ?

    #1059402
    bill57
    Participant
    Maître WordPress
    858 contributions

    désactives le theme par ftp en le renommant

    #1059403
    Flobogo
    Modérateur
    Maître WordPress
    20164 contributions

    Bonjour,

    Demandez dans votre panel OVH une restauration de site à J-3 ou J -1 semaine
    Ensuite, remettez à jour la version PHP si ce réglage a sauté avec le retour en arrière
    Pour finir, désactiver le plugin à partir du tableau de bord WP, et supprimez-le également à partir du tableau de bord.
    On ne supprime pas un plugin encore actif par le FTP ! (c’est comme de débrancher un lave-linge ou un ordinateur quand il tourne : il n’aime pas ça du tout !)

    #1059404
    founiouk
    Participant
    Padawan WordPress
    73 contributions

    Le problème c’est que j’ai eu ce problème il y a deux mois, je n’ai su m’en occuper que maintenant. Je ne sais pas faire de restauration plus tôt que 1 semaine.

    #1059405
    Flobogo
    Modérateur
    Maître WordPress
    20164 contributions

    Dans ce cas, suivez les indications de Founiouk :
    – par FTP (u deuis votre panel OVH si c’est possible ?), désactivez votre thème en le renommant, juste avec un X à la fin –> wp-content/themes/sagaX , et testez.
    Si ça résout le problème, c’est que ça vient du thème, et il faudra en changer.
    – Si ça ne résout pas le problème, essayez de renvoyer le dossier dézippé du plugin que vous aviez supprimé(par FTP ou en passant par votre panel OVH) –> dans wp-content/plugins

    #1059406
    founiouk
    Participant
    Padawan WordPress
    73 contributions

    Merci à tous pour vos conseils. J’ai replacé le theme et me voici avec « BackWPup requires PHP version 5.2.7 with spl extension or greater and WordPress 3.4 or greater. »

    Or j’ai mis a jour le PHP en 5.6, je ne sais pas comment ajouter le spl ni mettre à jour Wp si rien n’est accessible.

    #1059407
    Flobogo
    Modérateur
    Maître WordPress
    20164 contributions

    Désactivez tous vos plugins par FTP en renommant le dossier des plugins avec un X à la fin –> wp-content/pluginsX

    #1059408
    founiouk
    Participant
    Padawan WordPress
    73 contributions

    Flobogo, c’est fait mais j’ai juste une page blanche maintenant.

    #1059409
    Flobogo
    Modérateur
    Maître WordPress
    20164 contributions

    Mettez wordpress à jour manuellement, en partant de la version la plus proche de la vôtre.
    Les anciennes versions se téléchargent là : https://fr.wordpress.org/releases/
    Suivez les indications du Codex pour la mise à jour manuelle : https://codex.wordpress.org/fr:Details_de_mise_a_jour
    Faites ce que vous pouvez comme sauvegardes préalables : base de données par PhpMyAdmin et wp-content par FTP

    #1059410
    founiouk
    Participant
    Padawan WordPress
    73 contributions

    Bonjour, j’ai downgrade à la version 4.4.4 et j’ai ça qui s’affiche

    Warning: require(/home/founiouk/www/wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/founiouk/www/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required ‘/home/founiouk/www/wp-blog-header.php’ (include_path=’.:/usr/local/lib/php’) in /home/founiouk/www/index.php on line 17

    #1059411
    Qwindoo
    Modérateur
    Maître WordPress
    2861 contributions

    Hello,

    Pour le coup, je te conseille au contraire de passer à la version de PHP la plus élevée à laquelle tu as accès, ainsi qu’à la toute dernière version de WordPress.

    Tant pis pour ton extension de backup, il en existe bien d’autres tout aussi efficaces et surtout compatibles avec les dernière versions de WP et de PHP. En voici une gratuite et censée fonctionner avec PHP 5.6.

    #1059412
    founiouk
    Participant
    Padawan WordPress
    73 contributions

    Redémarrer de zero donc. Dans ce cas comment récupérer les articles ? Un copier coller du wp-content suffit ?

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.