Blog en https, mais des liens http dans le deader (Créer un compte)

  • WordPress :5.2
  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #2258905
    ebouilleur
    Participant
    Initié WordPress
    26 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : php 7.2 / mysql 5.7
    • Thème utilisé : twentyseventeen
    • Extensions en place : yoast seo
    • Nom de l’hébergeur : VM gandi
    • Adresse du site : https://www.pelotes-compagnie.fr/blog/

    Problème(s) rencontré(s) :

     

    Je voulais passer mon blog en https en utilisant cloudflare.

    Au niveau du blog, j’ai donc rajouter dans le wp-config :

    /** Définir l'URL par défaut */
    define('WP_HOME', 'https://www.pelotes-compagnie.fr/blog');
    define('WP_SITEURL', 'https://www.pelotes-compagnie.fr/blog');

    et j’ai remplacer dans mes tables tout ce qui était http en https.

    Mais ça bug, et quand je regarde mon code source, on voit u mélange de http et https… et je ne vois pas ce qui crée ce problème.

    <script type='text/javascript' src='http://www.pelotes-compagnie.fr/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
    <script type='text/javascript' src='http://www.pelotes-compagnie.fr/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
    <link rel='https://api.w.org/' href='https://www.pelotes-compagnie.fr/blog/wp-json/' />
    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.pelotes-compagnie.fr/blog/xmlrpc.php?rsd" />
    <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.pelotes-compagnie.fr/blog/wp-includes/wlwmanifest.xml" />
    <meta name="generator" content="WordPress 5.1.1" />
    <link rel="icon" href="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-32x32.png" sizes="32x32" />
    <link rel="icon" href="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-192x192.png" sizes="192x192" />
    <link rel="apple-touch-icon-precomposed" href="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-180x180.png" />
    <meta name="msapplication-TileImage" content="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-270x270.png" />
    </head>

    Une idée?

    Merci pour votre aide

    • Ce sujet a été modifié le il y a 5 années et 2 mois par ebouilleur.
    #2258907
    ouiouiphoto
    Participant
    Maître WordPress
    1539 contributions

    Bonjour

    Pour remplacer http://tondomaine  par https://ton domaine pourquoi ne pas utiliser une extension better search replace. Car la il reste plein de choses en http qui sont bloquées et donc ton site n’apparaît pas correctement

     

    Si tu as chrome tu fais un clic droit puis inspecter puis tu vas dans l’onglet security et tu recharge ta page. Tu veras tout ce qu’il ne va pas

    #2258925
    ebouilleur
    Participant
    Initié WordPress
    26 contributions

    J’ai installer le plugin, il m’a changer encore 14 url

    mais ça ne change rien à mon problème… c’est comme si wordpress ne voulait pas généré les url en https (enfin, pas toute…)

    <!-- / Google Analytics by MonsterInsights -->
    <!--[if lt IE 9]>
    <script type='text/javascript' src='http://www.pelotes-compagnie.fr/blog/wp-content/themes/twentyseventeen/assets/js/html5.js?ver=3.7.3'></script>
    <![endif]-->
    <script type='text/javascript' src='http://www.pelotes-compagnie.fr/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
    <script type='text/javascript' src='http://www.pelotes-compagnie.fr/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
    <link rel='https://api.w.org/' href='https://www.pelotes-compagnie.fr/blog/wp-json/' />
    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.pelotes-compagnie.fr/blog/xmlrpc.php?rsd" />
    <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.pelotes-compagnie.fr/blog/wp-includes/wlwmanifest.xml" />
    <meta name="generator" content="WordPress 5.1.1" />
    <link rel="icon" href="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-32x32.png" sizes="32x32" />
    <link rel="icon" href="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-192x192.png" sizes="192x192" />
    <link rel="apple-touch-icon-precomposed" href="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-180x180.png" />
    <meta name="msapplication-TileImage" content="https://www.pelotes-compagnie.fr/blog/wp-content/uploads/2016/12/cropped-ms-icon-310x310-270x270.png" />
    </head>

    #2258928
    ouiouiphoto
    Participant
    Maître WordPress
    1539 contributions

    Attention better search est en mode simulation par default.

    #2258929
    ebouilleur
    Participant
    Initié WordPress
    26 contributions

    Oui, j’avais bien vu 😉

    Résultat de l’essai : 14 tables ont été parcourues, 0 chaînes trouvées qui peuvent être mises à jour et 0 modifications auraient pu être apportées.

    • Cette réponse a été modifiée le il y a 5 années et 2 mois par ebouilleur.
    #2258932
    ouiouiphoto
    Participant
    Maître WordPress
    1539 contributions

    As tu redirigé les http vers https dans ton .htaccess ? Ca n’explique pas pourquoi tu as encore du http dans ton code mais ca peut aider

    #2258936
    ebouilleur
    Participant
    Initié WordPress
    26 contributions

    Oui j’avais essayer dans mon htacess, et aussi directement dans cloudflare

    mais oui dans tous les cas ça n’explique par pourquoi certains liens javascript et certains css sont en http et d’autres en https…

    j’ai essayer avec un autre theme et c’est parreil

    #2258955
    sebastienserre
    Participant
    Maître WordPress
    816 contributions

    Surement car ce sont des options sérialisées que les extensions n’arrivent pas a détecter.

    l’idéal si tu as un accès SSH c’est de le faire avec wp-cli ou d’utiliser le script d’interconnect’it https://github.com/interconnectit/Search-Replace-DB et remplacer tous les http par des https.

    Sinon il y a l’option https://fr.wordpress.org/plugins/really-simple-ssl/

    #2259146
    ebouilleur
    Participant
    Initié WordPress
    26 contributions

    J’ai fait un export de ma bdd (depuis phpmyadmin), et j’ai aucune url pointant vers mon site qui est en http du coup je comprend pas trop…

    tant pis je sens qu’il va rester en http et c’est tout.

    #2259345
    ebouilleur
    Participant
    Initié WordPress
    26 contributions

    Bon, ca me soule quand même alors j’essaye d’approfondir 😀

    Si je fais un :

    $url = site_url();
    echo $url;

    Ce m’affiche l’url de mon site en http, donc je pense que c’est une bonne piste. pourquoi il n’afficher pas https comme ce que je lui fixe? une idée?

    Edit : idem pour content_url() et includes_url() qui m’affiche http alors que je suis configuré en http

    merci

    • Cette réponse a été modifiée le il y a 5 années et 2 mois par ebouilleur.
    #2259354
    ebouilleur
    Participant
    Initié WordPress
    26 contributions

    En fait il faudrait pouvoir forcer $scheme à ‘https’

    mais je sais pas si ça peut se faire.

    Merci

    #2260146
    Flobogo
    Modérateur
    Maître WordPress
    20202 contributions

    Bonjour,

    Je vous conseille de lire ces tutos, et de vérifier si vous avez bien effectué tout ce qui est indiqué :

    Mais si vous n’y parvenez toujours pas, il reste la solution de l’extension Really Simple SSL, comme conseillé par Sébastien, en suivant ce tuto.

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.