Bibliothèque médias : problème de génération d’URL empêchant l’upload (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 38)
  • Auteur
    Messages
  • #558736
    Akadia
    Participant
    Initié WordPress
    30 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : dernière
    – Version de PHP/MySQL : 5.5
    – Thème utilisé : Divi
    – Extensions en place :
    – Nom de l’hebergeur : Webaxys
    – Adresse du site : http://are-btp.fr/

    Problème(s) rencontré(s) : Bonjour,
    Depuis que j’ai migré mon site sur un autre hébergeur, j’ai un problème d’affichage / d’upload des images.
    Le domaine de mon site est dédoublé sur les URL d’image, ainsi : http://are-btp.fr/http://are-btp.fr/wp-content/uploads/logo-booking-fever.png

    Je précise bien que pour les images existantes, c’est juste en back office, pas en front office.
    Quand j’ai chargé de nouvelles images (suite à la migration), WordPress a généré un nouveau chemin d’uploads :
    httpdocs/http:/are-btp.fr/wp-content/uploads/logo.png (httpdocs étant la racine du site).
    J’ai fouillé la base de données, sans succès.
    J’ai vraiment besoin de votre aide 😉, je vous en remercie vivement d’avance !

    #1039464
    mathieu789
    Participant
    Maître WordPress
    1084 contributions

    est ce que tu peux nous montrer un URL où on voit ce problème ?
    par exemple sur la page suivante qui a l’air d’être un nouvel article, l’image est au bon endroit :
    http://are-btp.fr/club-des-jeunes-dirigeants-des-entreprises-de-la-ffb-de-rouen-dieppe/

    #1039465
    Akadia
    Participant
    Initié WordPress
    30 contributions
    mathieu9512 wrote:
    est ce que tu peux nous montrer un URL où on voit ce problème ?
    par exemple sur la page suivante qui a l’air d’être un nouvel article, l’image est au bon endroit :
    http://are-btp.fr/club-des-jeunes-dirigeants-des-entreprises-de-la-ffb-de-rouen-dieppe/

    Je l’ai placée manuellement, via le FTP.
    Par ex. L’URL de l’image http://are-btp.fr/wp-content/uploads/SHT-3.jpg est correcte en frontoffice, mais au niveau de la Bib médias, elle apparait ainsi :
    http://are-btp.fr/http://are-btp.fr/wp-content/uploads/SHT-3.jpg

    #1039466
    Akadia
    Participant
    Initié WordPress
    30 contributions

    Dans la table “options”, j’ai changé :

    wp-content/uploads

    en

    http://are-btp.fr/wp-content/uploads

    toujours pareil…

    #1039467
    Akadia
    Participant
    Initié WordPress
    30 contributions

    upload_path dans la base de données

    #1039468
    luciole135
    Participant
    Maître WordPress
    13743 contributions
    Akadia wrote:
    Ma configuration WP actuelle
    – Version de WordPress : dernière ???????????? Précisez laquelle !
    – Extensions en place : ???????????

    Pourquoi n’avez-vous pas rempli complètement le questionnaire ?

    #1039469
    Akadia
    Participant
    Initié WordPress
    30 contributions

    Version WP : 4.4.1–fr_FR

    Extensions : Akismet, Another WordPress Classifieds Plugin (AWPCP), Custom Login, Duplicate Post, Elegant Builder, Elegant Theme updater, Layer Slider, Mailpoet, Shortcodes Ultimate, TinyMCE Advanced Really Simple Image Widget, Wordfence Security

    Merci

    #1039470
    Akadia
    Participant
    Initié WordPress
    30 contributions

    J’ai aussi essayé de en désactivant les extensions.

    #1039471
    luciole135
    Participant
    Maître WordPress
    13743 contributions

    J’ai déjà vu me même problème dans une autre discussion après une migration ratée, ce n’était pas vous déjà ?

    Avez-vous réenregistré les permaliens?

    #1039472
    Akadia
    Participant
    Initié WordPress
    30 contributions

    Oui exactement. J’ai réenregistré les permaliens. +essayé l’extension de réparation d’URL.
    Je suis bloquée avec ce problème. Éventuellement, je peux vous donner des accès en MP…

    #1039473
    luciole135
    Participant
    Maître WordPress
    13743 contributions

    Non, désolé je suis bénévole et je ne suis contre la gratuité du travail (bien que ce soit à la mode).

    Réenregistrez les permaliens avec la valeur par défaut dite simple, (normalement leur enregistrement supprime les rewrites rules dans le .htaccess).

    Vérifiez en téléchargeant le fichier .htaccess sur votre ordi que ces permaliens ont bien supprimés toutes les rewrite rules du .htaccess.

    #1039474
    Akadia
    Participant
    Initié WordPress
    30 contributions

    Ok, merci.
    j’ai réenregistré encore les permaliens en simple. Le htaccess est bien vidé des rewrite rules. Mais ça ne résout pas le problème

    #1039475
    luciole135
    Participant
    Maître WordPress
    13743 contributions

    Vérifiez les lignes siteurl et home dans la table de données wp_options avec phpMyAdmin. Ce doit être celles de votre site.

    #1039476
    Akadia
    Participant
    Initié WordPress
    30 contributions

    siteurl et home sont OK, ça ne vient pas de là

    #1039477
    luciole135
    Participant
    Maître WordPress
    13743 contributions
    Akadia wrote:
    Dans la table “options”, j’ai changé :

    wp-content/uploads

    en

    http://are-btp.fr/wp-content/uploads

    toujours pareil…

    Je n’ai pas cette ligne dans ma table de données wp-options !
    Où avez-vous effectué cette modification exactement ?

15 sujets de 1 à 15 (sur un total de 38)
  • Vous devez être connecté pour répondre à ce sujet.