Barre administration WP disparue

  • WordPress :5.2
  • Statut : non résolu
  • Ce sujet contient 14 réponses, 4 participants et a été mis à jour pour la dernière fois par ChrisLnn, le il y a 3 mois.
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #2286267
    ChrisLnn
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle :

    – Version de WordPress : 5.3
    – Version de PHP/MySQL : 7.2.19 / 5.6.43
    – Thème utilisé : Divi
    – Thème URI : http://www.elegantthemes.com/gallery/divi/
    – Extensions en place : All-in-One WP Migration (7.10), All-in-One WP Migration Unlimited Extension (2.32), Forum_wordpress_fr (4.2), TablePress (1.10), Yoast SEO (12.5.1)
    – Adresse du site : https://asos-conseil.fr
    – Nom de l’hébergeur : Apache

     

    Problème(s) rencontré(s) :

    Bonjour ,
    depuis hier, lorsque je vais sur les pages de mon site en étant connecté à mon wordpress, la wp admin bar n’est pas présente. Autrement dit , lorsque je navigue sur les pages de mon site (en étant connecté) , c’est comme si je naviguais comme un simple visiteur (non connecté).
    Mon thème (DIVI) qui propose normalement une interface pour modifier le site en directe sur les pages, n’affiche plus non plus cette interface…. Bref, ceci m’empêche de modifier les pages et c’est assez handicapant.

    Dans le même temps j’avais un problème d’affichage de la majorité des images, problème qui s’est réglé en désinstallant WP-super cache, mais la barre d’admin n’est pas réapparu pour autant…

    J’ai essayé de désactiver tous les autres plugins, ça ne change rien.
    J’ai essayé avec d’autres navigateurs, ça ne change rien .

    Auriez vous une idée d’où peut provenir ce pb et comment réactiver la barre ?
    Merci beaucoup
    Chris

    #2286268
    ChrisLnn
    Participant
    Initié WordPress
    8 contributions

    Petite correction, le problème au niveau de l’affichage des images ne s’est pas du tout réglé…toute aide sera la bienvenue 🙂

    #2286347
    jissey
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    verifie que wp_head() est bien présent dans le fichier header.php de ton thème et wp_footer() dans footer.php.

    Ceci dit, Divi étant une vrai usine à gaz, cette simple vérification n’est pas évidente!!

    #2286350
    ferman
    Participant
    Maître WordPress
    1884 contributions

    Bonjour,

    Quand on examine le html de votre image (exemple du drapeau français) on voit le code 1 (le src set  ne se référe pas au site https mais http). Vous devriez avoir le code 2. Quand on fait cette modif dans l’inspecteur, le drapeau français apparaît bien dans toute sa splendeur. Cela doit être pareil pour les autres images mais je n’ai pas essayé. Il faut modifier les liens dans la base de données.

    <img src="https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais.png" alt="" title="" srcset="https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais.png 2000w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-150x150.png 150w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-300x300.png 300w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-768x768.png 768w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-1024x1024.png 1024w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-1080x1080.png 1080w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-1280x1280.png 1280w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-980x980.png 980w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-480x480.png 480w" sizes="(max-width: 2000px) 100vw, 2000px">
    
    
    
    <img src="https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais.png" alt="" title="" srcset="http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais.png 2000w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-150x150.png 150w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-300x300.png 300w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-768x768.png 768w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-1024x1024.png 1024w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-1080x1080.png 1080w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-1280x1280.png 1280w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-980x980.png 980w, http://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-480x480.png 480w" sizes="(max-width: 2000px) 100vw, 2000px">

    • Cette réponse a été modifiée le il y a 3 mois par ferman.
    #2286358
    studiocreav2com
    Participant
    Padawan WordPress
    84 contributions

    Salut,

    Pour la barre admin, simple vérification, est ce qu’elle est activée au niveau de l’utilisateur (case  à cocher : “Afficher la barre d’outils lorsque vous visitez le site”)…

    #2286359
    studiocreav2com
    Participant
    Padawan WordPress
    84 contributions

    Pour les images, je rejoint Ferman, installe ‘Realy Simple SSL’ et tes soucis de conflit Http et https devraient êtres réglés…

    #2286380
    ferman
    Participant
    Maître WordPress
    1884 contributions

    Bonjour,

    @studiocreav2com

    On recommande souvent sur le forum “really simple ssl” en particulier quand un participant arrive en demandant comment passer de http en https ou ne s’en sort pas avec des redirections dans .htaccess. C’est simple et efficace. Mais quand il y a déjà de bonnes redirections placées dans .htaccess (ça doit être le cas ici) , c’est dommage de revenir dessus. Personnellement je recommande dans ce cas d’utiliser le plugin “better-search-replace” en faisant un peu attention bien sûr.

     

    #2286415
    ferman
    Participant
    Maître WordPress
    1884 contributions

    Bonjour,

    Je n’avais pas pris le temps de vérifier mais en fait il n’y a aucune redirection en place. Il faut en mettre: soit effectivement avec really simple ssl mais là comme il ne reste plus grand à faire je préférerais ne pas revenir dessus et mettre directement des redirections  dans .htaccess . La manière de faire varie légèrement selon l’hébergeur mais ce n’est pas difficile à faire.

    #2286465
    studiocreav2com
    Participant
    Padawan WordPress
    84 contributions

    Salut,

    100% d’accord avec toi Ferman !
    Quand je migre un site, je réécrit les URL dans ma Bdd depuis PhpMyAdmin (ou avec Search-Replace-DB-master )
    Realy Simple SSL est très bien quand tu n’as pas accès ni au Ftp, ni à PhpMyAdmin … pour éviter les contenus mixtes. Je le pose aussi quand le client gère son site et ne fais pas forcément gaffe quand il alimente son site.

    #2286601
    ChrisLnn
    Participant
    Initié WordPress
    8 contributions

    Bonjour à tous,

    et tout d’abord un énorme merci pour toutes vos réponses et bons conseils concernant mon (mes) problèmes suscités.

     

    Je n’ai pas eu le temps encore d’essayer vos solutions mais je vais m’y employer dès la fin de ce message.

    Pour ce qui est des images, je pense que cela a effectivement à voir avec la redirection, j’espère donc pouvoir régler le souci sans trop de difficultés.

    Cependant en ce qui concerne la disparition de la barre d’admin, en réponse à <span class=”bbp-author-name”>jissey</span> et <span class=”bbp-author-name”>studiocreav2com, wp_head() est bien présent dans le fichier header.php de mon thème et wp_footer() dans footer.php, et la barre d’admin est bien activé dans les options utilisateurs (j’avais déjà vérifié ce point, et cela m’aurait bien arrangé que ce soit juste une petite case à cocher pour régler ce mystère :D</span>

    Je vous tiens au courant dans la journée de mes avancées (et je l’espère de mes réussites ^^) et vous remercie encore grandement.

     

    Excellente journée à tous

     

    #2286605
    ChrisLnn
    Participant
    Initié WordPress
    8 contributions

    Bon je peux vous redonner des (bonnes ?) nouvelles plus rapidement que ce que je ne pensais…je me reconnecte sur /wp-admin de mon site, et là surprise, la barre d’administration s’affiche de nouveau en frontend…je n’y ai absolument pas touché du weekend, je suis donc assez décontenancé (mais ravi tout de même!) mais du coup il devait s’agir d’un simple bug..

    Et seconde surprise du Lundi, mes images s’affichent de nouveau, pensant qu’il s’agissait là aussi d’un bug ou que ce soit dû à mon cache, j’ai vérifié sur un autre ordi qui n’avait jamais été sur le site, et confirmation les images sont bel et bien là…

    Je ne sais pas si je dois être content de cela, je ne suis pas sûr d’aimer ne pas savoir d’où venait mon problème et encore plus de ne pas savoir pourquoi il s’est réglé miraculeusement de lui-même.

    Petite précision, je suis actuellement en train de suivre une formation en alternance (dév d’appli frontend) et je ne suis pas encore bien à l’aise à tout les niveaux, je ne sais pas trop si je dois m’inquiéter de cette résolution spontanée !

    Si vous avez une ou des explications sur cet état de fait, je serais ravi d’avoir vos points de vue, mais en tout cas merci à chacun d’avoir pris le temps de me répondre

    #2286606
    studiocreav2com
    Participant
    Padawan WordPress
    84 contributions

    Guérison miraculeuse ?! … Loué soit Saint-WP !!

    #2286607
    ChrisLnn
    Participant
    Initié WordPress
    8 contributions

    C’est à ni rien comprendre ! Je ne suis pas très pratiquant mais je vais me renseigner sur ce Saint-Wp, et peut-être brûler un cierge au passage 😉

    #2286611
    ferman
    Participant
    Maître WordPress
    1884 contributions

    Bonjour,

    Vous êtes sûr qu’il n’a pas d’autre administrateur (peut être un lutin facétieux?) parce que non seulement les urls de src set  sont tous repassés en https (et ne sont plus les mêmes: plus simples, comparez avec le code d’hier) mais la disposition des drapeaux me semble être différente. Ils étaient en triangle et les voila maintenant alignés. Ma mémoire me jouerait-elle des tours?

    <img src="https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais.png" alt="" title="" srcset="https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais.png 2000w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-1280x1280.png 1280w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-980x980.png 980w, https://asos-conseil.fr/wp-content/uploads/2019/11/drapeau-francais-480x480.png 480w" sizes="(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) and (max-width: 980px) 980px, (min-width: 981px) and (max-width: 1280px) 1280px, (min-width: 1281px) 2000px, 100vw">

    #2286632
    ChrisLnn
    Participant
    Initié WordPress
    8 contributions

    Je suis le seul maître à bord ! Le fils de ma cliente avait ouvert une instance Wp sur ce domaine (hébergeur OVH) mais il n’avait qu’installé un thème de base (twenty seventeen de mémoire) et fait quasi aucune modif.

    J’ai donc migré celui que je développais sur l’adresse finale (avant recette, pas très malin comme idée je vous l’accorde mais cela me servira de leçon) et donc il n’avait plus les accès à l’interface wp.

    Et je suis le seul utilisateur de créé (en admin of course) l’affaire reste assez flou pour le moment…!

    Par contre pour la disposition des drapeaux elle était bien en ligne depuis le début ! Petite blague de votre mémoire, cependant la disposition en triangle pourrait bien rendre, elle a le sens du style au moins

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.