Bannière aléatoire (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #455278
    go 2 ride
    Membre
    Initié WordPress
    42 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : Version 2.3.1
    – Thème utilisé : Nightlife 1.0
    – Plugins en place : Lightbox 2
    – Nom de l’hebergeur : W3M Solutions
    – Adresse du site : http://www.aquashoot.net/V3/ (phase de test pour le moment sinon http://www.aquashoot.net pour l’ancien site)

    Problème(s) rencontré(s) :

    Je souhaiterais insérer une bannière aléatoire (pas de flash car j’ai déjà testé et ça pose probleme avec Lightbox 2 car la bannière flash reste toujours au premier plan) donc je voulais de la banniere jpg que le site chargerait aléatoirement ! j’ai testé quelques script trouvé sur le net que j’ai inséré sur mon header.php de mon theme (voir ci dessous) mais toujours des erreurs de scripts à l’affichage !

    <div id="header">
    je mettais ici mon script !
    </div>

    #614269
    secmast
    Membre
    Chevalier WordPress
    227 contributions

    Bonjour,

    Une copie des erreurs et du script est apprécié :D

    #614270
    go 2 ride
    Membre
    Initié WordPress
    42 contributions

    Bah soit c’etait une include qui renvoyait vers le script en question soit je mettais ca direct mais lkes deux script se resemblaient bcp !!

    voilà le fameu script que j’ai mis en direct

    #614271
    secmast
    Membre
    Chevalier WordPress
    227 contributions

    Et dans le fichier banniere.txt ?
    Tu n’as pas copié les erreurs que tu avait :D

    #614272
    dlo
    Participant
    Maître WordPress
    1849 contributions

    Bon, il existe aussi des plugins pour obtenir le même effet, comme celui-ci par exemple.

    Cordialement

    #614273
    go 2 ride
    Membre
    Initié WordPress
    42 contributions
    secmast wrote:
    Et dans le fichier banniere.txt ?
    Tu n’as pas copié les erreurs que tu avait :D

    Dans le banniere.txt j’avais juste le code avec l’url de l’image donc rien de bien sorcier !

    J’essaye le plugin et je vous tiens au courant !!

    Merci

    #614268
    go 2 ride
    Membre
    Initié WordPress
    42 contributions

    Hop me revoilà !!
    Je seche un peu quand à l’installation de ce plugins !! J’ai du mal à traduire et bien comprendre !
    J’ai donc Up le plugins, créé le rep dans wp-content et j’y ai mis deux bannière de test mais la suite ? Je crois comprendre qu’il y a qq lignes de code à changer dans le CSS et le header.php mais j’arrive pas à tout traduire donc je seche là

    #614274
    dlo
    Participant
    Maître WordPress
    1849 contributions

    Il faut modifier la fonction hir_add_css() du plugin pour remplacer #headerID par le CSS id utilisé dans ton thème pour afficher l’image de l’entête.

    Mais il ne faut pas modifier ton thème…

    #614275
    go 2 ride
    Membre
    Initié WordPress
    42 contributions
    dlo wrote:
    Il faut modifier la fonction hir_add_css() du plugin pour remplacer #headerID par le CSS id utilisé dans ton thème pour afficher l’image de l’entête.

    Mais il ne faut pas modifier ton thème…

    je veux pas te vexer mais j’ai rien compris ! Je prend le CSS du plugin et je met quoi ?

    #614276
    dlo
    Participant
    Maître WordPress
    1849 contributions

    D’après la doc du plugin, il faut:

    1) Créer un répertoire wp-content/header-images
    2) Mettre les images qui serviront de bannière dedans
    3) S’assurer dans les options du plugin que le CSS ID est bien celui qui est utilisé dans le thème pour afficher l’image de l’entête.

    Est-ce plus clair ?

    Cordialement

    #614277
    go 2 ride
    Membre
    Initié WordPress
    42 contributions

    c’est l’etape 32 qui bloque !! 🙂 C’est quoi le CSS ID déjà ? Je dois mettre le meme ID que dans le CSS du theme ?

    La partie de mon css de theme est comme ceci :

    #header {
    background: #333333 url(images/header.jpg);
    width: 861px;
    height: 180px;
    margin: 0px auto 0px;
    padding: 0px 0px 0px 0px;
    text-align: center;
    text-transform: uppercase;
    }

    Et dans le header-image-rotator.php, j’ai ça que je suppose à avoir à remplir mais ??? Je sais pas quoi lol

    /* Check to see if options already exist in the database */
    $swap_rate = get_option(‘swap_rate’);
    $header_id = get_option(‘header_id’);

    /* Add options if they does not already exist */
    if($swap_rate ==  ») {
    add_option(‘swap_rate’, ‘1’);
    }
    if($header_id ==  ») {
    add_option(‘header_id’, ‘header’);
    }

    #614278
    dlo
    Participant
    Maître WordPress
    1849 contributions

    Il ne faut pas modifier le code du plugin ! Donc, surtout ne rien changer dans le fichier header-image-rotator.php.

    Par contre, une fois que le plugin est installé et activé, il faut vérifier dans ses options (via le panneau d’administration de WordPress) que la valeur de l’identifiant stocké dans la zone « CSS header ID tag » est bien la même que celle utilisée dans ton thème pour l’affichage de la bannière d’entête.

    Dans ton cas, cet identifiant (CSS ID) est « header », d’après les infos que tu donnes. Donc il faut mettre « header » comme valeur de la zone « CSS header ID tag ».

    C’est mieux comme cela ? 😗

    #614279
    go 2 ride
    Membre
    Initié WordPress
    42 contributions

    Oui et bien ça c’etait déjà fait dans la partie options du plugins !! mais ça ne fonctionne pas ! C’est pour ça que je cherchais du coté du code !! L’ancienne image reste en place !
    Et non les dexu nouvelles de tests que j’ai mis dans le bon rep !!

    #614280
    dlo
    Participant
    Maître WordPress
    1849 contributions

    En regardant le source de ta page, on peut voir que le plugin marche bien puisqu’il rajoute la définition du style pour #header avec une url vers une des images du répertoire header-images. Donc, ce n’est plus qu’un problème d’affichage et de prise en compte des clauses de la CCS.

    Je ferais un essai en supprimant la définition de #header dans la CSS de ton thème. Il y a peut-être un conflit.

    Cordialement

    #614281
    go 2 ride
    Membre
    Initié WordPress
    42 contributions
    dlo wrote:
    En regardant le source de ta page, on peut voir que le plugin marche bien puisqu’il rajoute la définition du style pour #header avec une url vers une des images du répertoire header-images. Donc, ce n’est plus qu’un problème d’affichage et de prise en compte des clauses de la CCS.

    Je ferais un essai en supprimant la définition de #header dans la CSS de ton thème. Il y a peut-être un conflit.

    Cordialement

    OK merci

15 sujets de 1 à 15 (sur un total de 15)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.