Balise more marche pas (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • #486412
    kayorn
    Participant
    Chevalier WordPress
    439 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.0.1 fr
    – Version de PHP/MySQL :
    – Thème utilisé : Twenty Ten 1.1
    – Extensions en place : All in One Video Pack – Downloads Manager – jQuery Lightbox…
    – Nom de l’hebergeur : ovh
    – Adresse du site : http://web2aconcept.fr/

    Problème(s) rencontré(s) :

    J’insère la balise au milieu de l’article (page) en mode visuel

    electronic typesetting, remaining essentially unchanged.
    
    <!--more-->
    
    [caption id=”” align=”alignleft”…….

    et à aucun moment, je vois de changement dans la visu (pas la prévi) je teste sur un autre navigateur en mode abonné.
    C’est pas comme ça?

    merci pour vos réponses

    #740082
    Environnement-France
    Participant
    Maître WordPress
    1115 contributions

    en mode visuel faut appuyer sur le bouton more.
    En mode code, tu peux ajouter

    #740083
    kayorn
    Participant
    Chevalier WordPress
    439 contributions

    je fais ainsi mais je ne vois nulle part un lien menant vers la suite (d’ailleurs l’article n’est absolument pas cindé en 2) je dois être le vrai boulet, j’ai tout essayé à partir des recherches sur le sujet…

    tu n’as qu’à vérifier, la balise est située juste au dessis de la photo : l’article

    #740084
    Environnement-France
    Participant
    Maître WordPress
    1115 contributions

    Dans le fichier index de ton thème, tu as quelque chose comme :

    et dans réglages/ lecture tu as mis “Pour chaque article, fournir Le texte complet”

    #740085
    kayorn
    Participant
    Chevalier WordPress
    439 contributions

    je dois être une quiche.

    dans l’index du thème il n’y a pas ce bout de script php.

    j’ai essayé de le rajouter mais oualou,

    #740086
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    Dans loop.php, tu as php_the_excerpt, à remplacer par le bout de code donné par Environnement-France.

    #740087
    kayorn
    Participant
    Chevalier WordPress
    439 contributions

    j’ai rajouté ce bout de code dans le loop.php du theme Twenty Ten 1.1
    ajouté la balise more en visu
    testé en visu deconnectée de l’admin

    resultat : peau de balles et variétés

    #740088
    Environnement-France
    Participant
    Maître WordPress
    1115 contributions

    C’est vrai que j’oublie qu’avec wordpress 3, la boucle est séparée…

    Donne-nous le code du fichier loop.

    #740089
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    Kayorn, je comprends pas ton problème…

    Tu donnes un lien vers un article en t’étonnant de ne pas y voir la balise more, mais il me semble que la balise more n’est pas sensé apparaitre dans un article seul mais plutôt sur l’index ou dans les pages catégories par exemple. Donc mets ton article en page d’accueil ou va sur la page de catégorie de ton article et tu verras la balise more (avec le theme twenty ten, car avec “mystique” en page catégorie tu affiches le excerpt il me semble)

    Je précise que dans l’article que tu donnes en exemple, si tu regardes ton code source tu verras qui est l’ancre de ta balise more, preuve que ta balise est bie intégrée Autrement dit quand tu cliqueras sur “lire la suite” tu arriveras sur la page http://www.test.web2aconcept.fr/?p=35#more-35

    A mon avis aucun problème donc, c’est juste que tu regardes pas au bon endroit.

    tiens moi au courant

    #740090
    kayorn
    Participant
    Chevalier WordPress
    439 contributions

    j’ai fait l’essai sur la page d’accueil également à cet endroit

    adnexam Isauriae se contulerunt ibique densis intersaepientes itinera praetenturis provincialium et viatorum opibus pascebantur.<!--more-->

    voici le code pour le loop de twenty ten car dans le thme actuel, Elements of SEO 1.2, je ne le trouve pas…

    </div><!-- .entry-summary -->
    	
    			<div class="entry-content">
    				<?php the_content( __( 'Continue reading <span class="meta-nav">→</span>‘, ‘twentyten’ ) ); ?>
    				 ‘<div class="page-link">‘ . __( ‘Pages:’, ‘twentyten’ ), ‘after’ => ‘</div>‘ ) ); ?>
    			</div><!-- .entry-content -->
    	

    #740091
    Gueblo
    Participant
    Maître WordPress
    1058 contributions

    je ne sais pas où est l’erreur cette fois (pas sûr que ce soit le même problème, puisque theoriquement il n’y a pas de problème), mais mets cet article en homepage : http://www.test.web2aconcept.fr/?p=35 (ne touche pas au contenu de cet article)

    #740092
    kayorn
    Participant
    Chevalier WordPress
    439 contributions

    effectivement, en plaçant un article en home, on a le lien qui s’affiche. bien vu.
    c’est logique en fait, pourquoi un lien à suivre si l’on est déjà sur l’article.

    par contre, si je veux faire une page statique et que je préfère avoir des “pages suivantes” plutôt qu’un scroll géant, pour la page d’accueil, je fais comment?

    puisque j’ai un spécialiste “sous la main” j’ai posté sans succès concernant l’automatisation du dump de la bdd avec le plugin database. par mail ça fonctionne bien mais j’ignore s’il est possible de créer une tâche journalière style webcron, avec sauvegarde sur le serveur.

    merci pour ta réponse

    #740093
    Gueblo
    Participant
    Maître WordPress
    1058 contributions
    kayorn wrote:
    effectivement, en plaçant un article en home, on a le lien qui s’affiche. bien vu.
    c’est logique en fait, pourquoi un lien à suivre si l’on est déjà sur l’article.

    De rien.

    kayorn wrote:
    par contre, si je veux faire une page statique et que je préfère avoir des “pages suivantes” plutôt qu’un scroll géant, pour la page d’accueil, je fais comment?

    Bah tu fais une recherche sur le forum par-exemple. Pour ma part j’ai trouvé la réponse en 15 secondes.

    kayorn wrote:
    puisque j’ai un spécialiste “sous la main” j’ai posté sans succès concernant l’automatisation du dump de la bdd avec le plugin database. par mail ça fonctionne bien mais j’ignore s’il est possible de créer une tâche journalière style webcron, avec sauvegarde sur le serveur.

    Demande au créateur du plugin.

    #740094
    kayorn
    Participant
    Chevalier WordPress
    439 contributions

    Merci pour tous ces renseignements.

    #740095
    icerunner
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    Je pense que le problème vient du thème twenty ten et qu’il faut modifier un bout de code pour faire fonctionner la balise “more”.

    Cependant, dans mon cas, je post des articles en pages d’accueil en souhaitant ne montrer que quelques lignes + une image liée à l’article. J’essaie alors d’intégrer la balise more depuis l’éditeur mais rien ne fonctionne. L’article apparaît dans son intégralité.

    J’ai essayé de modifier le code dans le loop et remplacer par mais sans succès.

    J’ai bien vérifié dans les options de lecture qu’il était bien spécifié que c’est l’article entier qui doit s’afficher et pas l’excerpt.
    J’avais alors pensé ne me contenter que de l’excerpt mais celui-ci n’affiche pas les images sur la homepage.

    Comment faire pour que la balise more fonctionne?
    Quelqu’un a-t-il une solution?

    Merci

15 sujets de 1 à 15 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.