Authentification hook (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #2351940
    virtazp
    Participant
    Padawan WordPress
    83 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : La dernière
    • Thème utilisé : Custom
    • Extensions en place : Single Sign-on with Azure Active Directory
    • Nom de l’hébergeur :
    • Adresse du site :

    Problème(s) rencontré(s) :

    Salut à tous,

    J’utilise un plugin pour me connecter en SSO à mon site WordPress.
    Auparavant, j’utilisait comme url de redirection l’adresse de mon site. Aujourd’hui cela ne fonctionne plus 🙁
    Je suis obligé d’utiliser l’url de redirection suivante : https://monsite/wp-login.php pour que cela fonctionne.

    Du coup au lieu de me rediriger sur la page d’accueil je suis rediriger dans le BO du site.

    Du coup j’ai fait un test :
    – J’ai utilisé la fonction is_user_logged_in() sur le template de ma page d’accueil. Si il est co, un message, si il est pas co un autre message.
    Et bien, si je me co en sso, et que je redirige sur la page d’accueil, il est considéré comme pas connecté.

    J’en déduis que is_user_logged_in() est appelé trop tôt ou que la connexion se fait trop tard.

    Ca c’est juste pour tester !!!!!

    Du coup qu’est-ce qui a changé ? Avant cela fonctionnait très bien

    Merci d’avance et bonne journée.

Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.