Au secours j’ai tout perdu

  • WordPress :5.2
  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2259401
    marc_m
    Participant
    Initié WordPress
    35 contributions

    Bonjour,

    Ma configuration WP actuelle 5.1.1

    • Version de PHP/MySQL :
    • Thème utilisé :
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site : lenjeu.eu

    Problème(s) rencontré(s) : J’ai voulu modifier mes préefixes de base de données dans mysql et modifier mon mot de passe et la base de données. Ensuite j’ai relancé wordpress qui ne trouvant plus  le bon mot de passe dans wp_config. Je l’ai remodifié dans ce fichier. Puis j’ai relancé wordpress. Ca marche, il rentre dans mon site : TOUT VIERGE.  J’ai perdu toutes mes pages. tout le site. Y a t il un moyen de le restaurer.
    Merci pour votre aide
    Marc

    #2259433
    marc_m
    Participant
    Initié WordPress
    35 contributions

    Bon comme il le promet dans l’excellent tuto

    https://creer-un-iste.com/recuperer-sauvegarde-wordpress-ovh/

    J’ai retrouvé le sourire.
    Donc j’ai tout récupéré

     

     

     

    #2259435
    Cyssoo
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Modifier le préfixe des tables ne suffit pas, il vous faut également modifier des entrées dans la table.

    Saisissez cette requête SQL dans PhpMyAdmin :

    SELECT *
    FROM `mysite_usermeta`
    WHERE `meta_key` LIKE 'wp_%';
     
    SELECT *
    FROM `mysite_options`
    WHERE `option_name` LIKE 'wp_%'
    get prefix on meta and options

    Dans les deux requêtes ci-dessus, modifiez “mysite_” par le préfixe actuel (et donc modifié) de vos tables, et modifiez “wp_” par votre ancien préfixe.

    Vous verrez ainsi des éléments qui ont le préfixe directement renseigné dans des colonnes, vous pourrez modifier cela manuellement.

    Si vous désirez mettre à jour d’un coup (sauvegarde de la base de données fortement conseillées, comme d’habitude), les requêtes SQL sont celles-ci :

    UPDATE mysite_usermeta
    SET meta_key = REPLACE(meta_key, 'wp_', 'mysite_') WHERE INSTR(meta_key, 'wp_') > 0;
     
    UPDATE mysite_options
    SET option_name = REPLACE(option_name, 'wp_', 'mysite_') WHERE INSTR(option_name, 'wp_') > 0;
    update meta and options prefix

    Modifiez comme indiqué précédemment les préfixes “mysite_” et “wp_”.

    Vérifiez par la suite dans le wp-config.php le préfixe et le mot de passe, mais comme votre site est semble-t-il visible en ligne, cela a certainement été déjà fait.

    #2259442
    marc_m
    Participant
    Initié WordPress
    35 contributions

    Bon, je ne comprends pas tout, mais j’ai restauré également ma base que j’avais suavegardé. Du coup elle reprend le préfixe d’origine.
    J’ai donc remodifié le préfixe du config et tout fonctionne.
    Mais le probème  que j’avais à l’origine persite
    Je m’explique :
    J’ai chez OVH un herbergement “perso” avec une base de données et 100 go
    J’ai donc installé en un clic wordpress dans le répertoire www qui est sous la racine.
    Donc, comme je viens de le préciser tout refonctionne.

    En revanche, j’ai un ancien site développé il y a 10 ans de dreamweaver que je voulais relooker
    Je l’ai hébergé dans un répertoire sous la racine, donc au même niveau que www.
    J’ai donc
    racine
    => ./www
    => ./monsite2.eu

    Dans OVH my sql, j’ai dupliqué mes 17 tables et j’ai rajouté un nouveau préfixe ddmm_ devant chacune.
    J’ai copié dans le repertoire les fichiers wordpress 5.1.1 et j’ai modifié le config en lui indiquant la même base de données, le mot de passe et le nouveau prefixe.
    Maintenant comment installer l’interface wordpress pour gérer cet autre site ?
    J’ai essayé de lancer http://monsite2.eu/wp-login.php et il me demande le login et mot de passe.
    Il n ‘a l’air d’accepter que celui de l’enjeu.

    J’ai dans OVH un multi site où apparait mon Site 2. Si je lui mets l’ancien index.php, j’y accède
    En revanche si je créé un nouveau module “en un clic”, j’ai peur de tout reperdre à nouveau par rapport à tout ce que j’ai copier dans le répertoire concernant wordpress.
    Suis-je clair ?

    merci pour votre aide
    Marc

     

     

    #2259448
    Cyssoo
    Participant
    Initié WordPress
    13 contributions

    Bonjour à nouveau,

    Je ne suis pas modérateur (loin s’en faut), mais je pense que vous devriez éditer le titre de votre demande sur le forum pour préciser un peu plus en détail votre besoin/souci. Par exemple, remplacer “Au secours j’ai tout perdu” par “Mise en place de deux sites WordPress sur un multisite OVH” fait un peu moins “crier au loup” 🙂 et vous auriez peut-être davantage de réponses selon votre problématique.

    En cas de besoin, OVH dispose d’une documentation concernant le multisite à cet endroit :

    https://docs.ovh.com/fr/hosting/multisites-configurer-un-multisite-sur-mon-hebergement-web/

    N’hésitez pas non plus à ouvrir un ticket de support depuis votre manager, ils devraient vous répondre dans les deux-trois jours. Le multisite est mine de rien quelque chose d’un peu particulier.

     

    #2259449
    marc_m
    Participant
    Initié WordPress
    35 contributions

    Ok Merci je vais arrêter ici ce post et enn rouvir un comme vous me le conseillez.
    J’ai déjà ouvert un ticket ovh, mais sans réponse …
    Bonne journée

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.