Article de blog et catégories

  • WordPress :4.9.9
  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2222654
    Lou
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Nous avons un site web vitrine avec un thème personnalisé. Je souhaite créer un blog attaché au site. Pour cela, j’ai créé un article et une catégorie blog. J’ai rattaché mon article à ma catégorie et enfin ajouté la catégorie dans le menu. Pourtant, mon article n’apparaît pas.  Pas même en prévisualisation lors de la création… Cela ne vient pas de mon article, car j’ai tenté d’attacher l’article d’exemple Helloworld à la catégorie blog cela ne fonctionne pas non plus. Avez-vous une idée de ce que j’ai oublié de faire ?

    Merci beaucoup d’avance ! Bonne journée à tous.

    Ma configuration WP actuelle :

    • Thème utilisé : Personnalisé
    • Nom de l’hébergeur : OVH
    • Adresse du site : lateliertropezien.fr
    #2222670
    PhiLyon
    Modérateur
    Maître WordPress
    20964 contributions

    Bonjour.

    As-tu essayé de créer une page « Blog » et de la choisir comme page des articles dans Réglages/Lecture ?

    🙂

    #2222702
    Lou
    Participant
    Initié WordPress
    3 contributions

    Merci c’est une super idée. Je ne connaissais pas cette fonction. Mais cela ne fonctionne toujours pas, j’ai une page blanche qui s’affiche dès que les articles sont reliés. J’ai effacé mon article et créé un nouveau avec juste un titre… Toujours une page blanche.

    #2222787
    Noaneo
    Participant
    Maître WordPress
    29198 contributions

    Bonjour,
    Ne pas créer de catégorie Blog, choisir un autre nom.
    Comme vous l’a expliqué PhiLyon, il faut créer une page vide, juste nommé Blog et la publier, c’est cette page qui sera en lien dans votre menu.
    Puis dans Réglages et après Lecture, à la ligne « Page des articles » choisir la page Blog
    https://bloginfos.com/page-articles-de-blog/

    N’oubliez pas d’avoir la page obligatoire « Mentions Légales ».

    De garder votre site à jour, par exemple Yoast SEO plugin v4.6, plugin pas à jour, dernière version 9.1.
    https://fr.wordpress.org/plugins/wordpress-seo/

    Attention aux plugins
    https://wordpress.org/plugins/font-awesome/

    « This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress. »

    Vous dites thème personnalisé, cela veut dire que vous avez créé un thème enfant ?
    Ou est-ce un thème créé par vous même ou une agence ?

    Merci

     

    #2222964
    Lou
    Participant
    Initié WordPress
    3 contributions

    Noaneo ,

    Merci beaucoup pour votre réponse complète. J’ai supprimé la catégorie, crée une page blog, relié les articles à cette page et la page au menu… Toujours une page blanche les articles n’apparaissent pas. Il s’agit d’un thème crée par une agence.

    Bonne journée !

    #2222970
    Noaneo
    Participant
    Maître WordPress
    29198 contributions

    Bonjour @lou ,
    J’ai juste essayé de compléter la solution de PhiLyon, il faut rendre à César ce qui est à César.

    Vous dites avoir supprimé la catégorie Blog,  mais WordPress a toujours une catégorie par défaut nommé « Non Classé » c’est bien celle là que vous avez renommé ? Les articles sont liés à une catégorie, il faut une catégorie, j’ai dit de choisir un autre nom et non de supprimer, il me semble.

    Vous dites « crée une page blog, relié les articles à cette page et la page au menu…  »
    Relié des articles à une page ??  Vous avez bien été dans Réglages puis Lecture ?

    Bizarre le code source, au niveau du menu, comparer à Contact

    <li id="menu-item-72" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72"><a href="http://lateliertropezien.fr/contact/">Contact</a></li>
    <li id="menu-item-1597" class="menu-item menu-item-type-post_type menu-item-object-page current-menu-item page_item page-item-1586 current_page_item current_page_parent menu-item-1597"><a href="http://lateliertropezien.fr/blog/">Blog</a></li>

    Vous n’avez rien fait pour les plugins
    Yoast SEO plugin v4.6
    MonsterInsights plugin v 6.1.7 , etc.

    #2223018
    PhiLyon
    Modérateur
    Maître WordPress
    20964 contributions

    Bonjour.

    Il manque peut-être un hook dans le thème créé par le prestataire.

    🙂

    #2223046
    Noaneo
    Participant
    Maître WordPress
    29198 contributions

    Peut-être, il faut peut être activer un des thèmes par défaut de WordPress, pour voir si cela fonctionne.

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.