Après installation, le contenu de mon blogue ne s’affiche pas

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 32)
  • Auteur
    Messages
  • #459789
    kimauclair
    Membre
    Initié WordPress
    37 contributions

    Bonjour,

    Je viens de migrer de dotclear à wordpress.

    La version actuelle de mon blogue est http://www.kimauclair.ca/blog avec dotclear

    La version dont je souhaites publiée mais qui est actuellement en construction est http://kimauclair.ca/wordpress/
    et c’est au sujet de cette version que je vous écris car aucun contenu s’affiche présentement …. alors qu’il y a des billets de publicé.

    Ma configuration WP actuelle
    – Version de WordPress : 2.5.1
    – Thème utilisé :Business Blue 2.0 par Ganar dinero
    – Plugins en place : Akismet 2.1.4 All in One SEO Pack 1.4.6.8 Out-of-the-box SEO
    Blogroll Page 1.0 del.icio.us widget 1.0 Google Search widget 1.0 Hello Dolly 1.5 Sidebar Widgets
    – Nom de l’hebergeur : http://www.ibsolution.net
    – Adresse du site : http://kimauclair.ca/wordpress/

    Problème(s) rencontré(s) :

    – J’aimerais comprendre pourquoi le contenu de mon blogue ne s’affiche pas.
    – J’aimerais savoir s’il a possibilité de traduire ce thème autrement ou il faut passer le code en entier nous même.
    – J’aimerais obtenir également de vos conseils pour améliorer mon blogue avec les pluggins que vous conseiller très importants.

    Merci à l’avance de votre aide et à très bientôt

    #631113
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    1/ Apparemment, tu as résolu le 1er problème, ça s’affiche
    2/ Deux possibilités concernant la traduction de ton thème :
    – soit il est accompagné d’un fichier de langue (fr_FR.po) : dans ce cas, c’est ce fichier qu’il faut traduire avec un utilitaire nommé POEDIT
    – soit les textes sont codés « en dur » dans le thème, dans ce cas, il faut aller modifier « en dur » dans les fichiers.
    3/ Il y a sur internet plein de discussions du genre « les XX extensions indispensables pour WP ». Même si c’est assez subjectif, on trouve tout de même quelques classiques plus ou moins indispensables :
    — Pour la sauvegarde !
    — Pour le référencement
    etc.
    J’ai lancé une discussion sur ce sujet ici.

    #631114
    kimauclair
    Membre
    Initié WordPress
    37 contributions

    Bonjour Comme une image

    – Le problème est toujours présent sur safari : http://kimauclair.ca/wordpress/

    Je regarde pour la traduction et le lien pour les conseils. Merci

    #631115
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Au niveau validation XHTML, je n’ai pas vu grand chose comme erreur.
    Une balise non fermée :
    Ziki - Be Visible
    mais je doute que Safari soit si chatouilleux.

    #631116
    kimauclair
    Membre
    Initié WordPress
    37 contributions

    Je trouve encore étrange que mon contenu n’affiche pas sur certain navigateur.

    Est-ce que ça marche bien partout ? Est-ce que vous voyez bien les textes à gauche ?

    #631117
    kimauclair
    Membre
    Initié WordPress
    37 contributions
    #631118
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Call to undefined function related_posts() in …
    Ça, c’est le message typique dû à l’extension désactivée.

    Ça me rappelle un article qui parlait de ce problème[en]. Et, coïncidence étonnante, l’exemple qu’il donne, c’est aussi avec related_post :D

    #631119
    kimauclair
    Membre
    Initié WordPress
    37 contributions

    Je ne parles pas anglais. Est-ce possible de me donner une piste.

    Je viens de voir mes extensions… je ne suis pas sure de comprendre, elles sont activées.

    #631120
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Ah, je pensais qu’au Canada, tu parlais forcément anglais. Tu as des outils sur le net de traduction automatique. C’est très médiocre, mais ça peut t’aider à cerner le sens général.

    Tu as l’extension « Related Posts » installée sur ton WP ? (parce que le code correspond à cette extension)

    #631121
    kimauclair
    Membre
    Initié WordPress
    37 contributions

    Je ne vois pas Related Post dans mes pluggins.
    Même sur mon ftp.

    Voici une copie d’écran 1211731608_Image-2.png

    #631122
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Même si tu ne parles pas anglais, tu pourrais faire l’effort de regarder le lien que je t’ai passé, quitte à le traduire automatiquement comme je te le suggère. Même en japonais, on doit pouvoir comprendre ça :

    The plugin author gives you the following code to use:

    As you can see, there is no if/then involved, so it will cause problems if you deactivate the plugin. Here is how the code needs to look to avoid breaking your blog:

    #631123
    kimauclair
    Membre
    Initié WordPress
    37 contributions

    Salut

    Je viens de lire. Je ne comprends juste pas dans quelle page le placer le code.

    Je suis désolée de tout ce dérangement…

    #631124
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    C’est marqué dans ton erreur.

    Fatal error: Call to undefined function related_posts() in /var/www/vhosts/kimauclair.ca/httpdocs/wordpress/wp-content/themes/business-blue-20/single.php on line 22

    Mais tu peux vérifier dans tous les autres fichiers de ton thème.

    #631125
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Salut Kim,

    Dis, tu l’as ce plugin ou non ? Est-ce que par hasard ce ne serait pas que tu as le code dans le thème sans avoir le plugin activé et qui bloque l’affichage du contenu ??

    Sinon, comme le dit jérôme (Comme une image), va voir dans le fichier single.php et changes le code… Mais franchement, j’aurais plutôt tendance à le virer, mais bon… j’ai ptêt pas tout bien lu !! 😋

    #631126
    kimauclair
    Membre
    Initié WordPress
    37 contributions

    Salut

    Comme je le disais plus haut , je n’ai pas de ce pluggin dans mon repetoire ftp.

    Dans la page single.php j’ai ceci :

    
      <div id="container" class="clearfix">
       <div id="leftnav">
    	  
        </div>
        <div id="rightnav">
    	  
    </div>
        <div id="content">
    				
    
      
    	
    			<div class="post" id="post-“>
    			<h3 class="posttitle"><a href="” rel=”bookmark” title=”Lien permanent: “></a></h3>
    	
    			<div class="entry">
    				<?php the_content('<p class="serif">Read the rest of this entry »</p>‘); ?>
    	
    				<?php link_pages('<p><strong>Pages:</strong> ‘, ‘</p>‘, ‘number’); ?>
    </div>
    <h4>Articulos relacionados</h4>
    <ul></ul>
    </div>
    				<p class="postmetadata2">
    					<small>
    						This entry was posted
    						
    						on  at 
    						and is filed under .
    						You can follow any responses to this entry through the  feed. 
    						
    						 comment_status) && (‘open’ == $post->ping_status)) {
    							// Both Comments and Pings are open ?>
    							You can <a href="#respond">leave a response</a>, or <a href="” rel=”trackback”>trackback</a> from your own site.
    						
    						 comment_status) && (‘open’ == $post->ping_status)) {
    							// Only Pings are Open ?>
    							Responses are currently closed, but you can <a href=" ” rel=”trackback”>trackback</a> from your own site.
    						
    						 comment_status) && !(‘open’ == $post->ping_status)) {
    							// Comments are open, Pings are not ?>
    							You can skip to the end and leave a response. Pinging is currently not allowed.
    			
    						 comment_status) && !(‘open’ == $post->ping_status)) {
    							// Neither Comments, nor Pings are open ?>
    							Both comments and pings are currently closed.			
    						
    						
    						
    					</small>
    				</p>
    			<div class="navigation">
    			<div class="alignleft"></div>
    			<div class="alignright"></div>
    		</div>
    	<div class="post">
    		
    	
    	
    	
    	
    		<p>	Désolé, il n’y a pas de billets qui correspondent à vos critères.</p>
    	
    
    	
        </div>
    	
        </div>
    
    	
      </div>

    Je vois une ligne en rapport :

      …. Faudrait-il que je regarde ailleurs aussi ?

      Je m’excuse de tout ces retours… je ne suis pas une adepte dans tout ça. J’apprends !

    15 sujets de 1 à 15 (sur un total de 32)
    • Vous devez être connecté pour répondre à ce sujet.