[Résolu] Apparence-Personaliser: Non-existent changeset UUID ! (Créer un compte)

  • WordPress :4.9
  • Statut : résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2034630
    Joe76000
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Ma configuration WP 4.9.1 actuelle :

    • Version de PHP/MySQL : PHP 5.6.30, MySQL 5.5.55-0+deb7u1-log – Linux
    • Thème utilisé : Smartline Lite 1.4.4 de ThemeZee
    • Extensions en place : une petite douzaine: dont iThemes Security 6.7.0 – WP Super Cache 1.5.9 – WP-Optimize – Responsive Lightbox – NextGEN Gallery – TablePress – The Events Calendar – TinyMCE Advanced
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://www.linuxrouen.fr/wp/

    Problème(s) rencontré(s) :

    J’ai décrit mon problème et mes investigations en détail sur le site Support de WP en anglais mais personne ne se bouscule au portillon: Non-existent changeset UUID / Theme Not Accessible anymore!.
    Il ne m’est plus possible d’accéder à la page de personnalisation de mon thème depuis le tableau de bord par Apparence – Personnaliser (customize.php).
    Ce problème est apparu pour moi avec-vers la mise à jour de WP 4.9.1. L’erreur renvoyée par WP très furtivement et par 2 fois est “Non-existent changeset UUID !”. Puis, une petite fenêtre affiche “Votre session a expiré. Veuillez vous reconnecter pour reprendre à la dernière page visitée.” avec les 2 champs d’identification. Mais que nenni, en les remplissant, rebelote “Non-existent changeset UUID !” s’affiche à nouveau. C’est la boucle infernale.
    Je reviens en arrière au tableau de bord, en étant toujours bien connecté, soit en cliquant sur le X de la fenêtre de personnalisation soit la flèche Reculer d’une page de mon butineur Firefox.

    Toutes les recherches sur Internet et les 2 sites Support WP (EN + FR) n’ont rien donné de concret.

    Merci pour votre aide. Librement,

    #2035090
    bkantique
    Participant
    Chevalier WordPress
    352 contributions

    Bonjour

    juste une réflexion  à défaut de solution

    – je vois que le thème que tu emploies à été MAJ la dernière fois en février 2017 es-tu certain qu’il soit compatible avec ta version de WP? Que se passe-t-il si tu change de thème pour revenir sur l’un des thèmes par défaut installé avec WP?

    Cdlt

     

    #2035195
    Joe76000
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Merci pour cette suggestion que je vais tester avec Twenty Fifteen.

    Pour l’instant mes recherches étaient plutôt concentrées du côté des plugins iThemes Security et WP Super Cache.

    Librement,

    #2035208
    Joss47
    Modérateur
    Maître WordPress
    4725 contributions

    Bonjour,

    Tant qu’on y est passe ta version de PHP en 7 chez ovh

    Egalement après test avec un autre theme, désactive tout tes plugins et vois si tu accèdes au customizer 😉

    #2035210
    PhiLyon
    Modérateur
    Maître WordPress
    25680 contributions

    Bonjour.

    Vérifies dans Réglages/Général que tes deux url soient identiques.

    🙂

    #2035311
    Joe76000
    Participant
    Initié WordPress
    11 contributions

    @ PhiLyon
    Merci, mais c’est le cas depuis plus d’un an quand j’ai passé mon site de HTTP en HTTPS.
    – My Web site: https://www.linuxrouen.fr/wp/
    – WordPress web address (URL): https://www.linuxrouen.fr/wp/

    @Joss47
    Merci, je vais essayer de passer mon site de PHP 5.6.30 à 7.x, mais en vérifiant d’abord que WP 4.9.1 et tous mes plugins supportent bien PHP 7.x. Et si oui, quelle version ?
    Pour la désactivation de tous mes plugins, je l’avais déjà testée avec succès et les 2 “fautifs” étaient  le couple iThemes Security 6.7.0 / WP Super Cache 1.5.9. Après une analyse plus fine, en désactivant que WP Super Cache 1.5.9, j’avais de nouveau bien accès au Cutomizer, même après déconnexion et reconnexion à mon site. Mais c’était une rustine pas pratique du tout car après réactivation de WPSC, il fallait faire les remises en cache, ce qui prend un temps plus que certain à chaque fois, et mon site sans WPSC est aussi rapide qu’une tortue !
    J’ai aussi posté il y a près de 2 semaines sur le Forum WP – WP Super Cache mon problème avec une analyse détaillée, en anglais, mais à ce jour silence radio. Voir le lien dans mon 1er message.

    @bkantique
    Merci, c’est pourquoi je n’avais pas investigué la piste de tester le changement du thème, mais qui est risqué si l’on valide sa publication. Quid d’un retour en arrière au thème Smartline Lite, retrouve-t-on automatiquement tous ses réglages et paramétrages pour ce thème ?

    Librement,

    #2035319
    bkantique
    Participant
    Chevalier WordPress
    352 contributions

    Bonne remarque joe76000 je pense que tous les paramétrages sont gardés mais il faudrait te le faire confirmer par un pro WordPress.

    si tu as un site de dev tu pourrais essayer comme cela pas de risque

    cdlt

    #2035330
    Joss47
    Modérateur
    Maître WordPress
    4725 contributions

    Prends la version 7 ou 7.1, dans le pire des cas ça plante mais tu peux en un clic revenir à la version précédente de PHP 😉
    Aussi, as-tu essayé un autre plugin de cache que WP Super Cache ? Cela résoudrait peut être ton soucis ?

    Je pense qu’il y a un réglages dans ton WP Super Cache qui fait planter ton customizer, à affiner également de ce côté la.
    Regarde : WP Super Cache > Advanced, désactiver “Make known users anonymous so they’re served supercached static files.”.

    #2037146
    Joe76000
    Participant
    Initié WordPress
    11 contributions

    @Joss47

    Alors là, chapeau bas Mon Sieur, ta dernière suggestion fût la bonne ! J’ai à nouveau accès au Customizer de mon WP.

    Je reconfirme TA solution:
    – Tableau de bord WP -> Réglages -> WP Super Cache -> Réglages WP Super Cache -> Ongle Avancé -> Divers -> DÉCOCHER la case devant “Make known users anonymous so they’re served supercached static files.” car SI COCHÉE elle est INCOMPATIBLE avec au moins WP 4.9.x.
    Et le message d’erreur “Non-existent changeset UUID” disparaît rendant bien la main au Customizer !

    Même Automattic, les développeurs principaux de WP Super Cache mais aussi de WordPress, n’ont pas été capables en 15 jours de pointer le doigt sur ce bogue de leur plugin ! Je vais leur dire dans mon message d’origine en anglais.

    Un grand merci à TOI, et aussi aux autres contributeurs.

    Librement,

    #2288224
    MARKS ONLY
    Participant
    Initié WordPress
    1 contributions

    bonjour a tous

    J’ai le même problème ( Non-existent changeset UUID )

    Mes clients m’appelle voici le message qui apparaît sur la page d’accueil de mon site

    Quelqu’un peut’il m’aider ?

    C’est noël je suis vraiment embarrassé

     

    Merci d’avance

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.