Ancres, ou liens n’apparaissent pas quand j’affiche la page (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #557324
    Fourmi Krohonde
    Participant
    Chevalier WordPress
    349 contributions

    Bonjour,

    Ma configuration WP actuelle :

    – Version de WordPress : 4.3.1
    – Version de PHP/MySQL : 5.3.8 / 5.1.66-0+squeeze1
    – Thème utilisé : Himalayas
    – Thème URI : http://themegrill.com/themes/himalayas/
    – Extensions en place : Count Per Day (3.4.1), Divi Builder (1.1.1), Forum_wordpress_fr (3.9), Menu Items Visibility Control (0.3.1), Modal Portfolio (1.5), WassUp Real Time Analytics (1.8.7), Wordfence Security (6.0.22), WP Maintenance (2.6.8)
    – Adresse du site : http://witwag.alwaysdata.net/mensonges-science
    – Nom de l’hébergeur : Apache/2.2

    Bonjour
    J’ai placé des ancres (

    ……

    ) dans l’éditeur « texte »; c’est un sommaire pour aller vers des élément plus bas dans la page.
    Lorsque j’affiche la page, il ne se passe rien quand je clique sur les parties ou j’ai mis ces ancres.
    Savez vous pourquoi?

    Merci pour vos explications.

    #1031938
    Flobogo
    Modérateur
    Maître WordPress
    20205 contributions

    Bonjour 😉

    Parce que tes ancres sont mal construites. 😗

    Voir le tuto de Openclassrooms (ex-site du Zéro) –> https://openclassrooms.com/courses/apprenez-a-creer-votre-site-web-avec-html5-et-css3/creer-des-liens#/id/r-1604608
    (tiens, justement, c’est un lien vers une ancre :happy: )

    #1031939
    Fourmi Krohonde
    Participant
    Chevalier WordPress
    349 contributions
    Flobogo wrote:
    Bonjour 😉

    Parce que tes ancres sont mal construites. 😗

    Voir le tuto de Openclassrooms (ex-site du Zéro) –> https://openclassrooms.com/courses/apprenez-a-creer-votre-site-web-avec-html5-et-css3/creer-des-liens#/id/r-1604608
    (tiens, justement, c’est un lien vers une ancre :happy: )

    Comment ça mal construit?
    Voici mon ancre, la plus simple possible: 1 + Chapitre 1.
    Et voici le lien vers cette ancre:


    Le texte est bien visible sur le visuel de l’éditeur WordPress, mais n’apparait pas si j’affiche la page!

    Merci pour ton (votre) aide!

    #1031940
    Flobogo
    Modérateur
    Maître WordPress
    20205 contributions

    Ce que tu as mis en bleu ciel est correct. 🙂

    Mais ton message disait :

    ……

    –> soit il manque name= »xxx », soit il manque le #

    #1031941
    Fourmi Krohonde
    Participant
    Chevalier WordPress
    349 contributions

    Bonsoir Flo.

    Flobogo wrote:
    Ce que tu as mis en bleu ciel est correct. 🙂

    Mais ton message disait :

    ……

    –> soit il manque name= »xxx », soit il manque le #

    Maintenant mes liens s’affichent, changent de couleur quand on passe dessus, mais ils ne redirigent pas vers l’ancre en question.
    Quelle affaire ce Ouordprèce.

    #1031942
    Flobogo
    Modérateur
    Maître WordPress
    20205 contributions

    Tu peux donner le lien de ta page où il a une ancre qui ne « fonctionne pas » ?
    (puisque c’est sur le site en ligne, je pourrai aller voir ; tandis que sur ton install’ locale avec WAMP, je ne pourrais accéder à rien 😉 )

    #1031943
    Fourmi Krohonde
    Participant
    Chevalier WordPress
    349 contributions
    Flobogo wrote:
    Tu peux donner le lien de ta page où il a une ancre qui ne « fonctionne pas » ?
    (puisque c’est sur le site en ligne, je pourrai aller voir ; tandis que sur ton install’ locale avec WAMP, je ne pourrais accéder à rien 😉 )

    Le site en ligne, celui de mon frère donc, ne fonctionne plus du tout pour moi. Lorsque je veux afficher une page, je reçois un message « erreur web ».
    Non, là c’est méchant maintenant! Je suis bloqué de partout!

    #1031944
    ouistiti.net
    Participant
    Maître WordPress
    1879 contributions

    Si je peux me permettre, il faut mettre in id

    <a href="#chapitre_1″>Chapitre 1

    <h2 id="]chapitre_1>Chapitre 1

    #1031945
    ouistiti.net
    Participant
    Maître WordPress
    1879 contributions

    Edit:

    <a href="#chapitre_1« >Chapitre 1

    <h2 id="chapitre_1« >Chapitre 1

    #1031946
    Flobogo
    Modérateur
    Maître WordPress
    20205 contributions

    Aïe, qu’est-ce que tu as touché ?
    Cette adresse là fonctionne pourtant : http://witwag.alwaysdata.net/mensonges-science/
    Mais lorsqu’on clique sur l’image, on est dirigé sur http://mensonges/ … qui évidemment, n’existe pas !

    Je pense que tu as touché aux réglages d’URL.
    Va voir cette solution : http://www.wordpress-fr.net/faq/jai-malencontreusement-modifie-le-parametre-adresse-web-du-site-url-comment-rendre-le-site-de-nouveau-accessiblea/

    Les bonnes URL à rentrer, sur les 2 lignes, c’est l’adresse complète

    #1031947
    Fourmi Krohonde
    Participant
    Chevalier WordPress
    349 contributions
    Flobogo wrote:
    Aïe, qu’est-ce que tu as touché ?
    Cette adresse là fonctionne pourtant : http://witwag.alwaysdata.net/mensonges-science/
    Mais lorsqu’on clique sur l’image, on est dirigé sur http://mensonges/ … qui évidemment, n’existe pas !

    Je pense que tu as touché aux réglages d’URL.
    Va voir cette solution : http://www.wordpress-fr.net/faq/jai-malencontreusement-modifie-le-parametre-adresse-web-du-site-url-comment-rendre-le-site-de-nouveau-accessiblea/

    Les bonnes URL à rentrer, sur les 2 lignes, c’est l’adresse complète

    DOnc selon ton lien:

    Elle consiste à corriger les valeurs dans la base de données en s’y connectant à l’aide de PHPMyAdmin.
    Une fois connecté, allez dans la table wp-options puis modifier les valeurs des champs « siteurl » et « home » pour remettre les paramètres d’origine.

    DAns ces tables, j’ai « http://localhost » comme valeur.
    Faut que je modifie avec quoi?
    J’ai un peu peur de modifier des trucs là!

    #1031948
    Fourmi Krohonde
    Participant
    Chevalier WordPress
    349 contributions
    ouistiti.net wrote:
    Edit:

    <a href="#chapitre_1« >Chapitre 1

    <h2 id="chapitre_1« >Chapitre 1

    Merci, mais j’ai recopié ces lignes, cela ne change rien.
    Je pense qu’il s’agit d’un autre problème, puisque je n’arrive pas à importer certaines images, alors que d’autres oui. Et impossible d’installer un plugin Elegant thèmes, impossible d’importer une image dans l’Epanel délégant thèmes.

    #1031949
    Flobogo
    Modérateur
    Maître WordPress
    20205 contributions

    Donc selon ton lien:

    « Elle consiste à corriger les valeurs dans la base de données en s’y connectant à l’aide de PHPMyAdmin. (…)

    Utilise la 1ère méthode, plus simple et moins dangereuse, car elle ne touche pas à la base de données !
    –>

    Elle [la méthode] permet de forcer les valeurs existantes en modifiant votre fichier wp-config.php avec un éditeur de code comme NotePad++

    Ajouter les lignes suivantes avec les URL d’origine :

    define(‘WP_HOME’,’http://example.com&rsquo;);
    define(‘WP_SITEURL’,’http://example.com&rsquo;);

    Vous aurez ainsi de nouveau accès à votre site. Mettre ces valeurs dans le fichier wp-config.php interdit par la suite toute modification de ces valeurs à partir du tableau de bord.

    Forcément, sur le site en ligne hébergé par ton frère chez alwaysdata, il ne doit pas y avoir de localhost ! Il faut juste remettre l’adresse complète : http://witwag.alwaysdata.net/mensonges-science/

    A mettre comme indiqué ci-dessus dans le fichier wp-config.php que tu auras au préalable récupéré avec Filezilla (côté droit), puis ouvert avec Notepad++, puis tu modifies les 2 lignes,tu enregistres avec encodage en UTF8-sans-BOM (voir menu « Encodage » en haut de Notepad++) et enfin tu renvoies pas Filezilla.

    #1031950
    Fourmi Krohonde
    Participant
    Chevalier WordPress
    349 contributions
    Flobogo wrote:
    A mettre comme indiqué ci-dessus dans le fichier wp-config.php que tu auras au préalable récupéré avec Filezilla (côté droit), puis ouvert avec Notepad++, puis tu modifies les 2 lignes,tu enregistres avec encodage en UTF8-sans-BOM (voir menu « Encodage » en haut de Notepad++) et enfin tu renvoies pas Filezilla.

    Rebonjour Flo,
    moi je veux bien, mais je trouve où ce fichier WP-Config php. Introuvable dans FIlezilla et dans Wamp.

    #1031951
    Flobogo
    Modérateur
    Maître WordPress
    20205 contributions

    Bon, alors après cette interruption liée à la remise en ligne du site (et à la remise en route de WAMP en local), revenons au souci avec les ancres sur le site en ligne.

    Pour essayer de comprendre où est l’erreur, peux-nous donner l’adresse URL de la page où tu as mis ces ancres, et nous indiquer (pour gagner du temps) où elles se situent : sur quel mot, et où elles doivent renvoyer ?

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.