Ancre en flèche

  • WordPress :4.9.4
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #2141772
    Lino
    Participant
    Initié WordPress
    26 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : gtl multipurpose
    • Extensions en place :
    • Nom de l’hébergeur :
    • Adresse du site :

    Problème(s) rencontré(s) : hello à tous voila je m’explique sur mon thème gtl multipurpose j’aimerais ajouter une ancre en flèche comme pour ce thème là   https://fr.wordpress.org/themes/amadeus/

    Position comme pour le thème seulement sur l’image en header pas sur la page si vous avez des astuce ou plugin n’hésitez voilà voila merci les amie

    #2142890
    PhiLyon
    Modérateur
    Maître WordPress
    23948 contributions

    Bonjour.

    Tu veux parler de la flèche vers le bas pour descendre dans les sections ?

    🙂

    #2143071
    Lino
    Participant
    Initié WordPress
    26 contributions

    Oui voilà comme pour le thème que j’ai montrer  voilà savoir si il y a une ligne de code à noté ou plugin j’ai essayé de mettre un glyphicon sur ma page et faire position :absolute et le positionner mais le truc c’est que la flèche ce mais en dessous de l’image du thème gtl multipurpose et pas au dessus voilà

    #2143586
    PhiLyon
    Modérateur
    Maître WordPress
    23948 contributions

    Même si tu arrives à mettre cette flèche, elle ne fonctionnera qu’une fois, vers la première ancre, après il faudra utiliser le menu ou le scroll de la souris.

    🙂

    #2143608
    hocus35
    Participant
    Initié WordPress
    26 contributions

    Si tu as réussi a mettre la flèche, tu es proche du but ! Essaies de jouer avec le z-index en CSS

    #2143620
    Lino
    Participant
    Initié WordPress
    26 contributions

    D’accord je vais me renseigner sur le z-index c’est pour choisir lampilation mais je n’est jamais utiliser le z- index  j’essaie

    #2143628
    Lino
    Participant
    Initié WordPress
    26 contributions

    j’ai regarder mais sa ne fonctionne pas je pence qu’il faut que je mette un z-index sur limage etc pour pouvoir placer ma flèche au dessus mais le problème c’est que sa fait partit du theèe de base j’ai une idée faut t’il que je fasse inspecter et chercher la ligne de code pour ajouter au css ou il y a un autre moyen plus facile ou différent merci d’avance

    #2143636
    Lino
    Participant
    Initié WordPress
    26 contributions

    jai la reponce a ma question lol aussi tot dit aussi tot fait jai fait inspecter etc comme jai dit mtn plus qua le rendre cliquable etc  je revien vaire vous quand cest fini . merci de mavoir apris ce code css

     

    #2143664
    Lino
    Participant
    Initié WordPress
    26 contributions
    #2143755
    bkantique
    Participant
    Chevalier WordPress
    352 contributions

    hello

    voici le code que j’ai mis sur ma page d’accueil (avec une flèche vers le bas) qui permet donc d’aller à l’ancre que j’ai mise cela fonctionne plutôt bien mais comme te l’as dit Phylon cela ne marche qu’une seule fois

    Attention je travaille avec Elementor donc ce code CSS ne me sert qu’à faire rebondir l’icône (flèvhe vers le bas) qui pointe vers l’ancre que j’ai positionnée au préalable…

    Si cela peut t’aider quand même (.bounce = class)

    .bounce {
    position:absolute;
    left:0;
    bottom:0;
    margin-top:0;
    height:50px;
    width:100%;
    -webkit-animation:bounce 1s infinite;
    -moz-animation:bounce 1s infinite;
    -o-animation:bounce 1s infinite;
    animation:bounce 1s infinite;
    z-index: 10;
    }

    @-webkit-keyframes bounce {
    0% { bottom:0px; }
    50% { bottom:15px; }
    100% {bottom:30;}
    }

    @-moz-keyframes bounce {
    0% { bottom:0px; }
    50% { bottom:15px; }
    100% {bottom:30;}
    }

    @-o-keyframes bounce {
    0% { bottom:0px; }
    50% { bottom:15px; }
    100% {bottom:30;}
    }

    @keyframes bounce {
    0% { bottom:0px; }
    50% { bottom:15px; }
    100% {bottom:30;}
    }

    #2143761
    Lino
    Participant
    Initié WordPress
    26 contributions

    Merci de m’aider c’est gentil j’ai essayer et j’ai découvert elementor c’est pas mal petit bug je c’est pas vous aussi je crée ma pas

    Ge je mais accéder à elementor sa fonctionne je fait mais truc etc je quite  et après petite pause je reprends je retourne sur mage j’ouvre avec elementor et la problème a chaque fois en quittant et relançant la page fait que de charger mais ne s’affiche pas vous aussi ? J’ai essayer version précédant bug aussi je suis obliger de tout faire en une fois pour que ça ne bug pas 😢( avec elementor j’ai réussi pour la flèche merci beaucoup)

    #2143765
    bkantique
    Participant
    Chevalier WordPress
    352 contributions

    attention avec Elementor il ne faut pas oublier de sauvegarder les modifications en cliquant sur le bouton “mettre à jour” avant de quitter la page sinon tout ce qui a été ajouté ou modifié est perdu et on repart depuis le dernier moment ou il y a eut une sauvegarde.

    #2143766
    Lino
    Participant
    Initié WordPress
    26 contributions

    Oui j’ai sauvegarder mon modèle mais comme j’ai dit ce bug en voulant modifier une page chargement en continue de la page sur elementor du coup obliger de recrée une page pour fair mes modifications seul moyen pour contourner le bug si tu as une idée du beug n’hésite pas

     

    #2143767
    bkantique
    Participant
    Chevalier WordPress
    352 contributions

    Comme cela je ne vois pas faudrait que je vois si j’ai un bug aussi…

    quelle version d’elementor utilises-tu?

    #2143936
    Lino
    Participant
    Initié WordPress
    26 contributions

    Je n’est pas l’ordinateur sous les yeux c’est la 2.0.8 si je me trompe pas

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.