“alt” n’apparaissent pas

  • WordPress :5.2
  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #2262063
    Muchon
    Participant
    Initié WordPress
    9 contributions

    Bonjour,
    <div id=”fwf_content”>Ma configuration WP actuelle :

    • – Version de WordPress : 5.1.1
    • – Version de PHP/MySQL : 7.0.33 / 5.6.42
    • – Thème utilisé : Fashion Trends Child
    • – Thème URI : https://www.sktthemes.net/shop/fashion-wordpress-theme/
    • – Extensions en place : Advanced iFrame (7.6), All In One WP Security (4.3.9.2), Archive Control (1.3.3), Categories Images (2.5.4), Contact Form 7 (5.1.1), Contact Form 7 Conditional Fields (1.5.4), Cookie Notice (1.2.46), Custom Post Type UI (1.6.1), Duplicate Post (3.2.2), Facebook for WooCommerce (1.9.12), Forum_wordpress_fr (4.1), Image Hover Effects (4.7.8), Leaflet Map (2.14.0), Mailchimp for WooCommerce (2.1.15), Menu Icons (0.11.4), Orbit Fox Companion (2.8.3), Smart Slider 3 (3.3.18), WooCommerce (3.6.2), WooCommerce Services (1.19.0), WooCommerce Shortcodes (1.0.0), WP Maintenance (5.0.4), WP Post Popup (3.2.4), Yoast SEO (11.1)
    • – Adresse du site : https://www.orcadys.com
    • – Nom de l’hébergeur : Apache

    </div>
     

    Problème(s) rencontré(s) : Toutes mes images ont un “alt”, il sont sur l’inspecteur mais ils n’apparaissent pas sur les hover de la souris sur le site en ligne. pouvez-vous m’aider?

    merci beaucoup

    #2262075
    PhiLyon
    Modérateur
    Maître WordPress
    23948 contributions

    Bonjour.

    La balise alt à quoi ça sert ?

    La balise alt s’ajoute sur les images de votre site.

    Alt est l’abréviation du mot « alternative », la balise alt est donc une balise alternative qui s’affiche lorsque le navigateur n’est pas capable d’afficher l’image sur laquelle elle est ajoutée.

    C’est le cas si par exemple vous désactivez l’affichage des images sur votre navigateur, ou si un problème de connexion empêche leur chargement.

    La balise alt est également très utile pour les personnes malvoyantes, car les navigateurs vocaux (qui lisent à haute voix les pages web) se serviront de son contenu pour décrire l’image que leur utilisateur ne peut pas voir.

    Cela vient d’ici https://www.reussir-mon-ecommerce.fr/balise-alt/

    Ce n’est pas de cela dont tu parles ?

    🙂

    #2262650
    Muchon
    Participant
    Initié WordPress
    9 contributions

    Bonjour PhiLyon,

    Merci pour ton retour à mon problème. Oui, c’est bien de cette balise dont je parle. Je ne travaille pas seule sur ce site, alors je passe derrière celui qui rempli le contenu pour vérifier et en l’occurrence les balises “alt”, sur la page California Mango que j’ai traitée, elles n’apparaissent pas sur les images des produit, alors que, par exemple, elle est bien en hover sur le logo du site (que j’ai mis dans “personnaliser”). Pourtant, avec l’inspecteur du navigateur, elles sont bien présentes. Ai-je fais un réglage quelque part? où cela peut-il être?

    Merci de votre aide

    #2262652
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Bonjour,

    Ce que vous avez sur le logo, qui apparaît “on hover” n’est pas un “ALT” mais un “TITRE” (class=”logoimga” title=”orcadys”).  Les  autres images n’ont pas de titre. Si, dans l’inspecteur, vous en créez un,  par exemple pour l’image 2537 class=”wp-image-2537″ title=”parfum d’ambiance Florilège Robe d’Azur Laboratoire Biotech” (en italique: partie ajoutée), ce texte apparaît bien au survol de la souris. Donc il faut donner des titres à vos images.

    Regardez cet article pour plus d’informations.

     

     

     

    #2262698
    Muchon
    Participant
    Initié WordPress
    9 contributions

    Re,

    toujours est-il que je téléverse une image, je mets un titre, un texte alternatif, une légende, une description Bref! je renseigne tous les champs qui me sont proposés, rien à faire, je n’ai rien au survol… je vais voir dans le css

    Merci

    #2262700
    PhiLyon
    Modérateur
    Maître WordPress
    23948 contributions

    Bonjour.

    Colles ce code dans le fichier functions.php de ton thème enfant

    // ~~~~~~~~~~~~~~~~~~~~~ Add Image Title - Crunchify.com Tips ~~~~~~~~~~~~~~~~~~~~~~~~
    function crunchify_add_image_title( $html, $id ) {
    	$crunchify_attach = get_post($id);
    	if (strpos($html, "title=")) {
        		return $html;
        	}
        	else {
    		$crunchifyTitle = esc_attr($crunchify_attach->post_title);
    		return str_replace('<img', '<img title="' . $crunchifyTitle . '" '  , $html);      
    	}
    }
    add_filter( 'media_send_to_editor', 'crunchify_add_image_title', 15, 2 );
     
    function crunchify_add_image_title_gallery( $content, $id ) {
    	$crunchify_title = get_the_title($id);
    	return str_replace('<a', '<a title="' . esc_attr($crunchify_title) . '" ', $content);
    }	
    add_filter('wp_get_attachment_link', 'crunchify_add_image_title_gallery', 10, 4);

    🙂

    #2262702
    ferman
    Participant
    Maître WordPress
    1364 contributions

    Bizarre: je viens d’essayer et je n’ai eu aucun problème.

    Le code de PhiLyon est bien car il permet de donner des titres automatiquement à toutes les images à venir mais je ne suis pas sûr  pas qu’il permette de revenir sur celles déjà publiées.

    #2264439
    Muchon
    Participant
    Initié WordPress
    9 contributions

    Bonjour Philyon et Ferman,

    Désolée de ne pas avoir donné suite à notre conversation pour cause de déménagement réel. J’ai suivi vos solutions, j’ai fait de nouvelles publication mais rien à faire, toujours pas de texte alternatif, pourtant visible dans l’inspecteur. Je reviendrai sur ce problème plus tard, j’ai maintenant un autre problème, je poste un nouveau sujet.

    Merci à tous et excellente journée

    #2282241
    lowkeyseo
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    Même soucis pour moi, les champs sont bien renseignés mais je n’ai pas de alt qui apparaît dans le code. (cache vidé, extensions désactivés…)

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.