AIDE PAGE SHOP (Créer un compte)

  • WordPress :5.2
  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #2298028
    Shinobishozoku
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle :
    – Version de WordPress : 5.3.2
    – Version de PHP/MySQL : 7.0.20-2~ubuntu14.04.1+deb.sury.org+1 / 5.5.62
    – Thème utilisé : 5th-Avenue Child
    – Thème URI : http://vavenue.lifeis.design/
    – Extensions en place : 5th-Avenue Plugin Core (1.0.2), Autoptimize (2.6.1), Categories to Tags Converter Importer (0.5), Contact Form 7 (5.1.6), Forum_wordpress_fr (4.2), Google Analytics Dashboard for WP (GADWP) (5.3.10), Kirki Toolkit (3.0.34.1), MC4WP: Mailchimp for WordPress (4.7.4), Meta Box (5.2.6), Ninja Popups (4.4.1), Redux Framework (3.6.17), Slider Revolution (5.2.6), Smash Balloon Instagram Feed (2.1.5), TI WooCommerce Wishlist Plugin (1.16.2), W3 Total Cache (0.13.0), WooCommerce (3.9.1), WooCommerce Admin (0.24.0), WooCommerce PDF Invoices (3.0.11), WooCommerce Stripe Gateway (4.3.0), WooCommerce Variation Swatches (1.0.4), WPBakery Page Builder (6.1), WP Cerber Security, Antispam & Malware Scan (8.5.8), WP Mail SMTP (1.8.1), Yoast SEO (13.0)
    – Adresse du site : https://shinobishozoku.fr
    – Nom de l’hébergeur : Apache

    Mon problème :

    Dans la page SHOP de mon site j’aimerai savoir comment activer et désactiver une option, voir en changer l’intitulé.
    Je m’explique, lors de l’affichage de la liste des produits de la page shop (mais aussi de toutes les pages ou il y a une liste de produits), en dessous de chaque photos produits il y a une option qui s’affiche lors du survol, “CHOIX DES OPTIONS” et un icone en COEUR (whislist) en dessous.

    J’aimerai connaitre la méthode pour pouvoir le masquer ou en changé l’intitulé.
    Je vous joints des captures d’écrans pour mieux illustrer cela, une capture état normal et une capture état survol.

    En espérant que quelqu’un puisse m’aider.

    Merci par avance
    Cordialement

    Nino

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2298064
    ferman
    Participant
    Maître WordPress
    4232 contributions

    Bonjour,

    Je pense que le  coeur vient de votre plugin TI woocommerce wishlist. Il doit être possible de l’enlever en désactivant l’extension, ou dans les réglages. Le message  “choix des options” doit aussi venir d’un autre plugin mais je ne sais pas lequel.

    Regardez en priorité s’il n’est pas possible de faire ce que vous voulez depuis les réglages des extensions. Sinon il est possible de masquer avec des CSS.

    Essayez les deux codes suivants à placer dans vos CSS additionnelles. Essayez d’abord sans les !important et ajoutez-les seulement si ça ne fonctionne pas. Cela va cacher le coeur et le texte.

    a.button.product_type_variable.add_to_cart_button {display:none!important;}
    a.tinvwl_add_to_wishlist_button{display:none!important;}

    Si vous voulez modifier le texte sans  le supprimer, ça doit être possible en utilisant un plugin de traduction tel que locotranslate mais il faut savoir d’où vient ce texte (réglage woocommerce ou extension et laquelle)

    #2298937
    Shinobishozoku
    Participant
    Initié WordPress
    4 contributions

    Bonjour Ferman,

    Merci pour ta réponse rapide.

    Je viens d’effectuer tes conseils et j’ai réussi à désactiver l’icone COEUR de la wishlist sous les photos produits dans ma liste de produits.
    En revanche je ne vois toujours pas d’où vient l’option CHOIX DES OPTIONS et comment la désactiver…
    Les lignes de code que tu m’as envoyé sont uniquement pour la l’icone WISHLIST n’est ce pas ?

    Merci par avance

    #2298959
    ferman
    Participant
    Maître WordPress
    4232 contributions

    Bonjour,

    Non, chez moi ça fonctionne pour les deux. Première ligne pour choix des options, deuxième pour wishlist. Voir en pièce jointe: à gauche sans la ligne de code, à droite avec ligne de code. Vous avez bien copié/collé directement (sans mettre avant dans un traitement de texte). Avez-vous laissé le !important?

    Vous pouvez aussi essayer cette variante qui fonctionne aussi chez moi. Autrement je ne vois pas. On parle bien de la page shop?

    a.button.product_type_variable.add_to_cart_button {visibility:hidden!important;}

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2298975
    Shinobishozoku
    Participant
    Initié WordPress
    4 contributions

    On peut se tutoyer ?
    Je n’ai pas essayé la ligne de code.
    Premierement car je pensais que cela concernait que la wishlist que j’ai pu régler dans les réglages du plugins en suivant tes conseils.
    Et deuxièmement je m’y connais pas du tout en code, donc je ne sais pas ou je dois l’écrire ?

     

     

    #2299008
    ferman
    Participant
    Maître WordPress
    4232 contributions

    On peut se tutoyer ?

    Vous pouvez si vous voulez, cela ne me pose aucun problème mais moi je ne tutoie pas (je ne suis pas le seul sur le forum), sauf les très proches; simple question d’habitude.

    Bon, le problème wishlist étant résolu avec le plugin, il reste seulement la deuxième ligne de code. Le plus simple:  depuis votre tableau de bord vous allez dans “apparence->personnaliser” et là il doit y avoir une fenêtre “css additionnelles”. Vous copiez-collez la ligne de code dans cette fenêtre puis  vous publiez. Deuxième possibilité, la plus classique quand on a un thème enfant: toujours depuis le tableau de bord, apparence->éditeur de thème -> onglet “style .css”. Là vous copiez/collez le code à la suite de ce que le fichier  contient déjà, puis vous pressez “mettez à jour le fichier”. Les deux méthodes fonctionnent. Essayez d’enlever le  “!important”. Il ne faut le mettre qu’en dernier ressort.

    Dites-moi si ça fonctionne et quelle méthode vous avez choisie.

    #2299018
    Shinobishozoku
    Participant
    Initié WordPress
    4 contributions

    <span class=”token selector”>J’ai essayé la premiere ligne de code : a<span class=”token class”>.button.product_type_variable.add_to_cart_button</span> </span><span class=”token punctuation”>{</span><span class=”token property”>display</span><span class=”token punctuation”>:</span>none!important<span class=”token punctuation”>;</span><span class=”token punctuation”>}</span>
    Sa fonctionne ! Mais le problème c’est qu’ il y a toujours un état survol qui masque le prix.

    Enfaite avant lors du survol le prix se masque pour faire apparaitre “choix des options”
    La on a bien masqué le “choix des options” mais la fonction masquer le prix lors du survol est toujours active.

    J’ai aussi essayé la deuxième ligne de code : <span class=”token selector”>a<span class=”token class”>.button.product_type_variable.add_to_cart_button</span> </span><span class=”token punctuation”>{</span><span class=”token property”>visibility</span><span class=”token punctuation”>:</span>hidden!important<span class=”token punctuation”>;</span><span class=”token punctuation”>} mais c’est pareille. </span>

    J’ai enlever !important comme conseillé.

    Je suis d’accord sa doit venir d’un plugins mais je ne vois pas lequel j’ai l’impression d’avoir tout farfouiller..

     

     

    #2299021
    ferman
    Participant
    Maître WordPress
    4232 contributions

    Bonjour,

    Vous n’aviez pas parlé du prix qui devait rester visible au survol.  Là  je ne pourrai pas vous aider. Par défaut le prix disparaît. Pour modifier ça il faudrait d’abord savoir d”où il vient. Pas de woocommerce lui même (je n’ai pas ça), à moins que je n’aie pas vu l’option mais j’en doute. Pour tenter de le savoir, il faudrait désactiver les plugins les uns après les autres.

    #2381685
    driingdriing
    Participant
    Initié WordPress
    1 contributions

    Bonjour,

    J’avais le même problème que Shinobishozoku, c’est à dire que sous chaque photo de produit il s’affichait “CHOIX DES OPTIONS” au survol à la place du prix (et sur les produits en rupture de stock cette phrase s’affichait d’office sans qu’il y ait besoin de survoler). J’ai cherché sans succès une solution sur le net, mais après moult essais j’ai fini par en trouver une par moi-même. Trop tard pour que ce soit utile à Shinobishozoku, j’imagine, mais ça aidera peut-être d’autres personnes confrontées à ce problème ?

    Pour supprimer ce message “CHOIX DES OPTIONS” – qui vient du plugin “Extra Product Options” – j’ai ajouté les règles suivantes au CSS (Menu “Apparence -> Personnaliser -> Developer Tools -> Custom CSS Code”, dans le premier champ “Custom CSS”) :

    .woocommerce ul.products li.product:hover .price {
    opacity: 1;
    transform: translateY(0%);
    z-index: 1; }
    .woocommerce .product_type_simple.button {
    display: none; }

    • Cette réponse a été modifiée le il y a 13 minutes par driingdriing.
9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.