Afficher image de mon post (post format) dans le RSS (Créer un compte)

  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #496685
    MoiMM
    Participant
    Chevalier WordPress
    378 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.1.3
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site : http://www.graphikandsound.com

    Problème(s) rencontré(s) :

    Bonjour tout le monde !

    Voilà je viens de refaire mon blog !

    J’utilise pour mes post des post format et le soucis que j’aimerai régler est que les premières images utilisées ne s’affichent pas dans le fil RSS !!!

    Comment résoudre ce soucis ?

    J’ai essayé une methode indiquée ici > http://www.wpbeginner.com/wp-tutorials/how-to-add-custom-post-types-to-your-main-wordpress-rss-feed/

    Mais ça ne fonctionne pas chez moi ! :(

    Si vous avez une idée elle sera la bienvenue !

    Booonnn diiiiii-manche !

    🙂

    #778381
    njaka41
    Participant
    Chevalier WordPress
    212 contributions

    Salut, je suis aller sur ton site “www.graphikandsound.com” et j’aimerais bien faire un site comme le tien. comment tu as fait pour la première page? merci 🙂

    #778382
    njaka41
    Participant
    Chevalier WordPress
    212 contributions

    bonjour, est-ce que

    get_post_types( array( ‘public’ => true ) )

    instead of

    get_post_types()

    t’as aidé ou pas.
    Je suis aussi intéresser par cette réponse merci. 🙂

    #778383
    MoiMM
    Participant
    Chevalier WordPress
    378 contributions

    Salut njaka41 ! 🙂

    Voici le code qui est actuellement dans mon fichier functions.php

    /*———————————————————————————–*/
    /*	Add Post format in RSS
    /*———————————————————————————–*/
    
    function myfeed_request($qv) {
    	if (isset($qv[‘feed’]))
    		$qv[‘post_type’] = get_post_types(array( ‘public’ => true ) );
    	return $qv;
    }
    add_filter(‘request’, ‘myfeed_request’);

    Mais ça ne fonctionne pas ! :(

    #778384
    njaka41
    Participant
    Chevalier WordPress
    212 contributions

    Bonjour, je suis aussi sur le même projet, ton code semble marche bien. Par contre peux tu revérifier ton custom post types

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.