Affichage intempestif de warning sur les pages du blog (Créer un compte)

  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #451617
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.1.3
    – Thème utilisé : Gentle Calm customisé
    – Plugins en place : Polyglot, Spam Karma, ContactForm, etc…
    – Nom de l’hebergeur : Free
    – Adresse du site : http://arkhamdreamer.free.fr

    Problème(s) rencontré(s) :

    Depuis hier, je me retrouve avec 8 lignes de message de type Warning sur toutes les pages du blog qui disent ceci :

    Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /mnt/106/sdb/a/8/arkhamdreamer/wordpress/wp-includes/classes.php on line 95
    
    Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /mnt/106/sdb/a/8/arkhamdreamer/wordpress/wp-includes/classes.php on line 96

    Ce qui évidemment décale toute la mise en page.

    J’ai vérifié mes fichiers de thème et il n’y a pas de caractères bizarres avant ou après les balises et . D’ailleurs si je change de thème, le problème persiste: Cela ne vient donc pas du thème, à priori.

    J’ai réécrit mon fichier .htaccess au cas où il y aurait été “accidentellement” altéré.

    Je penche plutôt pour un problème d’interprétation des permalink car si je reviens aux liens par défaut, le problème disparaît. Mais bien sûr, cela ne me convient pas !!!

    J’ai essayé de mettre à jour la configuration des permalinks en supprimant et recréant ce paramétrage mais le problème se reproduit alors. J’utilise la forme suivante de permalink qui m’a toujours donné satisfaction jusqu’à maintenant : /index.php/%category%/%postname%/

    Quelqu’un a t’il une idée de la direction dans laquelle chercher ?

    Merci d’avance.

    #598199
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Utilises-tu un plugin de smileys?
    http://wordpress.org/support/topic/101850

    #598200
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Xavier : Non, je n’ai pas ce genre de plugin.

    Aaxane : C’est à la ligne 96 de classe.php que se trouve la fonction preg_match appelée. Le fichier n’a pas de problème, c’est la fonction qui renvoie ce message de warning car on ne lui envoie pas ce qu’elle attend. Mais la difficulté est de trouver ce qui est envoyé pour pouvoir comprendre ce qui doit être corrigé. :fouet:

    #598201
    johnnoone
    Membre
    Chevalier WordPress
    140 contributions

    as-tu activé un autre plugin ?

    #598202
    dlo
    Participant
    Maître WordPress
    1850 contributions
    johnnoone wrote:
    as-tu activé un autre plugin ?

    J’ai bien sûr fait le test de désactiver tous les plugins mais le problème persiste. Cela ne semble pas venir de là.

    Je commence sérieusement à sécher! Grrrrrrr !!!! :mad::mad::mad:

    Quelqu’un a une idée géniale ?

    #598203
    dlo
    Participant
    Maître WordPress
    1850 contributions
    Aaxane wrote:
    Je serais curieuse de voir les premières lignes de ton header.

    Il n’y a qu’à demander ! 😉 Et merci de t’intéresser autant à mon problème.

    
    
    
    
    	<meta http-equiv="Content-Type" content="; charset=” />
    	<title>  </title>
    	<meta name="generator" content="WordPress ” /> <!-- leave this for stats please -->
    	
    		@import url(  );

    #598204
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Hélas non, Aaxane ! Cette ligne n’est pas la cause du problème (Même si je l’enlève, le problème persiste :() et c’est elle qui charge la localisation française de mon thème : Elle sert donc à quelque chose.

    Je continue de chercher.

    #598205
    AmO
    Participant
    Maître WordPress
    4449 contributions

    Met à un @ devant la preg ^^

    #598206
    Qwindoo
    Modérateur
    Maître WordPress
    2862 contributions

    Bouh le vilain-crosoftien qui cache ses erreurs :fouet: :D

    #598207
    dlo
    Participant
    Maître WordPress
    1850 contributions

    AmO -> Ta dernière suggestion m’a rappelé quelque chose ! :search: Merci !

    Dans le fichier wp-settings.php, il y un appel à la fonction suivante :

    // Change to E_ALL for development/debugging
    error_reporting(E_ALL ^ E_NOTICE);

    Elle fixe le niveau de reporting des messages d’erreur de PHP.
    Pour ne plus avoir de notification des “Warning” qui viennent s’afficher à l’écran, il suffit de rajouter le code suivant après le code vu ci-dessus :

    // Suppress Warning messages
    $errlvl = error_reporting();
    error_reporting($errlvl & ~E_WARNING);

    Et voilàààà ! :happy:

    Bon, d’accord, cela ne résoud pas la cause de l’apparition de ce message “Warning” mais au moins l’affichage redevient correct.

    Cela peut dépanner en cas de besoin, le temps de trouver ce qui ne va pas.

    Merci à tous pour votre aide ! :wp:

    #598208
    freediver29
    Participant
    Initié WordPress
    17 contributions

    Hey hey même problème…:mad:

    As-tu regardé si ton hébergeur n’avait pas fait de modifs de configuration php, mod_rewrite… ?
    Et es-tu sûr de ton fichier .htaccess aussi ?

    #598209
    freediver29
    Participant
    Initié WordPress
    17 contributions

    Bon et bien j’ai trouvé une explication au problème, mais elle n’est que partielle.
    Le problème intervient dans les permaliens lors d’une définition de ré-écriture d’URL.
    Dès que le terme %category% est renseigné, wordpress demande de mettre à jour le fichier .htaccess afin de définir la nouvelle règle.
    Et là patatra, gros messages d’erreur sur le site.
    Si, au contraire, un autre terme que %category% est renseigné, et qu’aucune règle n’est à renseigner dans le .htaccess, il n’y a plus aucun message d’erreur.

    Un peu étrange comme problème, et comme solution du coup 😕, mais cela fonctionne quand même.😋

    Ciao!

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.