Affichage du lien background (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #2365012
    SylvieS
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle :
    – Version de WordPress : 5.6
    – Version de PHP/MySQL : 5.6.30 / 5.7.17
    – Thème utilisé : Twenty Fifteen
    – Thème URI : https://wordpress.org/themes/twentyfifteen/
    – Extensions en place : Advanced Editor Tools (previously TinyMCE Advanced) (5.6.0), Child Theme Generator (2.2.6.1), Classic Editor (1.6), Font Organizer (2.1.1), Forum_wordpress_fr (4.2), Go Live Update Urls (6.2.2), Google Photos & Picasa Viewer (3.2.3), TablePress (1.12), WP Sitemap Page (1.6.2)
    – Adresse du site : http://127.0.0.1/wordpress
    – Nom de l’hébergeur : Apache/2.4.25 (Win32) PHP/5.6.30

     

    Problème(s) rencontré(s) : Je développe mon site en Local avec Easyphp (depuis très longtemps) et je me suis depuis peu à WordPress. J’arrive à bien migrer de Localhost au site d’hébergement. Je change par l’intermédiaire de requêtes SQL la modification des URL . Tout fonctionne très bien pour les liens de téléchargements, les urls, les images… sauf UNE ! en outre, c’est celle qui doit s’afficher en arrière plan à l’affichage du site.

    Quand je consulte le code source de la page, je constate qu’entre les lignes 201 et 203 que le lien renvoie toujours à localhost :

    <<span class="start-tag">style</span> <span class="attribute-name">type</span>="text/css" <span class="attribute-name">id</span>="custom-background-css">
    <span id="line202"></span>body.custom-background { background-color: #876d91; background-image: url("http://127.0.0.1/wordpress/wp-content/uploads/2021/01/lampes_fig_05.jpg"); background-position: center center; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
    <span id="line203"></span></<span class="end-tag">style</span>>
    Je ne comprends pas pourquoi les requêtes d'Update dans les guid, dans le contenu des pages, les images, etc. ne fonctionne pas.
    J'ai quasiment regardé toutes les lignes du w_post and co, les fichiers PHP et CSS du thème mais je ne trouve pas le fichier qui doit être modifié.
    En vous remerciant pour vos réponses et conseils
    
    #2365019
    mathieu42
    Participant
    Chevalier WordPress
    276 contributions

    regardez dans Apparence -> Personnaliser -> Image d’arrière-plan

    #2365100
    ferman
    Participant
    Maître WordPress
    3516 contributions

    Bonjour,

    les images… sauf UNE ! en outre, c’est celle qui doit s’afficher en arrière plan à l’affichage du site.

    Juste un mot d’explication: les liens des images de fond ne sont pas dans la base de données mais en dur dans les CSS et donc on ne peut pas les modifier par des  requêtes SQL. Par contre elles devraient être visibles dans les fichiers style.css du thème.

    #2365266
    SylvieS
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    J’ai vérifié tous les fichiers css à partir de l’éditeur du thème et je n’ai pas trouvé.

    Je suis preneuse de toute idée pour le nom du fichier où devrait se trouver ce lien.

     

    #2365281
    ferman
    Participant
    Maître WordPress
    3516 contributions

    Bonjour,

    Comme on n’a pas accès à votre site j’ai jeté un coup d’oeil aux démos du thème. Cela ne correspond pas à votre site mais pourra peut-être vous aider. Dans cette démo il y a trois images de fond. Elles sont dans le “visual composer” (wp bakery page builder) intégré au thème(voir pièces-jointes).  Ce doit être assez semblable sur votre site si c’est bien de ça que vous parlez.

    Je pense que le support du thème aurait pu vous renseigner rapidement. Pour un thème payant, il faut toujours contacter  le support.

    • Cette réponse a été modifiée le il y a 2 semaines par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2365289
    SylvieS
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    C’est le thème Twenty Fifteen de WordPress qui est gratuit il me semble.

    Je développe le site (pour une association) dans les pages persos de free (www.sfecag.free.fr).

    En résumé, je souhaite faire venir une image sous la page blanche accueil à la place du fond violet clair : cela fonctionne très bien en localhost (ci-joint) mais pas sur le serveur

    Je peux peut-être insérer un bout de code mais je ne sais pas sur quel fichier interagir ?

    #2365290
    SylvieS
    Participant
    Initié WordPress
    5 contributions
    Cette réponse a été marquée comme privée.
    #2365294
    ferman
    Participant
    Maître WordPress
    3516 contributions

    C’est le thème Twenty Fifteen de WordPress qui est gratuit il me semble.

    Absolument et vraiment désolé pour l’erreur. Vous avez dû comprendre que j’ai mélangé votre sujet avec un autre qui lui utilisait un thème payant (et qui n’a pas ce problème).  Ce genre de confusion n’arrive pas souvent mais ça arrive.

    Bon, je ne suis pas modérateur et ne peux pas voir le message privé. Ce n’est pas grave. Essayez ce code:

    .page-id-9 #page{background-image:url("https://wpfr.net/files/2020/12/computer-hacked-1920x500.jpg");
     background-repeat: round;}

    en changeant bien sûr l’adresse de l’image. Pour le background-repeat il y a plusieurs possibilités. Il faut essayer et choisir une option selon ce que vous voulez faire.

    J’espère que cela vous sera utile. La raison pour laquelle ça fonctionne en local et pas chez l’hébergeur. Peut-être  êtes vous restée avec une adresse en localhost (pas accessible sur le net) alors qu’il faut donner l’adresse de l’image chez l’hébergeur (comme dans le code ci-dessus  pour wpfr).

     

     

    #2365304
    ferman
    Participant
    Maître WordPress
    3516 contributions

    Décidément aujourd’hui ça ne va pas question compréhension. Je crois que l’image que vous voulez n’est pas présente dans votre bibliothèque d’image . On peut mettre la carte en image de fond mais pas celle que vous voulez.

    #2365315
    ferman
    Participant
    Maître WordPress
    3516 contributions

    Bon, cette fois ci je pense que c’est bon. L’image est bien dans le dossier upload et donc si vous mettez ce qui suit dans les css additionnelles ça devrait marcher:

    body.custom-background {
     background-color: #876d91;
     background-image: url("http://sfecag.free.fr/wp-content/uploads/2020/12/lampes_fig_03.png")!important;}"
     background-position: left top;
     background-size: auto;
     background-repeat: repeat;
     background-attachment: scroll;
    }

    Essayez sans le !important mais je pense qu’il est nécessaire. Vous verrez bien. Encore une fois, désolé.

    • Cette réponse a été modifiée le il y a 2 semaines par ferman.
    #2365324
    SylvieS
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Le code a fonctionné  tel que vous l’avez indiqué (avec !important) ! J’ai ouvert le site sur un autre ordinateur pour être sûre.

    Je vous remercie infiniment pour votre aide

    #2365326
    ferman
    Participant
    Maître WordPress
    3516 contributions

    Bonjour,

    Je vous remercie infiniment pour votre aide

    Mais je vous en prie, avec plaisir. Dans le code il y a des guillemets en trop; ce n’est pas du tout grave mais enlevez-les quand même car ils ne servent à rien.

    …png”)!important;} enlevez les derniers pour donner…png”)!important;}

    Et merci de passer le sujet en “résolu”.

     

    • Cette réponse a été modifiée le il y a 1 semaine et 6 jours par ferman.
12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.